Bug 1378428 - openstack-swift-proxy.service fails to start in IPv6 envrionment
Summary: openstack-swift-proxy.service fails to start in IPv6 envrionment
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-tripleo
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: 10.0 (Newton)
Assignee: Emilien Macchi
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On: 1390010
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-22 11:51 UTC by Marius Cornea
Modified: 2016-12-14 16:03 UTC (History)
18 users (show)

Fixed In Version: puppet-tripleo-5.1.0-0.20160921213932.ceccbfd.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 16:03:56 UTC


Attachments (Terms of Use)
proxy-server.conf (1.95 KB, text/plain)
2016-09-22 11:51 UTC, Marius Cornea
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 372734 None None None 2016-09-22 16:51:10 UTC
OpenStack gerrit 372903 None None None 2016-09-22 16:51:51 UTC

Description Marius Cornea 2016-09-22 11:51:11 UTC
Created attachment 1203693 [details]
proxy-server.conf

Description of problem:
openstack-swift-proxy.service fails to start in IPv6 envrionment:

swift-proxy-server[4552]: Traceback (most recent call last):
swift-proxy-server[4552]: File "/usr/bin/swift-proxy-server", line 23, in <module>
swift-proxy-server[4552]: sys.exit(run_wsgi(conf_file, 'proxy-server', **options))
swift-proxy-server[4552]: File "/usr/lib/python2.7/site-packages/swift/common/wsgi.py", line 908, in run_wsgi
swift-proxy-server[4552]: loadapp(conf_path, global_conf=global_conf)
swift-proxy-server[4552]: File "/usr/lib/python2.7/site-packages/swift/common/wsgi.py", line 396, in loadapp
swift-proxy-server[4552]: return ctx.create()
swift-proxy-server[4552]: File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 710, in create
swift-proxy-server[4552]: return self.object_type.invoke(self)
swift-proxy-server[4552]: File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 207, in invoke
swift-proxy-server[4552]: app = filter(app)
swift-proxy-server[4552]: File "/usr/lib/python2.7/site-packages/swift/common/middleware/memcache.py", line 117, in cache_filter
swift-proxy-server[4552]: return MemcacheMiddleware(app, conf)
swift-proxy-server[4552]: File "/usr/lib/python2.7/site-packages/swift/common/middleware/memcache.py", line 105, in __init__
swift-proxy-server[4552]: max_conns=max_conns)
swift-proxy-server[4552]: File "/usr/lib/python2.7/site-packages/swift/common/memcached.py", line 156, in __init__
swift-proxy-server[4552]: for server in servers))
swift-proxy-server[4552]: File "/usr/lib/python2.7/site-packages/swift/common/memcached.py", line 156, in <genexpr>
swift-proxy-server[4552]: for server in servers))
swift-proxy-server[4552]: File "/usr/lib/python2.7/site-packages/swift/common/memcached.py", line 115, in __init__
swift-proxy-server[4552]: server, DEFAULT_MEMCACHED_PORT)
swift-proxy-server[4552]: File "/usr/lib/python2.7/site-packages/swift/common/utils.py", line 2098, in parse_socket_string
swift-proxy-server[4552]: raise ValueError("IPv6 addresses must be between '[]'")
swift-proxy-server[4552]: ValueError: IPv6 addresses must be between '[]'


Version-Release number of selected component (if applicable):
openstack-puppet-modules-9.0.0-0.20160802183056.8c758d6.el7ost.noarch
openstack-heat-templates-0.0.1-0.20160906185549.ac2db55.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy IPv6 enabled overcloud 
2. Check swift-proxy-server status

Actual results:
● openstack-swift-proxy.service                                               loaded failed failed    OpenStack Object Storage (swift) - Proxy Server


Expected results:
Service is running

Additional info:
Attaching /etc/swift/proxy-server.conf

Comment 2 Marius Cornea 2016-09-22 11:55:32 UTC
Adding the memcache_servers addresses in square brackets made it work:

memcache_servers = [fd00:fd00:fd00:2000::18]:11211,[fd00:fd00:fd00:2000::11]:11211,[fd00:fd00:fd00:2000::1c]:11211

Comment 3 James Slagle 2016-09-22 16:27:05 UTC
emilien, can you take a look at this one?

Comment 5 James Slagle 2016-10-03 14:36:41 UTC
i believe this has been built downstream. can you confirm and if so, set the Fixed in Version and move the bug to MODIFIED?

Comment 20 errata-xmlrpc 2016-12-14 16:03:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.