Bug 1378436 - build: python-ctypes no longer exists in Fedora Rawhide
Summary: build: python-ctypes no longer exists in Fedora Rawhide
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: build
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kaleb KEITHLEY
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1538258
TreeView+ depends on / blocked
 
Reported: 2016-09-22 12:15 UTC by Kaleb KEITHLEY
Modified: 2018-01-24 17:52 UTC (History)
4 users (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1538258 (view as bug list)
Environment:
Last Closed: 2017-03-06 17:27:39 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1412227 0 unspecified CLOSED build/packaging: Fedora rawhide's python has obsoleted the python-ctypes package 2021-02-22 00:41:40 UTC

Internal Links: 1412227

Description Kaleb KEITHLEY 2016-09-22 12:15:39 UTC
Description of problem:

Was notified by cstratak@redhat that python-ctypes is now in stdlib. (python stdlib?)

python packaging has been using a Virtual Provides of python-ctypes in Rawhide thus far, and that will eventually go away. In the mean time python-ctypes should be removed from the glusterfs.spec file

(Also put on notice that eventually python should become python2 in the .spec file.)


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2016-09-22 12:24:56 UTC
REVIEW: http://review.gluster.org/15546 (build: python-ctypes no longer exists in Fedora Rawhide) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 2 Charalampos Stratakis 2016-09-22 13:58:24 UTC
Also please note that python already virtually provides the python2 name as well (and when python will become python2, it will also virtually provide the python name).

The current list of --provides by python in rawhide:

python = 2.7.12-6.fc26
python(abi) = 2.7
python(x86-32) = 2.7.12-6.fc26
python(x86-64) = 2.7.12-6.fc26
python-abi = 2.7
python-argparse = 2.7.12-6.fc26
python-ctypes = 1.0.1
python-hashlib = 20081120
python-sqlite = 2.3.2
python-uuid = 1.31
python2 = 2.7.12

Comment 3 Worker Ant 2016-09-22 14:40:36 UTC
REVIEW: http://review.gluster.org/15546 (build: python-ctypes no longer exists in Fedora Rawhide) posted (#2) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 4 Worker Ant 2016-09-23 14:32:36 UTC
COMMIT: http://review.gluster.org/15546 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 85f7a86730db229ce264f43d224465a76202d270
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Thu Sep 22 08:22:50 2016 -0400

    build: python-ctypes no longer exists in Fedora Rawhide
    
    Python packaging in Rawhide has a Virtual Provides of python-ctypes
    but that will be removed soon
    
    Change-Id: I353f7fcbff35dfbfb1a726c7608eef721976453d
    BUG: 1378436
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/15546
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Aravinda VK <avishwan@redhat.com>

Comment 5 Shyamsundar 2017-03-06 17:27:39 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.