Bug 1378492 - warning messages seen in glusterd logs for each 'gluster volume status' command
Summary: warning messages seen in glusterd logs for each 'gluster volume status' command
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: mainline
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Atin Mukherjee
QA Contact:
URL:
Whiteboard:
Depends On: 1378484
Blocks: 1379284 1379287
TreeView+ depends on / blocked
 
Reported: 2016-09-22 14:27 UTC by Atin Mukherjee
Modified: 2017-03-06 17:27 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1378484
: 1379284 1379287 (view as bug list)
Environment:
Last Closed: 2017-03-06 17:27:39 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Atin Mukherjee 2016-09-22 14:27:20 UTC
+++ This bug was initially created as a clone of Bug #1378484 +++

Description of problem:
-----------------------
Executing the 'gluster volume status' generates the warning message in glusterd.log.

The warning message goes like this :
<snip>
 "W [MSGID: 106217] [glusterd-op-sm.c:4706:glusterd_op_modify_op_ctx] 0-management: Failed uuid to hostname conversion"
</snip>

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
Layered installation - RHGS 3.2.0 (interim build - glusterfs-3.8.4-1.el7rhgs )
on RHEL 7.2

How reproducible:
-----------------
Always

Steps to Reproduce:
-------------------
1. Create any type of volume 
2. Start the volume
3. Execute 'gluster volume status'

Actual results:
---------------
Warning message seen in the glusterd.log

Expected results:
-----------------
Clean pass of the 'gluster volume status' command

Additional info:
----------------
The error snippet :
<snip>
[2016-09-22 09:21:38.536538] I [MSGID: 106499] [glusterd-handler.c:4360:__glusterd_handle_status_volume] 0-management: Received status volume req for volume test
[2016-09-22 09:21:38.537509] W [MSGID: 106217] [glusterd-op-sm.c:4706:glusterd_op_modify_op_ctx] 0-management: Failed uuid to hostname conversion
[2016-09-22 09:21:38.537533] W [MSGID: 106387] [glusterd-op-sm.c:4812:glusterd_op_modify_op_ctx] 0-management: op_ctx modification failed
</snip>

Comment 1 Worker Ant 2016-09-22 14:58:50 UTC
REVIEW: http://review.gluster.org/15547 (glusterd: fix return val in glusterd_op_modify_op_ctx ()) posted (#1) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 2 Atin Mukherjee 2016-09-22 15:13:21 UTC
RCA:

As gNFS has been disabled by default, glusterd_op_volume_dict_uuid_to_hostname () has started misbehaving given its idx_max has been now reduced by one process. The issue in this function is although dict get failures are ignored but ret codes are not reset back to 0.

Comment 3 Worker Ant 2016-09-22 15:15:58 UTC
REVIEW: http://review.gluster.org/15547 (glusterd: fix return val in glusterd_op_volume_dict_uuid_to_hostname ()) posted (#2) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 4 Worker Ant 2016-09-26 09:15:59 UTC
COMMIT: http://review.gluster.org/15547 committed in master by Kaushal M (kaushal@redhat.com) 
------
commit 3bf8f05a8a0eccd723a9478a5c925d099a145a1a
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Thu Sep 22 20:04:12 2016 +0530

    glusterd: fix return val in glusterd_op_volume_dict_uuid_to_hostname ()
    
    glusterd_op_volume_dict_uuid_to_hostname () ignores few dict_get_str failures
    but doesn't reset the ret value to 0.
    
    Reproducer steps:
    1. Configure a volume and start it (gNFS has to be disabled)
    2. gluster volume status
    
    An warning log is observed with:
    [MSGID: 106217] [glusterd-op-sm.c:4706:glusterd_op_modify_op_ctx] 0-management:
    Failed uuid to hostname conversion
    [2016-09-22 09:21:38.537533] W [MSGID: 106387]
    [glusterd-op-sm.c:4812:glusterd_op_modify_op_ctx] 0-management: op_ctx
    modification failed
    
    Change-Id: I1d3aa79304d83a9d5db1b7198773d8c2780e24a9
    BUG: 1378492
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: http://review.gluster.org/15547
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Samikshan Bairagya <samikshan@gmail.com>
    Reviewed-by: Kaushal M <kaushal@redhat.com>

Comment 5 Shyamsundar 2017-03-06 17:27:39 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.