Bug 1378558 - Can't install host from synced content
Summary: Can't install host from synced content
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: Unspecified
Assignee: Partha Aji
QA Contact: Lukáš Hellebrandt
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-22 18:26 UTC by Perry Gagne
Modified: 2019-09-26 14:39 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-21 17:31:35 UTC
Target Upstream Version:


Attachments (Terms of Use)
Create Host Group Main Page (140.49 KB, image/png)
2017-10-03 05:31 UTC, Partha Aji
no flags Details
Create HG With the Synced Content radio (108.88 KB, image/png)
2017-10-03 05:32 UTC, Partha Aji
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 16480 0 Normal Closed Unable to select medium on New Hosts page 2021-02-08 18:39:31 UTC
Foreman Issue Tracker 21185 0 High Closed New Host Synced Content Radio Button disabled 2021-02-08 18:39:31 UTC

Description Perry Gagne 2016-09-22 18:26:36 UTC
Description of problem:
W

Version-Release number of selected component (if applicable):
6.3 snap 1

How reproducible: Every time


Steps to Reproduce:
1. Added kickstart repos, synced products, added content views. With RHEL 7.2 
2. Create a new host group
3. Select x86_64 arch

Actual results:
Cannot select "Sync Content" for install media

Expected results:
Should be able to select sync content and install from kickstart. 


Additional info:
 "Operating Systems-> Redhat 7.2 -> installation media" shows "None found".

Comment 2 Bryan Kearney 2016-09-22 20:20:19 UTC
Upstream bug assigned to paji@redhat.com

Comment 3 Bryan Kearney 2016-09-22 20:20:21 UTC
Upstream bug component is WebUI

Comment 4 Bryan Kearney 2016-09-22 20:20:24 UTC
Upstream bug assigned to paji@redhat.com

Comment 5 Bryan Kearney 2016-10-14 00:19:24 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/16480 has been resolved.

Comment 6 Perry Gagne 2017-09-18 19:03:13 UTC
Lukas is there a reason you assigned yourself this bug or can i take it back?

Comment 7 Lukáš Hellebrandt 2017-09-19 08:28:56 UTC
I was assigning random Sat6 bugs that don't have any QA contact to work on them. If you want to work on this one, feel free to take it.

Comment 8 Lukáš Hellebrandt 2017-09-22 14:00:53 UTC
FailedQA with Sat6.3 snap 16.

This is still not fixed. After syncing RHEL7.4 Server and Kickstart, the "Synced Content" radion button is still not selectable in Configure->Host Groups->New Host Group->Operating System->x86_64->RHEL7.4. Furthermore, the installation media is not listed in Hosts->Installation Media (which is OK, according to [1]). The same for RHEL7.2. In Sat6.2, the Installation Media is listed but the radio button still does not work.

[1] https://access.redhat.com/solutions/2578041

Comment 11 Partha Aji 2017-10-03 05:30:27 UTC
Hmm ok I checked your satellite but I see synced content when creating Host group for rhel 7.4 (check the attached screen shots). Basically you need to be selecting
1) Lifecycle Env
2) CV
3) Content Source
4) OS
5) Arch

Wondering if I mm missing something in the steps here

Comment 12 Partha Aji 2017-10-03 05:31:13 UTC
Created attachment 1333482 [details]
Create Host Group Main Page

Comment 13 Partha Aji 2017-10-03 05:32:08 UTC
Created attachment 1333483 [details]
Create HG With the Synced Content radio

Comment 14 Lukáš Hellebrandt 2017-10-03 08:58:01 UTC
So, the thing is I did it in different order: First, I selected arch and OS, then I switched to the first tab, selected LE, CV and CS, and switched back. Then, the synced content wasn't there. I believe it's still a bug?

Comment 15 Partha Aji 2017-10-03 22:28:56 UTC
Creating a new issue on this.
The Bug steps should be more along

1) Configure->Host Groups->New Host Group
2) Change the Arch and OS in the OS Tab
3) Set  the LCE, CV and Content Source
4) Go back to the OS tab and notice that the synced content radio is still disable even though there is a Bootable Kickstart Distribution synced for that Operating System.

Comment 16 Partha Aji 2017-10-03 22:31:29 UTC
Created redmine issue http://projects.theforeman.org/issues/21185 from this bug

Comment 18 Lukáš Hellebrandt 2017-11-01 09:39:47 UTC
Verified with Sat6.3 snap 22.

Used reproducers from OP and from comment 15 and didn't hit the issue. Synced content can be selected properly.

Comment 19 Bryan Kearney 2018-02-21 17:31:35 UTC
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA.

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2018:0336


Note You need to log in before you can comment on or make changes to this bug.