Bug 137866 - Install does not recognize Adaptec 2400A Raid card
Install does not recognize Adaptec 2400A Raid card
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-02 08:35 EST by Sergey Shanygin
Modified: 2015-01-04 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-02 20:20:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sergey Shanygin 2004-11-02 08:35:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3)
Gecko/20041026 Firefox/1.0RC1

Description of problem:
Adaptec 2400A raid with latest bios (v001.62 2002/11/06) is not
recognized. Same problem with FC2. 

FC1 installed and worked just fine...

Starting install -> "No hard drives have been found... would you like
to select drivers now?" -> The following devices have been found on
your system ..I2O block device driver (i2o_block)-> Selecting that,
pressing Done, graphical part starts.

Select language, keyboard, coming to Disk partitioning, select
automatically (does not matter which)-> Message box  "An error has
occured - no valid devices were found on which to create new file
systems. Please check your hardware for the cause of this problem"

Pressing OK shuts down the installation.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start the install from CD, follow prompts.
2.
3.
    

Actual Results:  RAID is not recognized, installation shutdowns.

Expected Results:  Install, just as it worked with FC1

Additional info:

Computer - Dell PowerEdge 600SC, 512RAM, Raid 5 with 3*200GB
Comment 1 Ivo Sarak 2004-12-26 19:09:29 EST
Same here - the Adaptec 2400A is found, but array attached to it is not.

lspci:
[root@ragana ~]# lspci
00:00.0 Host bridge: VIA Technologies, Inc. VT8385 [K8T800 AGP] Host
Bridge (rev 01)
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI bridge [K8T800
South]
00:08.0 Ethernet controller: 3Com Corporation 3c940 10/100/1000Base-T
[Marvell] (rev 12)
00:0a.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado]
(rev 78)
00:0b.0 PCI bridge: Adaptec (formerly DPT) PCI Bridge (rev 02)
00:0b.1 I2O: Adaptec (formerly DPT) SmartRAID V Controller (rev 02)
00:0e.0 RAID bus controller: Silicon Image, Inc. (formerly CMD
Technology Inc) SiI 3114 [SATALink/SATARaid] Serial ATA Controller
(rev 02)
00:0f.0 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge
[KT600/K8T800 South]
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8
[Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8
[Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8
[Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8
[Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: ATI Technologies Inc Rage 128 Pro
Ultra TF
[root@ragana ~]#

[root@ragana ~]# fdisk /dev/sda

Unable to open /dev/sda
[root@ragana ~]#
Comment 2 Ivo Sarak 2004-12-27 13:52:24 EST
Fixed. I found the drive under /dev/i2o/hda.
Comment 3 Dave Jones 2005-07-15 15:39:59 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 4 Dave Jones 2005-10-02 20:20:45 EDT
This bug has been automatically closed as part of a mass update.
It had been in NEEDINFO state since July 2005.
If this bug still exists in current errata kernels, please reopen this bug.

There are a large number of inactive bugs in the database, and this is the only
way to purge them.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.