Bug 13787 - kernel-2.2.16-3 megaraid driver fails
kernel-2.2.16-3 megaraid driver fails
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-12 09:43 EDT by djschaap
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-22 14:15:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description djschaap 2000-07-12 09:43:54 EDT
I've got a Dell PowerEdge 4300 system (approx. 1 year old) with a megaraid
controller.  Attempting to load the megaraid driver (v1b08b) under this
kernel (either UP or SMP) bombs out, leaving the system to finish the
ramdisk boot, only to fail as it tries to mount the root partition (which
is on the megaraid).

When the module fails, it prints a dozen lines or so, including something
about a signal 11 (IIRC -- we were in a real time crunch this morning.  I
should be able to get the exact error message within a few days if it would
help).

Kernel 2.2.14-5.0 (megaraid v107 driver) works fine.
Comment 1 Michael K. Johnson 2000-08-04 16:38:12 EDT
Make sure you have the latest firmware for the megaraid
controller.
Comment 2 Alan Cox 2000-08-22 12:26:24 EDT
Did this fix it ?
Comment 3 djschaap 2000-08-22 14:11:58 EDT
I haven't had a chance to try it.  And now that classes have started for the
semester, Christmas may be the earliest chance we get to experiment on either of
those 2 servers.

Go ahead and mark the bug resolved if you'd like.  Sorry I can't do any better. 
:-(
Comment 4 djschaap 2000-08-22 14:15:17 EDT
(Additional info I forgot above...)

I was able to get the kernel-2.2.16-8 package to work by removing the megaraid
patch from the SPEC file and rebuilding the RPM.  (I also added in NFSv3
patches, which have been working fine.)  This kernel has been running reliably
for several weeks now.
Comment 5 Michael K. Johnson 2000-08-22 14:56:14 EDT
I'm going to mark it resolved, because we *expect* oopses on the
old megaraid firmware.

If you get an oops with the new driver but not with the old driver,
I understand that you might be in danger of file corruption because
of a bug in the old firmware.  FYI.

Note You need to log in before you can comment on or make changes to this bug.