Bug 1378742 - create manpage for pcsd
Summary: create manpage for pcsd
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pcs
Version: 7.3
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: rc
: ---
Assignee: Ondrej Mular
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
Keywords:
: 1318656 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-23 08:46 UTC by Tomas Jelinek
Modified: 2017-08-01 18:22 UTC (History)
7 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-08-01 18:22:57 UTC


Attachments (Terms of Use)
proposed fix (11.06 KB, patch)
2017-02-23 11:43 UTC, Tomas Jelinek
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1958 normal SHIPPED_LIVE pcs bug fix and enhancement update 2017-08-01 18:09:47 UTC
Red Hat Bugzilla 1315627 None None None Never
Red Hat Bugzilla 1318656 None None None Never

Internal Trackers: 1315627 1318656

Description Tomas Jelinek 2016-09-23 08:46:09 UTC
We need to have a description of environment variables (/etc/sysconfig/pcsd and others like http_proxy) and config files (/var/lib/pcsd/*) recognized and used by pcsd. This should preferably go to its own manpage not to complicate the pcs manpage which is already huge.

Comment 1 Tomas Jelinek 2016-10-26 13:15:51 UTC
From duplicate bz1318656:

Radek Steiger 2016-03-17 09:06:57 EDT

PCS daemon supports reading several various environmental variables that are usually set via initscript or systemd through /etc/sysconfig/pcsd, but are not documented anywhere at this point.

So far we expose following ones in /etc/sysconfig/pcsd and should mention them in man pages:

PCSD_DEBUG
RACK_ENV
DISABLE_GUI

Ideally, we should provide a general description of the supported ENV variables without being tied to /etc/sysconfig, because a user might want to set these in other ways (and also other distributions might use different approach than what we do in RHEL).

We might consider other ENV variables that pcsd already understands, but most of them are for internal use only.

Comment 2 Tomas Jelinek 2016-10-26 13:16:10 UTC
*** Bug 1318656 has been marked as a duplicate of this bug. ***

Comment 5 Tomas Jelinek 2017-02-23 11:43 UTC
Created attachment 1256880 [details]
proposed fix

Comment 6 Ivan Devat 2017-04-10 15:50:48 UTC
After Fix:

[vm-rhel72-1 ~] $ rpm -q pcs
pcs-0.9.157-1.el7.x86_64

[vm-rhel72-1 ~] $ man pcsd
[vm-rhel72-1 ~] $ echo $?
0

Comment 9 errata-xmlrpc 2017-08-01 18:22:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1958


Note You need to log in before you can comment on or make changes to this bug.