Bug 1378853 - instack-virt-setup fails on grub2-tools dependency issue
Summary: instack-virt-setup fails on grub2-tools dependency issue
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: diskimage-builder
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 10.0 (Newton)
Assignee: Jiri Stransky
QA Contact: Sergii Nozhka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-23 11:24 UTC by Jiri Stransky
Modified: 2016-12-14 16:04 UTC (History)
10 users (show)

Fixed In Version: diskimage-builder-1.21.0-3.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 16:04:42 UTC


Attachments (Terms of Use)
Verification output of the "instack-virt-setup" command (6.23 KB, application/x-gzip)
2016-11-03 11:19 UTC, Sergii Nozhka
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
RDO 3360 None None None 2016-10-19 13:23:24 UTC
OpenStack gerrit 375430 None None None 2016-09-23 12:18:35 UTC
Launchpad 1627000 None None None 2016-09-23 12:08:43 UTC

Description Jiri Stransky 2016-09-23 11:24:32 UTC
Description of problem:

instack-virt-setup fails with

+ install_grub2
+ '[' -f /tmp/grub/install ']'
+ source /tmp/grub/install
++ rpm -i /tmp/grub/grub2-2.02-0.41.el7.x86_64.rpm
warning: /tmp/grub/grub2-2.02-0.41.el7.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID f21541eb: NOKEY
error: Failed dependencies:
        grub2-tools = 1:2.02-0.41.el7 is needed by grub2-1:2.02-0.41.el7.x86_64


# rpm -q diskimage-builder
diskimage-builder-1.18.2-0.20160802165621.e884309.el7ost.noarch

Comment 1 Dmitry Tantsur 2016-10-17 08:34:25 UTC
Hi Jiri! The patch has merged upstream, could you please backport it or ask for DIB rebase?

Comment 3 Jiri Stransky 2016-10-17 15:25:05 UTC
In the meantime, to have a workaround at least for development purposes, here's a twoliner one can run before instack-virt-setup and before building overcloud images:

https://paste.fedoraproject.org/453957/14767178/raw/

Comment 8 Jiri Stransky 2016-10-18 09:47:36 UTC
Discussed it with Haikel, RDO builds from upstream releases rather than using DLRN promote at this point, we agreed to make an RDO packaging backport, i posted the patch here: https://review.rdoproject.org/r/#/c/3360/

Comment 11 Sergii Nozhka 2016-11-03 11:19:27 UTC
Created attachment 1216932 [details]
Verification output of the "instack-virt-setup" command

Comment 12 Sergii Nozhka 2016-11-03 11:21:35 UTC
The issue not reproduced with diskimage-builder-1.21.0-4.el7ost.noarch,
instack-virt-setup command executed successfully, please refer attachment 1216932 [details] for details.

Comment 15 errata-xmlrpc 2016-12-14 16:04:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.