Bug 1378899 - osp director provider not showing cpu stats for nodes
Summary: osp director provider not showing cpu stats for nodes
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.6.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: GA
: 5.7.0
Assignee: Marek Aufart
QA Contact: Dave Johnson
URL:
Whiteboard: openstack:infra:host
Depends On:
Blocks: 1410604
TreeView+ depends on / blocked
 
Reported: 2016-09-23 13:21 UTC by Colin Arnott
Modified: 2020-07-16 08:55 UTC (History)
11 users (show)

Fixed In Version: 5.7.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1410604 (view as bug list)
Environment:
Last Closed: 2018-09-20 11:54:56 UTC
Category: ---
Cloudforms Team: Openstack
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0012 0 normal SHIPPED_LIVE CFME 5.7.0 bug fixes and enhancement update 2017-01-04 17:50:36 UTC

Description Colin Arnott 2016-09-23 13:21:46 UTC
Description of problem:
when I connect osp director as an infra provider, I show ram information for my nodes, but nothing for their cpu information

Version-Release number of selected component (if applicable):
cfme-5.6.1.2

How reproducible:
this env: reliable
lab: (no over/undercloud env setup)

Steps to Reproduce:
0. setup over/undercloud
1. add undercloud as infra provider
2. setup node credentials and validate
3. preform ems refresh

Actual results:
see pending sceenshot

Expected results:
see cpu and ram info for all nodes

Additional info:
logs pending too

Comment 5 Tzu-Mainn Chen 2016-11-03 19:18:26 UTC
should be fixed by https://github.com/ManageIQ/manageiq/pull/8466

Comment 7 Ronnie Rasouli 2016-11-13 12:41:31 UTC
verified on 5.7.0.10 by automation run test_host_memory

Comment 9 Jeffrey Cutter 2016-11-29 17:04:10 UTC
(In reply to Ronnie Rasouli from comment #7)
> verified on 5.7.0.10 by automation run test_host_memory

Does test_host_memory verify host CPU utilization stats?

I have a test appliance running 5.7.0.10-beta3.20161109111947_9a61b18 which is getting memory utilization but still not CPU.

Comment 11 errata-xmlrpc 2017-01-04 13:01:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0012.html

Comment 16 Richard Su 2017-02-27 20:15:49 UTC
Yes that is correct, the CPU information comes from Ironic introspection data, not ceilometer.

To verify that the data is present, find the uuid of the node in question:

openstack baremetal node list

Then check the introspection data has been saved as extra data in Swift:

openstack baremetal node show <uuid>

The extra field should read something like:

{u'hardware_swift_object': u'extra_hardware-9bb51068-9b8a-4ff9-b6e7-09aba946acba'}  

If it is empty, check if the node has been introspected:

openstack baremetal introspection status <uuid>

The "finished" field should read "True" and the "error" field should read "None".

If it reads False or has an error, then the node needs to be introspected again.

Comment 18 Richard Su 2017-03-01 21:40:39 UTC
@mydoyer, "ironic node show" is the equivalent command. Sounds like you might be using an older version of OpenStack. Which version of OSP is the customer using? The OpenStack environment needs to have the ironic-inspector/baremetal-introspection service deployed since CFME, starting with 4.2, fetches introspection data from that service instead of reading from Swift. I believe reading from Swift was broken, hence this BZ.

Comment 20 Richard Su 2017-05-22 21:08:08 UTC
@myoder. With OSP8, the inspection service is available but not registered with keystone. Try registering it with keystone and then see if the introspected data flows in.

To register the service, on the undercloud node, substitute IP address if appropriate:
openstack service create --name ironic-inspector --description "OpenStack Introspection" baremetal-introspection
openstack endpoint create --region regionOne ironic-inspector --publicurl http://192.0.2.1:5050/v1 --internalurl http://192.0.2.1:5050/v1 --adminurl http://192.0.2.1:5050/v1

Comment 22 Josh Carter 2018-09-20 11:54:56 UTC
Bug Closure

Dear customer, 

The CloudForms team is reviewing the current CloudForms Bug(defect) backlog in order to target engineering efforts. We are closing any bugs for versions that no longer have an active errata stream or that have hit their age limit. We are committing to better management of the backlog as we move forward. If you have an bug that you are still able to reproduce on a current version of CloudForms please open a new bug. 

If you have any concerns about this, please let us know.

Thanks and regards!


Note You need to log in before you can comment on or make changes to this bug.