Bug 1378933 - Certificate subject missing from the API
Summary: Certificate subject missing from the API
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt
Version: 4.0.4.2
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: ovirt-4.0.5
: 4.0.5
Assignee: Juan Hernández
QA Contact: Israel Pinto
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-23 14:29 UTC by Filip Krepinsky
Modified: 2017-01-18 07:36 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-18 07:36:56 UTC
oVirt Team: Virt
juan.hernandez: ovirt-4.0.z?
rule-engine: blocker?
rule-engine: planning_ack?
michal.skrivanek: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 64467 0 None None None 2016-09-28 08:13:29 UTC
oVirt gerrit 64925 0 None MERGED core: Fix "succeeded" flag when retriving VM certificate 2016-09-28 14:26:33 UTC

Description Filip Krepinsky 2016-09-23 14:29:37 UTC
Description of problem:
There isn't certificate subject under vms/{vmId} in the display node. It isn't accessible even under vms/{vmId}/graphicsconsoles.

The functionality is needed for the moVirt client to connect to the console. 

Version-Release number of selected component (if applicable):
Tried in 4.0.4.2 and 4.1.0

Expected results:
There should be a way to get certificate subject with the API

old way in 3.6:
<vm>
    <display>
        <certificate>
            <subject/>
        </certificate>
    </display>
</vm>

Comment 1 Red Hat Bugzilla Rules Engine 2016-09-26 13:49:16 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 2 Juan Hernández 2016-09-26 13:52:04 UTC
While investigating the issue I found that the problem isn't in the API, but in the backend command. As the fix is simple, I am taking the bug.

Comment 3 Juan Hernández 2016-10-06 10:32:45 UTC
The fix for this bug wasn't included in the first 4.0.5 build, so moving back to MODIFIED.

Comment 4 Israel Pinto 2016-10-26 06:38:02 UTC
Verify with:
Engine: Red Hat Virtualization Manager Version: 4.0.5.2-0.2.el7ev
Host:
OS Version:RHEL - 7.3 - 6.el7
OS Description:Red Hat Enterprise Linux Server 7.3 Beta (Maipo)
Kernel Version:3.10.0 - 510.el7.x86_64
KVM Version:2.6.0 - 27.el7
LIBVIRT Version:libvirt-2.0.0-10.el7
VDSM Version:vdsm-4.18.13-1.el7ev
SPICE Version:0.12.4 - 19.el7

Steps:
1. Start VM
2. Check display element via REST
Results:
<display>
<address>10.35.117.88</address>
<allow_override>false</allow_override>
<certificate>
<subject>
O=scl.lab.tlv.redhat.com,CN=seal08.qa.lab.tlv.redhat.com
</subject>
</certificate>
<copy_paste_enabled>true</copy_paste_enabled>
<disconnect_action>LOCK_SCREEN</disconnect_action>
<file_transfer_enabled>true</file_transfer_enabled>
<monitors>1</monitors>
<secure_port>5902</secure_port>
<single_qxl_pci>false</single_qxl_pci>
<smartcard_enabled>false</smartcard_enabled>
<type>spice</type>
</display>


Note You need to log in before you can comment on or make changes to this bug.