Bug 1379098 - [Regression] Gnome-shell crashes on switching back from tty ([abrt] gnome-shell: wl_resource_post_event(): gnome-shell killed by SIGSEGV)
Summary: [Regression] Gnome-shell crashes on switching back from tty ([abrt] gnome-she...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mutter
Version: 25
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:10196caf7ed67ee7e348a4e29c5...
Keywords:
Depends On:
Blocks: WaylandRelated F25FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2016-09-24 22:45 UTC by Christian Stadelmann
Modified: 2019-01-27 04:48 UTC (History)
12 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-10-23 22:52:52 UTC


Attachments (Terms of Use)
File: backtrace (48.90 KB, text/plain)
2016-09-24 22:45 UTC, Christian Stadelmann
no flags Details
File: core_backtrace (4.21 KB, text/plain)
2016-09-24 22:45 UTC, Christian Stadelmann
no flags Details
File: dso_list (25.50 KB, text/plain)
2016-09-24 22:45 UTC, Christian Stadelmann
no flags Details
File: limits (1.29 KB, text/plain)
2016-09-24 22:45 UTC, Christian Stadelmann
no flags Details
File: namespaces (102 bytes, text/plain)
2016-09-24 22:45 UTC, Christian Stadelmann
no flags Details
File: proc_pid_status (1.12 KB, text/plain)
2016-09-24 22:45 UTC, Christian Stadelmann
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1379440 None None None Never

Internal Trackers: 1379440

Description Christian Stadelmann 2016-09-24 22:45:41 UTC
Description of problem:
When switching to a tty and back, gnome-shell immediately crashes.

Steps to reproduce:
1. log in into a gnome+wayland session (gnome+x11 untested)
2. switch to any tty, e.g. tty3. It does not matter whether you login or not.
3. switch back to the tty with gnome session (usually tty2)

What happens:
Gnome-shell immediately crashes

What should happen:
No crash

Version-Release number of selected component:
gnome-shell-3.22.0-1.fc25

Additional info:
reporter:       libreport-2.8.0
backtrace_rating: 4
cmdline:        /usr/bin/gnome-shell
crash_function: wl_resource_post_event
executable:     /usr/bin/gnome-shell
kernel:         4.8.0-0.rc7.git0.1.fc25.x86_64
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
runlevel:       N 5
type:           CCpp

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 wl_resource_post_event at src/wayland-server.c:194
 #1 wl_pointer_send_motion at /usr/include/wayland-server-protocol.h:3423
 #2 meta_wayland_pointer_send_motion at wayland/meta-wayland-pointer.c:339
 #3 notify_motion at wayland/meta-wayland-pointer.c:557
 #4 handle_motion_event at wayland/meta-wayland-pointer.c:564
 #5 meta_wayland_pointer_handle_event at wayland/meta-wayland-pointer.c:710
 #6 meta_wayland_seat_handle_event at wayland/meta-wayland-seat.c:360
 #7 meta_wayland_compositor_handle_event at wayland/meta-wayland.c:208
 #8 meta_display_handle_event at core/events.c:386
 #9 event_callback at core/events.c:401

Comment 1 Christian Stadelmann 2016-09-24 22:45:46 UTC
Created attachment 1204453 [details]
File: backtrace

Comment 2 Christian Stadelmann 2016-09-24 22:45:47 UTC
Created attachment 1204454 [details]
File: core_backtrace

Comment 3 Christian Stadelmann 2016-09-24 22:45:50 UTC
Created attachment 1204455 [details]
File: dso_list

Comment 4 Christian Stadelmann 2016-09-24 22:45:51 UTC
Created attachment 1204456 [details]
File: limits

Comment 5 Christian Stadelmann 2016-09-24 22:45:52 UTC
Created attachment 1204457 [details]
File: namespaces

Comment 6 Christian Stadelmann 2016-09-24 22:45:54 UTC
Created attachment 1204458 [details]
File: proc_pid_status

Comment 7 Christian Stadelmann 2016-09-25 08:33:50 UTC
This bug is 100% reproducible after installing the Gnome 3.22 megaupdate https://bodhi.fedoraproject.org/updates/FEDORA-2016-77ffa78abb

Comment 8 Christian Stadelmann 2016-09-25 15:42:07 UTC
(In reply to Christian Stadelmann from comment #7)
> This bug is 100% reproducible after installing the Gnome 3.22 megaupdate
> https://bodhi.fedoraproject.org/updates/FEDORA-2016-77ffa78abb

To be more precise: I think it is a regression introduced by the 3.22 megaupdate. Downgrading gnome-shell to 3.21.92-1.fc25.x86_64 makes the problem go away.

This issue is 100% reproducible if animations are enabled.

Workaround: disable animations.

Comment 9 Christian Stadelmann 2016-09-28 10:16:35 UTC
(In reply to Christian Stadelmann from comment #8)
> Workaround: disable animations.

In fact, that's not reliable. Still getting the crash with animations disabled.

Anyway, it seems like this crash is triggered by moving the mouse after switching from tty to gnome/wayland session. If you don't move your mouse, no crash happens.

This issue is specific to gnome/wayland sessions and does not happen on gnome/X11 sessions.

Comment 10 Joachim Frieben 2016-09-29 16:20:19 UTC
Despite updating to mutter-3.22.0-2.fc25, etc., crashes caused by vt switches are still happening which the bug reporting tool redirects to this bug 1379098.

Comment 11 Christian Stadelmann 2016-10-06 09:26:50 UTC
(In reply to Joachim Frieben from comment #10)
> Despite updating to mutter-3.22.0-2.fc25, etc., crashes caused by vt
> switches are still happening which the bug reporting tool redirects to this
> bug 1379098.

Same issue here.

Comment 12 Adam Williamson 2016-10-11 23:01:46 UTC
Yep, just saw this after switching to a VT and back, with all current F25 packages from updates-testing plus:

gtk3-3.22.1-2.fc25.x86_64
gnome-shell-3.22.1-1.fc25.x86_64
mutter-3.22.1-1.fc25.x86_64

proposing as a Final blocker, per criterion "All known bugs that can cause corruption of user data must be fixed or documented at Common F25 bugs.", reading 'corruption' to include 'loss' (as it's kinda intended to, at least by me, who wrote it) - switching to a VT is something people commonly do quite frequently and 'casually' (no-one expects the desktop session to suddenly crash, so they usually don't save all unsaved work in the desktop session before switching), and this crash could lead to the loss of all unsaved data from the desktop session.

Christian, could you check if there's really any secret stuff in your attachments and set the bug public if not? abrt's 'private data' check very often gives false positives (it just looks for key phrases like 'password' and 'key' and stuff and is easily fooled by the same characters cropping up in other contexts, like library filenames).

Comment 13 Christian Stadelmann 2016-10-13 09:07:39 UTC
(In reply to Adam Williamson from comment #12)
> proposing as a Final blocker, per criterion "All known bugs that can cause
> corruption of user data must be fixed or documented at Common F25 bugs.",
> reading 'corruption' to include 'loss' (as it's kinda intended to, at least
> by me, who wrote it) - switching to a VT is something people commonly do
> quite frequently and 'casually' (no-one expects the desktop session to
> suddenly crash, so they usually don't save all unsaved work in the desktop
> session before switching), and this crash could lead to the loss of all
> unsaved data from the desktop session.

+1 (if I'm allowed to vote).

> Christian, could you check if there's really any secret stuff in your
> attachments and set the bug public if not? abrt's 'private data' check very
> often gives false positives (it just looks for key phrases like 'password'
> and 'key' and stuff and is easily fooled by the same characters cropping up
> in other contexts, like library filenames).

Ok. Feel free to make this bug public, i.e. remove it from the "Fedora Contrib Private" group. I don't have permission to do so.

Comment 14 Kamil Páral 2016-10-17 17:58:01 UTC
Similar problem has been detected:

Again tried to reproduce bug 1379098, following the same steps as described in bug 1379440 comment 26.

reporter:       libreport-2.8.0
backtrace_rating: 4
cmdline:        /usr/bin/gnome-shell
crash_function: wl_resource_post_event
executable:     /usr/bin/gnome-shell
global_pid:     17017
kernel:         4.8.1-1.fc25.x86_64
package:        gnome-shell-3.22.1-1.fc25
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
reason:         gnome-shell killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 15 Geoffrey Marr 2016-10-17 19:51:11 UTC
Discussed during the 2016-10-17 blocker review meeting: [1]

The decision to classify this bug as an "AcceptedBlocker" was made as it violates the following criteria:

"All known bugs that can cause corruption of user data must be fixed or documented at Common F25 bugs".

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2016-10-17/f25-blocker-review.2016-10-17-16.02.txt

Comment 16 Kamil Páral 2016-10-20 13:17:30 UTC
I can easily reproduce this on a bare metal machine with Intel graphics. GNOME crashes immediately after VT switch to text and back to graphics and *moving the cursor*. On my laptop, it takes longer to reproduce this (I have to switch multiple times), but it also occurs. So it seems this is pretty universal (Adam reproduced it with nouveau). I don't seem to hit it in a VM, though.

Comment 17 Paul W. Frields 2016-10-20 15:26:14 UTC
I reproduced this as well, but it seems to only reproduce when an application is open on the desktop. I can't reproduce the behavior immediately after a session start, when no apps are open on the desktop.

Comment 18 Paul W. Frields 2016-10-20 15:28:07 UTC
Sorry, details on current packages:

mutter-3.22.1-3.fc25.x86_64
gtk3-3.22.1-2.fc25.x86_64
gnome-shell-3.22.1-1.fc25.x86_64

Comment 19 Ray Strode [halfline] 2016-10-21 14:43:48 UTC
There's an update for this issue here:

https://bodhi.fedoraproject.org/updates/FEDORA-2016-1544cc87d7

FEDORA-2016-1544cc87d7
Submitter 	rtcm
Builds 	
mutter-3.22.1-5.fc25 	
Update ID 	FEDORA-2016-1544cc87d7
Release 	F25
Karma	0 stable threshold: 3 unstable threshold: -3
Type	bugfix
Severity	unspecified
Request	testing
Status	pending
Suggestion	unspecified
Submitted 	21 hours ago, 2016-10-20 17:19:45 (UTC)

Comment 20 Fedora Update System 2016-10-22 03:54:43 UTC
mutter-3.22.1-5.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-1544cc87d7

Comment 21 Fedora Update System 2016-10-23 22:52:52 UTC
mutter-3.22.1-5.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 22 Kamil Páral 2016-10-25 12:16:28 UTC
(In reply to Fedora Update System from comment #21)
> mutter-3.22.1-5.fc25 has been pushed to the Fedora 25 stable repository. 

Tested, seems fixed.


Note You need to log in before you can comment on or make changes to this bug.