Bug 1379113 - OSP Director should support setting the mappings for provider networks
Summary: OSP Director should support setting the mappings for provider networks
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: rc
: 10.0 (Newton)
Assignee: Tim Rozet
QA Contact: Itzik Brown
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-25 05:38 UTC by Itzik Brown
Modified: 2018-10-18 07:21 UTC (History)
8 users (show)

Fixed In Version: openstack-tripleo-heat-templates-5.0.0-1.7.el7ost puppet-neutron-9.4.0-4.el7ost
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
N/A
Last Closed: 2016-12-14 16:04:53 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 380445 None None None 2016-10-05 14:05:13 UTC
OpenStack gerrit 382551 None None None 2016-10-06 04:49:44 UTC

Description Itzik Brown 2016-09-25 05:38:18 UTC
Description of problem:
In order to use a provider network using OpenStack and Opendaylight one has to configure the openvswitch on the nodes to map the physical network to the right interface on the node.

E.g. 
# ovstbl=$(ovs-vsctl get Open_vSwitch . _uuid)
# sudo ovs-vsctl set Open_vSwitch $ovstbl other_config:provider_mappings=datacentre:br-ex

OSP Director should support this setting so that a user won't have to do it manually.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Tim Rozet 2016-10-05 16:35:21 UTC
1.  Align provider-mappings to bridge-mappings in puppet-neutron:
https://review.openstack.org/#/c/382551/1

2.  Expose vlan provider mappings as heat parameters in tripleo-heat-templates:
https://review.openstack.org/#/c/380445/1 (needs update after #1 is merged)

Comment 4 Itzik Brown 2016-11-21 11:06:02 UTC
Verified with:
puppet-neutron-9.4.0-4.el7ost.noarch
openstack-tripleo-heat-templates-5.1.0-3.el7ost.noarch

Comment 7 errata-xmlrpc 2016-12-14 16:04:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.