Bug 1379223 - "nfs.disable: on" is not showing in Vol info by default for the 3.7.x volumes after updating to 3.9.0
Summary: "nfs.disable: on" is not showing in Vol info by default for the 3.7.x volumes...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: mainline
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Atin Mukherjee
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1378677 1385451
TreeView+ depends on / blocked
 
Reported: 2016-09-26 05:22 UTC by Atin Mukherjee
Modified: 2017-03-06 17:27 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1378677
: 1385451 (view as bug list)
Environment:
Last Closed: 2017-03-06 17:27:39 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Atin Mukherjee 2016-09-26 05:24:31 UTC
Description of problem:
=======================
The volume option "nfs.disable: on" is not showing for the 3.7.x volumes after updating to 3.8.x

Version-Release number of selected component (if applicable):
=============================================================
This option is showing for the volumes created after updating 3.2.


How reproducible:
=================
Always


Steps to Reproduce:
===================
1. Have 3.7.x setup with replica-1 volume 
2. Update to 3.8.x
3. Check volume info 
4. Create a new replica-2 volume  
5. Compare the volume info of replica-1 and replica-2


Actual results:
===============
"nfs.disable: on" is showing in Vol info by default for the 3.7.x volumes after updating to 3.8.x

Expected results:
=================
Volume options in the volume info should be same for multiple same volume type by default.

Comment 2 Worker Ant 2016-09-26 05:25:14 UTC
REVIEW: http://review.gluster.org/15568 (glusterd: enable default configurations post upgrade to >= 3.8.0 versions) posted (#1) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 3 Atin Mukherjee 2016-09-26 05:29:28 UTC
RCA:

The options were put up in the dictionary during volume creation and were never recreated during upgrade and hence volume info doesn't show them as default. These options are now been put up in to volume's dictionary when the op-version is bumped up.

Comment 4 Kaushal 2016-09-26 07:18:49 UTC
The volume that was upgraded, will still have gNFS running for it, so volume info not having gNFS is expected and correct. This isn't a bug IMO, and doesn't need anything to be fixed.

Comment 5 Atin Mukherjee 2016-09-26 09:43:11 UTC
After a discussion with nfs team, it was agreed upon that 3.9 onwards we will be showing the default options nfs.disable which is 'on' in volume info output for a volume which was configured with older bits i.e. < 3.8.0

Comment 6 Worker Ant 2016-09-26 09:44:20 UTC
REVIEW: http://review.gluster.org/15568 (glusterd: enable default configurations post upgrade to >= 3.9.0 versions) posted (#2) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 7 Atin Mukherjee 2016-09-26 12:29:53 UTC
(In reply to Atin Mukherjee from comment #1)
> Description of problem:
> =======================
> The volume option "nfs.disable: on" is not showing for the 3.7.x volumes
> after updating to 3.8.x
> 
> Version-Release number of selected component (if applicable):
> =============================================================
> This option is showing for the volumes created after updating 3.2.
> 
> 
> How reproducible:
> =================
> Always
> 
> 
> Steps to Reproduce:
> ===================
> 1. Have 3.7.x setup with replica-1 volume 
> 2. Update to 3.8.x
> 3. Check volume info 
> 4. Create a new replica-2 volume  
> 5. Compare the volume info of replica-1 and replica-2
> 
> 
> Actual results:
> ===============
> "nfs.disable: on" is showing in Vol info by default for the 3.7.x volumes
> after updating to 3.8.x
> 
> Expected results:
> =================
> Volume options in the volume info should be same for multiple same volume
> type by default.

We are going to consider this change for a 3.9.x upgrade path not 3.8.x.

Comment 8 Worker Ant 2016-09-28 05:22:18 UTC
REVIEW: http://review.gluster.org/15568 (glusterd: enable default configurations post upgrade to >= 3.9.0 versions) posted (#3) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 9 Worker Ant 2016-09-29 06:42:56 UTC
REVIEW: http://review.gluster.org/15568 (glusterd: enable default configurations post upgrade to >= 3.9.0 versions) posted (#4) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 10 Worker Ant 2016-10-17 04:31:17 UTC
COMMIT: http://review.gluster.org/15568 committed in master by Kaushal M (kaushal@redhat.com) 
------
commit 91c353001c0acf6b6a4c08181fa9a582ae3f880b
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Sat Sep 24 13:18:24 2016 +0530

    glusterd: enable default configurations post upgrade to >= 3.9.0 versions
    
    With 3.8.0 onwards volume options like nfs.disable, transport.address-family
    have some default configuration value. If a volume was created pre upgrade to
    3.8.0 or higher the default options are not set post upgrade. This patch takes
    care of putting the default values in the op-version bump up workflow. However
    these changes will only reflect from 3.9.0 onwards
    
    Change-Id: I9a8d848cd08d87ddcb80dbeac27eaae097d9cbeb
    BUG: 1379223
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: http://review.gluster.org/15568
    Reviewed-by: jiffin tony Thottan <jthottan@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: soumya k <skoduri@redhat.com>
    Reviewed-by: Kaushal M <kaushal@redhat.com>

Comment 11 Shyamsundar 2017-03-06 17:27:39 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.