Bug 1379289 - RFE: virt-p2v should support mnemonic operations
Summary: RFE: virt-p2v should support mnemonic operations
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs
Version: 7.3
Hardware: x86_64
OS: Unspecified
medium
medium
Target Milestone: rc
: 7.4
Assignee: Pino Toscano
QA Contact: Virtualization Bugs
URL:
Whiteboard: P2V
Depends On: 1359086
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-26 09:35 UTC by Xiaodai Wang
Modified: 2017-08-01 22:11 UTC (History)
7 users (show)

Fixed In Version: libguestfs-1.36.2-3.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 22:11:26 UTC


Attachments (Terms of Use)
create (125.99 KB, image/jpeg)
2017-03-20 08:45 UTC, mxie@redhat.com
no flags Details
DCB (167.40 KB, image/jpeg)
2017-03-20 08:45 UTC, mxie@redhat.com
no flags Details
mnemonic-S (153.85 KB, image/jpeg)
2017-03-20 08:46 UTC, mxie@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2023 normal SHIPPED_LIVE libguestfs bug fix and enhancement update 2017-08-01 19:32:01 UTC
Red Hat Bugzilla 1434317 None None None Never

Internal Links: 1434317

Description Xiaodai Wang 2016-09-26 09:35:58 UTC
Description of problem:
RFE: virt-p2v should support mnemonic operations

Version-Release number of selected component (if applicable):
virt-p2v-1.32.7-2.el7.iso

How reproducible:
100%

Steps to Reproduce:
1. Run virt-p2v iso.
2. Check the virt-p2v dialog.
3. Press 'Alt' keys

Actual results:
No any mnemonic characters display.

Expected results:
virt-p2v should add mnemonic characters for buttons and text entries to increase easily operate with keyboard.

Additional info:

Comment 1 Richard W.M. Jones 2016-09-26 09:39:40 UTC
I think these are called accelerator keys?

Comment 2 Xiaodai Wang 2016-09-26 09:49:27 UTC
(In reply to Richard W.M. Jones from comment #1)
> I think these are called accelerator keys?

yep, sorry for confusing. :).

I saw 'mnemonics' in developer.gnome.org.

Labels may contain “mnemonics”. Mnemonics are underlined characters in the label, used for keyboard navigation. Mnemonics are created by providing a string with an underscore before the mnemonic character, such as "_File",

Comment 4 Pino Toscano 2016-09-26 14:56:29 UTC
Fixed upstream with
https://github.com/libguestfs/libguestfs/commit/7f236d2201e1063570ac18b118e83b31c778f304
which is in libguestfs >= 1.35.7.

Comment 6 mxie@redhat.com 2017-03-20 08:44:54 UTC
I could reproduce this bug with build:
virt-p2v-1.32.7-2.el7.iso

Verify the bug with builds:
virt-v2v-1.36.2-2.el7.x86_64
libguestfs-1.36.2-2.el7.x86_64
virt-p2v-1.36.2-2.el7


Steps:
1. Making virt-p2v bootable usb key via virt-p2v-make-disk command
# virt-p2v-make-disk -o /dev/sdb
[   2.9] Downloading: http://libguestfs.org/download/builder/fedora-25.xz
######################################################################## 100.0%
***********
[6814.6] Finishing off
                   Output file: /dev/sdb
                   Output size: 14.9G
                 Output format: raw
            Total usable space: 14.3G
                    Free space: 12.7G (89%)
*************

2.Insert the p2v bootable usb key into the machine and then boot the machine into p2v client

3.Checking the mnemonic characters  at p2v GUI interface

4.After finishing checking, found some buttons has no mnemonic characters or some mnemonic characters are conflict

4.1 At inputting v2v conversion server info interface-> configure network-> add -> type 'alt' keyboard-> found create button has no mnemonic character, pls refer to screenshot 'create'

4.2 At inputting v2v conversion server info interface-> configure network-> select one network, such as 'eth0' -> edit-> select 'DCB' option-> type 'alt' keyboard-> found 'Use 802.1X ..' option has no mnemonic character, pls refer to screenshot 'DCB'

4.3 At inputting conversion info interface-> type 'alt' keyboard-> found mnemonic character of 'output storage' and mnemonic character of 'start conversion' are conflict, pls refer to screenshot 'mnemonic-S'

So this bug still need to be fixed above issues

Comment 7 mxie@redhat.com 2017-03-20 08:45:24 UTC
Created attachment 1264715 [details]
create

Comment 8 mxie@redhat.com 2017-03-20 08:45:55 UTC
Created attachment 1264716 [details]
DCB

Comment 9 mxie@redhat.com 2017-03-20 08:46:39 UTC
Created attachment 1264717 [details]
mnemonic-S

Comment 10 Richard W.M. Jones 2017-03-20 09:04:54 UTC
'create' and 'DCB' are part of a dialog provided by NetworkManager's
"nm-connection-editor" tool, so you would have to file a separate
bug about those against NetworkManager.

I can fix the conflicting output storage / start conversion
ones today.

Comment 11 mxie@redhat.com 2017-03-21 09:31:52 UTC
I have filed the bug 1434317 to track the problem of 'create' and 'DCB' buttons

Comment 12 Richard W.M. Jones 2017-03-21 17:24:28 UTC
Patch posted to fix comment 9:

https://www.redhat.com/archives/libguestfs/2017-March/msg00238.html

Comment 13 Richard W.M. Jones 2017-03-22 15:49:36 UTC
Upstream commit:
9d6b1ec28811255ec4447e3f67eb508f0b6f8396
in libguestfs >= 1.37.7.

Comment 14 mxie@redhat.com 2017-03-24 09:08:27 UTC
Verify the bug with builds again:
virt-v2v-1.36.2-3.el7.x86_64
libguestfs-1.36.2-3.el7.x86_64
virt-p2v-1.36.2-3.el7


Steps:
1. Making virt-p2v bootable usb key via virt-p2v-make-disk command
# virt-p2v-make-disk -o /dev/sdb rhel-7.3

2.Insert the p2v bootable usb key into the machine and then boot the machine into p2v client

3.Checking the mnemonic characters at p2v GUI interface

4.After finishing checking, all buttons have mnemonic characters
except that 'DCB' and 'create' which there is bug1434317 to track

Result:
The bug has been fixed, so move the bug from ON_QA to VERIFIED

Comment 15 errata-xmlrpc 2017-08-01 22:11:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2023


Note You need to log in before you can comment on or make changes to this bug.