Bug 1379330 - eventsapi/georep: Events are not available for Checkpoint and Status Change
Summary: eventsapi/georep: Events are not available for Checkpoint and Status Change
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Aravinda VK
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1380257 1386178
TreeView+ depends on / blocked
 
Reported: 2016-09-26 11:51 UTC by Aravinda VK
Modified: 2017-03-06 17:28 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1380257 1386178 (view as bug list)
Environment:
Last Closed: 2017-03-06 17:28:10 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Aravinda VK 2016-09-26 11:51:34 UTC
Description of problem:
Events are not available on checkpoint completion and on Worker status change.

Following events are required from Geo-replication

GEOREP_CHECKPOINT_COMPLETION => Completion Time and other details
GEOREP_STATUS_CHANGE  => Active to Passive or vise versa

Comment 1 Worker Ant 2016-10-12 18:05:06 UTC
REVIEW: http://review.gluster.org/15630 (geo-rep/eventsapi: Additional Events) posted (#1) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 2 Worker Ant 2016-10-17 10:51:03 UTC
REVIEW: http://review.gluster.org/15630 (geo-rep/eventsapi: Additional Events) posted (#2) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 3 Worker Ant 2016-10-18 10:56:10 UTC
COMMIT: http://review.gluster.org/15630 committed in master by Aravinda VK (avishwan@redhat.com) 
------
commit 3830b48b6a46854d6597a36b6f2089ac1e486eb5
Author: Aravinda VK <avishwan@redhat.com>
Date:   Wed Oct 12 23:32:39 2016 +0530

    geo-rep/eventsapi: Additional Events
    
    Added following events
    EVENT_GEOREP_ACTIVE
        {
            "nodeid": NODEID,
            "ts": TIMESTAMP,
            "event": "GEOREP_ACTIVE",
            "message": {
                "master_volume": MASTER_VOLUME_NAME,
                "slave_host": SLAVE_HOST,
                "slave_volume": SLAVE_VOLUME,
                "brick_path": BRICK_PATH
            }
        }
    
    EVENT_GEOREP_PASSIVE
        {
            "nodeid": NODEID,
            "ts": TIMESTAMP,
            "event": "GEOREP_PASSIVE",
            "message": {
                "master_volume": MASTER_VOLUME_NAME,
                "slave_host": SLAVE_HOST,
                "slave_volume": SLAVE_VOLUME,
                "brick_path": BRICK_PATH
            }
        }
    EVENT_GEOREP_CHECKPOINT_COMPLETED
        {
            "nodeid": NODEID,
            "ts": TIMESTAMP,
            "event": "GEOREP_ACTIVE",
            "message": {
                "master_volume": MASTER_VOLUME_NAME,
                "slave_host": SLAVE_HOST,
                "slave_volume": SLAVE_VOLUME,
                "brick_path": BRICK_PATH,
                "checkpoint_time": CHECKPOINT_TIME,
                "checkpoint_completion_time": CHECKPOINT_COMPLETION_TIME
            }
        }
    
    BUG: 1379330
    Change-Id: I90716175868c59dd65c8d202e73e0ede90347b6a
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-on: http://review.gluster.org/15630
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Kotresh HR <khiremat@redhat.com>
    Tested-by: Kotresh HR <khiremat@redhat.com>

Comment 4 Shyamsundar 2017-03-06 17:28:10 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.