Bug 1379388 - Overcloud deployment by controlling nodes placement fails with Filter TripleOCapabilitiesFilter returned 0 hosts
Summary: Overcloud deployment by controlling nodes placement fails with Filter TripleO...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: rc
: 10.0 (Newton)
Assignee: Ben Nemec
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-26 14:41 UTC by Marius Cornea
Modified: 2016-12-14 16:05 UTC (History)
9 users (show)

Fixed In Version: openstack-tripleo-heat-templates-5.0.0-0.20161003064637.d636e3a.1.1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 16:05:17 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 377110 None None None 2016-09-26 21:44:23 UTC

Description Marius Cornea 2016-09-26 14:41:07 UTC
Description of problem:
Overcloud deployment by controlling nodes placement fails with:

ERROR due to "Message: No valid host was found. There are not enough hosts available., Code: 500"

Version-Release number of selected component (if applicable):
openstack-tripleo-image-elements-5.0.0-0.20160810171527.98b9c6a.el7ost.noarch
puppet-tripleo-5.0.0-0.20160907223204.488fb91.el7ost.noarch
python-tripleoclient-5.0.0-0.20160907170033.b0d7ce7.el7ost.noarch
openstack-tripleo-heat-templates-5.0.0-0.20160907212643.90c852e.2.el7ost.noarch
openstack-tripleo-puppet-elements-5.0.0-0.20160902162220.01fb147.el7ost.noarch
openstack-tripleo-common-5.0.1-0.20160907170731.18c71e1.el7ost.noarch
openstack-tripleo-0.0.1-0.20160830221128.15f0afe.el7ost.noarch


How reproducible:
100%

Steps to Reproduce:
1. Deploy overcloud:

source ~/stackrc
export THT=/home/stack/templates/openstack-tripleo-heat-templates
openstack overcloud deploy --templates $THT \
-e $THT/environments/network-isolation.yaml \
-e $THT/environments/network-management.yaml \
-e ~/templates/network-environment.yaml \
-e ~/templates/enable-tls.yaml \
-e ~/templates/inject-trust-anchor.yaml \
-e $THT/environments/storage-environment.yaml \
-e ~/templates/ips-from-pool-all.yaml \
-e ~/templates/scheduler_hints_env.yaml \
-e ~/templates/disk-layout.yaml \
-e ~/templates/wipe-disk-env.yaml \
--control-scale 3 \
--compute-scale 1 \
--ceph-storage-scale 1 \
--ntp-server clock.redhat.com 


Actual results:

2016-09-26 14:00:47 [overcloud]: CREATE_FAILED Resource CREATE failed: ResourceInError: resources.CephStorage.resources[0].resources.CephStorage: Went to status ERROR due to "Message: No valid host was found. There are not enough hosts available., Code: 500"


Expected results:

Deployment passes.

Additional info:

The scheduler hints environment:

[stack@undercloud-0 ~]$ cat templates/scheduler_hints_env.yaml 
parameter_defaults:
  ControllerSchedulerHints:
    'capabilities:node': 'controller-%index%'
  NovaComputeSchedulerHints:
    'capabilities:node': 'compute-%index%'
  CephStorageSchedulerHints:
    'capabilities:node': 'ceph-%index%'
  HostnameMap:
    overcloud-controller-0: ctrl-r00-00
    overcloud-controller-1: ctrl-r01-01
    overcloud-controller-2: ctrl-r02-02
    overcloud-compute-0: comp-r00-00
    overcloud-cephstorage-0: stor-r00-00

The ironic node capabilities:
[stack@undercloud-0 ~]$ ironic node-show ceph-0 | grep node
|                        | u'cpus': u'1', u'capabilities': u'node:ceph-0,boot_option:local'}       |


I added some logging in /usr/lib/python2.7/site-packages/tripleo_common/filters/capabilities_filter.py:

<         LOG.critical(str(host_node))
<         LOG.critical(str(instance_node[0]))

and I can see in nova-scheduler.log that the %index% is not translated:

controller-0
compute-%index%
ceph-1
compute-%index%
compute-0
compute-%index%
ceph-2
compute-%index%
ceph-0
compute-%index%
compute-1
compute-%index%
controller-2
compute-%index%
controller-1
compute-%index%

INFO nova.filters [req-fff83498-17e9-422c-b7b6-b8d79ba12617 5d05aab1cd2145c3adc58cb3bd6f219c d6721b73a7424eeda155250020db20e2 - - -] Filter TripleOCapabilitiesFilter returned 0 hosts

Comment 1 Marius Cornea 2016-09-26 14:56:06 UTC
[stack@undercloud-0 ~]$ ironic node-list
+--------------------------------------+--------------+---------------+-------------+--------------------+-------------+
| UUID                                 | Name         | Instance UUID | Power State | Provisioning State | Maintenance |
+--------------------------------------+--------------+---------------+-------------+--------------------+-------------+
| af48e1c3-5f9f-4b4f-9d11-55d1187b4285 | ceph-0       | None          | power off   | available          | False       |
| 0e437c67-4e29-4f56-8c6a-dd2e32134ff3 | ceph-1       | None          | power off   | available          | False       |
| 600beb10-71c3-4365-87bd-dc48f19d0e87 | ceph-2       | None          | power off   | available          | False       |
| 37225a18-1fda-4573-b836-e31024b7394f | controller-0 | None          | power off   | available          | False       |
| 39b355b9-db7c-46c8-b1ac-ffa45e66356f | controller-1 | None          | power off   | available          | False       |
| 099cbe74-0195-4c77-93ae-bfc605cca2e1 | controller-2 | None          | power off   | available          | False       |
| 4a59ef55-250d-4976-bb3d-c2fccaceb0a6 | compute-0    | None          | power off   | available          | False       |
| bc308ee0-2082-48a7-a56a-e87f291eaa53 | compute-1    | None          | power off   | available          | False       |
+--------------------------------------+--------------+---------------+-------------+--------------------+-------------+

Comment 3 Ben Nemec 2016-09-26 21:44:23 UTC
Fix proposed upstream.

Comment 4 James Slagle 2016-10-03 14:37:18 UTC
i believe this has been built downstream. can you confirm and if so, set the Fixed in Version and move the bug to MODIFIED?

Comment 6 Ben Nemec 2016-11-21 23:49:39 UTC
This is fixed, clearing needinfo.

Comment 7 Ben Nemec 2016-12-13 19:02:41 UTC
Regression that was fixed before release.  No need for doctext.

Comment 9 errata-xmlrpc 2016-12-14 16:05:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.