Bug 137940 - Crashes on start after trying to open empty mailbox
Crashes on start after trying to open empty mailbox
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-02 17:47 EST by Bob Gustafson
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-30 11:26:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Bug Buddy output from crash on accessing 'Junk' folder (12.50 KB, text/plain)
2004-11-02 18:21 EST, Bob Gustafson
no flags Details
Bug buddy report with evolution-debuginfo package installed (11.69 KB, text/plain)
2004-11-02 22:45 EST, Bob Gustafson
no flags Details
Bug Buddy crash dump after clicking on 'Trash' instead of 'Junk' (11.79 KB, text/plain)
2004-11-02 23:03 EST, Bob Gustafson
no flags Details
Fragment of screen dump of Evolution before crash (Gimp file) (77.95 KB, text/plain)
2004-11-02 23:29 EST, Bob Gustafson
no flags Details

  None (edit)
Description Bob Gustafson 2004-11-02 17:47:44 EST
Description of problem:

  I was clicking around (learning a bit more about it) and clicked on
my 'jumk' mailbox.

(Under my name, there is 'inbox', 'jumk', and 'trash')

Evolution crashed.

Now, whenever I launch evolution, it is at that same spot and always
crashes.

Hopefully there is something I can do with config to set the starting
point back to something not so tragic.

Version-Release number of selected component (if applicable):

  Latest fc3-3 updated this morning.

How reproducible:

  Whenever I click on the evolution icon on the gnome taskbar, it crashes.
Steps to Reproduce:
1.  Go to 'mail'
2.  Open a user name in the left panel.
3.  click on the sub-mailbox 'jumk' (below the 'inbox')
4.  watch it crash.

Actual results:

  see above

Expected results:

  do nothing (empty folder)

Additional info:

  I will try to get it to 'send info to developers' - as yet have not
been successful with that thingy.
Comment 1 Dave Malcolm 2004-11-02 17:56:43 EST
Works for me.  Please can you try to provide a backtrace as described
here:
http://fedora.linux.duke.edu/wiki/index.cgi/StackTraces
Comment 2 Bob Gustafson 2004-11-02 18:05:47 EST
in directory /home/user1/.evolution/mail/config

In the file 'folder-tree-expand-state.xml'

I whacked off the last line which mentioned the node name 'Junk'

Now things work.

----

I will try to repeat the sequence I described originally to attempt to
get into the same spot. Then will send StackTraces.



Comment 3 Bob Gustafson 2004-11-02 18:11:12 EST
Note, just after I sent the original bug report, I was successful in
running BugBuddy. I duplicated the Summary line and referenced this
bug report in the body of the Bug Buddy bug report.

I sent off that bug buddy report (which included a stack trace I think).

This new bug report is not in this bugzilla. Seems like it went to Zimian.

=====
Will try to reproduce problem by clicking again on the 'Jumk' folder.
Comment 4 Bob Gustafson 2004-11-02 18:21:15 EST
Created attachment 106095 [details]
Bug Buddy output from crash on accessing 'Junk' folder

See previous comment on this attachment.
Comment 5 Bob Gustafson 2004-11-02 18:25:26 EST
Hmm, that is funny, my previously typed comment does not show here..

So, the attachment above is from a new crash situation which was
created by clicking on 'Junk'.

Note that there are several 'junk' folders. The one which produced the
above crash was found by opening up my name on the left mail panel in
evolution. When this menu item is expanded, there are 'inbox', 'junk',
and 'trash'. When I click on 'junk' - Bang

The Bug Buddy dump attached above is from this new crash.
Comment 6 Dave Malcolm 2004-11-02 18:33:37 EST
Looking at the backtrace, it looks like this assertion at the top of
camel_mkdir is failing: g_assert(path && path[0] == '/'); 

Please can you ensure the evolution-debuginfo package is installed and
try to get another backtrace (in particular, this will hopefully give
information on the value of "path" when the assertion fails, though it
may also give other useful info).  Thanks!
Comment 7 Bob Gustafson 2004-11-02 22:40:24 EST
OK

None of the debuginfo packages are installed, so I installed:

Installed: evolution-debuginfo.i386 0:2.0.2-3
Complete!

Will do the bug buddy bit and will attach output in a minute
Comment 8 Bob Gustafson 2004-11-02 22:45:10 EST
Created attachment 106105 [details]
Bug buddy report with evolution-debuginfo package installed

Note that this crash was not created from the beginning, but was done by
restarting Evolution after the last crash.

I could go and delete the line I previously deleted to get this to crash from
the beginnng if this would show any more information (doubtful though).
Comment 9 Bob Gustafson 2004-11-02 23:01:33 EST
Hmm, little bug in bugzilla - cannot open a 'dot directory' (i.e. 
.evolution) in the 'browse' command of the 'create attachment' form.

The contents of the file that I whack to get Evolution restarted is:

[user1@hoho2 config]$ cd /home/user1/.evolution/mail/config
[user1@hoho2 config]$ cat folder-tree-expand-state.xml
<?xml version="1.0"?>
<tree-state>
  <node name="local" expand="true"/>
  <node name="vfolder" expand="true"/>
  <node name="1085547319.4448.0@hoho2.chidig.com" expand="true"><node
name="Junk" expand="true"/></node>
  <selected uri="maildir:Maildir#Junk"/>
</tree-state>
[user1@hoho2 config]$

After whacking it is:

[user1@hoho2 config]$ cat folder-tree-expand-state.xml
<?xml version="1.0"?>
<tree-state>
  <node name="local" expand="true"/>
  <node name="vfolder" expand="true"/>
</tree-state>
[user1@hoho2 config]$

I started Evolution and got to the same expanded menu folder on the
left side with 'inbox', 'junk', and 'trash'. I clicked on 'inbox' and
got a blank frame (expected - no mail coming in to this machine),
then, just for variety, I clicked on 'Trash' instead of 'Junk'. It
crashed here.  Attached is evolution3.bug dump from Bug Buddy.
Comment 10 Bob Gustafson 2004-11-02 23:03:21 EST
Created attachment 106106 [details]
Bug Buddy crash dump after clicking on 'Trash' instead of 'Junk'

As described above
Comment 11 Bob Gustafson 2004-11-02 23:29:35 EST
Created attachment 106110 [details]
Fragment of screen dump of Evolution before crash (Gimp file)

Note that there are TWO 'junk' files. The one that causes the crash is below
the 'BobG' name on the menu. (Also the 'trash' file in that same area).

The BobG name is not used much (if at all). My major testing has been with the
category at the top of the menu. (Black on dark grey is difficult to read..)
Comment 12 Bob Gustafson 2004-11-03 15:44:53 EST
Note that clicking on the first (topmost) junk menu item (below 'On
This Computer) does NOT cause a crash. Neither does clicking on the
first (topmost) trash folder.

But, clicking on either the junk or trash menu item (below 'BobG')
causes an immediate crash.

Perhaps the problem is related to the validity of 'BobG' ??
Comment 13 Bob Gustafson 2004-11-03 16:08:28 EST
I think there must be a hole in the accounts creation procedure. I
tried to create another account (SusyQ) which will mimic the behavior
(crashes) of BobG.

Going into Tools->Settings->(button)Add, I can create a new account
(SusyQ), but have not found the magic combination of settings (or
non-settings) which will create a crashing account. Have not tried
them all though.

It does give an Alert dialog:

'Error while Scanning folders in "SusyQ/".
Could not scan folder `SusyQ': No such file or directory.

But then goes ahead and creates that name in the menu. Whenever I
click on that name and try to expand that menu item, it gives me the
Alert dialog, but it does not crash.

It could be that the hole in the wizard has been fixed between the
time I 'added' that account and now.

I bet that if I just 'remove' that account (In the Tools->Settings
form), it would not crash ('BobG' name would not be there) and if I
tried to recreate the account, I would be hard pressed to screw it up
as badly (crashing) as it is now.

Should I just 'remove' BobG and go on with my life?
Comment 14 Bob Gustafson 2004-11-03 16:19:07 EST
Looking around for the [jJ]unk folder - doesn't seem to be anywhere
under the /home directory (using find)

Also, there is no mention of 'BobG' in the directories shown below. 

SusyQ is there, but I have already removed SusyQ (!!).

[root@hoho2 config]# pwd
/home/user1/.evolution/mail/config
[root@hoho2 config]# ls -1
et-expanded-mbox:_home_user1_.evolution_mail_local#Drafts
et-expanded-mbox:_home_user1_.evolution_mail_local#Inbox
et-expanded-mbox:_home_user1_.evolution_mail_local#Junk
et-expanded-mbox:_home_user1_.evolution_mail_local#Outbox
et-expanded-mbox:_home_user1_.evolution_mail_local#Sent
et-expanded-mbox:_home_user1_.evolution_mail_local#SusyQ
et-expanded-mbox:_home_user1_.evolution_mail_local#Trash
et-expanded-vfolder:_home_user1_.evolution_mail_vfolder#UNMATCHED
folder-tree-expand-state.xml
gtkrc-mail-fonts
[root@hoho2 config]#
Comment 16 Matthew Miller 2006-07-10 19:32:53 EDT
Fedora Core 3 is now maintained by the Fedora Legacy project for security
updates only. If this problem is a security issue, please reopen and
reassign to the Fedora Legacy product. If it is not a security issue and
hasn't been resolved in the current FC5 updates or in the FC6 test
release, reopen and change the version to match.

Thank you!
Comment 17 John Thacker 2006-10-30 11:26:18 EST
Closing per lack of response to previous request for information.
This bug was originally filed against a much earlier version of Fedora
Core, and significant changes have taken place since the last version
for which this bug is confirmed.

Note that FC3 and FC4 are supported by Fedora Legacy for security
fixes only.  Please install a still supported version and retest.  If
it still occurs on FC5 or FC6, please reopen and assign to the correct
version.  Otherwise, if this a security issue, please change the
product to Fedora Legacy.  Thanks, and we are sorry that we did not
get to this bug earlier.

Note You need to log in before you can comment on or make changes to this bug.