Bug 137943 - Installer can't see my SATA drives
Installer can't see my SATA drives
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-02 18:15 EST by Lars Damerow
Modified: 2015-01-04 17:11 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-24 01:27:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lars Damerow 2004-11-02 18:15:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; rv:1.7.3)
Gecko/20041011 Firefox/0.10.1

Description of problem:
A machine that installs happily to its SATA drives using FC2 has
problems with FC3 test 3. It's an x86_64 machine using the ata_piix
driver for SATA support. Specifically, the machine is an HP xw8200.

When the installer starts up, it says "No hard drives have been
found." and says that I might need to choose a device driver manually.
 However, ata_piix is already loaded.

On virtual terminal 4, I see the following messages:

<7>libata version 1.02 loaded.
<7>ata_piix version 1.02
<6>ACPI: PCI interrupt 0000:00:1f.2[A] -> GSI 18 (level, low) -> IRQ 185
<7>PCI: Setting latency timer of device 0000:00:1f.2 to 64
<6>ata1: SATA max UDMA/133 cmd 0x5810 ctl 0x582A bmdma 0x54F0 irq 185
<6>ata2: SATA max UDMA/133 cmd 0x5818 ctl 0x582E bmdma 0x54F8 irq 185
<7>ata1: dev 0 cfg 49:0000 82:0000 83:0000 84:0000 85:0000 86:0000
87:0000 88:0000
<7>ata1: no dma/lba
<4>ata1: dev 0 not supported, ignoring
<6>scsi2 : ata_piix
<7>ata2: dev 0 cfg 49:0000 82:0000 83:0000 84:0000 85:0000 86:0000
87:0000 88:0000
<7>ata2: nodma/lba
<4>ata2: dev 0 not supported, ignoring

What can I do to have FC3test3 detect these drives as FC2 can? I've
tried booting with the "linux pci=noacpi" boot option as I've seen
suggested for similar cases, but it hasn't helped. I also see no
options relating to LBA or DMA in the machine's BIOS.

Thanks very much!

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot off of FC3 test 3 install disc
2. Select "linux" boot option
3. Wait
    

Actual Results:  The installer fails to detect the SATA drives.

Expected Results:  The installer should have detected the drives and
proceeded to install FC3 test3.

Additional info:

I'm marking this bug as high because it renders FC3 potentially
uninstallable on these types of machines.
Comment 1 Anssi Johansson 2004-11-03 18:24:34 EST
I'm seeing very much the same on my own Abit AV8 (x86_64) motherboard,
with 250GB and 80GB SATA Maxtor hard disks and FC3-RC5. The driver in
my case is sata_via. I can also see the "no dma/lba" message when I
turn on debugging. I haven't tried this with FC2.

I have installed FC3T3 on another hard disk, a regular parallel ATA
hard disk. If I have both hard disks (the SATA and PATA disks)
attached and boot with the PATA hard disk, I can see the SATA hard
disk identified correctly. 

My console shows the following during install:
(copied manually from screen, look out for typos)

<7>libata version 1.02 loaded.
<7>sata_via version 0.20
<6>ACPI: PCI interrupt 0000:00:0f.0[B] -> GSI 20 (level, low) -> IRQ 185
<6>sata_via(0000:00:0f.0): routed to hard irq line 11
<6>ata1: SATA max UDMA/133 cmd 0xB400 ctl 0xB802 bmdma 0xC400 irq 185
<6>ata2: SATA max UDMA/133 cmd 0xBC00 ctl 0xC002 bmdma 0xC408 irq 185
<7>ata1: dev 0 cfg 49:0000 82:0000 83:0000 84:0000 85:0000 86:0000
87:0000 88:0000
<7>ata1: no dma/lba
<4>ata1: dev 0 not supported, ignoring
<6>scsi0 : sata_via
<6>ata2: no device found (phy stat 00000000) <- this is ok, just one HD
<6>scsi1 : sata_via
Comment 2 Anssi Johansson 2004-11-04 18:18:30 EST
To point out the blazingly obvious, the reason why the kernel ignores
the hard disk is that the capabilities bits are all turned off.
Specifically when the ID 49 field is zero, it yields the "no dma/lba"
error message. The reason why those fields are not filled is still
beyond me at this moment.

Here's what the kernel _should_ show for my hard disk. These results
were obtained by booting with a PATA hard disk to FC3T3 (.649 kernel)
on the same computer.

ata1: dev 0 cfg 49:2f00 82:7c6b 83:7f09 84:4043 85:7c69 86:3e01
87:4043 88:407f
ata1: dev 0 ATA, max UDMA/133, 490234752 sectors: lba48
ata1: dev 0 configured for UDMA/133
scsi0 : sata_via
ata2: no device found (phy stat 00000000)
scsi1 : sata_via
  Vendor: ATA       Model: Maxtor 7B250S0    Rev: BANC
  Type:   Direct-Access                      ANSI SCSI revision: 05
SCSI device sda: 490234752 512-byte hdwr sectors (251000 MB)
SCSI device sda: drive cache: write back
 sda: unknown partition table
Attached scsi disk sda at scsi0, channel 0, id 0, lun 0

Another thing, when I boot with an i386 boot disk the SATA hard disk
is detected properly. I use the images/boot.iso image when doing these
tests, both for i386 and x86_64.

Summary:
- i386 booted from CD: SATA works
- x86_64 booted from hard disk: SATA works
- x86_64 booted from CD: no SATA

What's the difference in the booting process when booting from CD and
from hard disk? The kernel appears to be exactly the same in both cases.
Comment 3 Anssi Johansson 2004-11-08 14:26:03 EST
For the record, this is also the case in final FC3.
Comment 4 Lars Damerow 2004-11-08 15:28:21 EST
I can confirm that for my boxes too--FC3 final still can't see my drives.
Comment 6 dff 2004-11-22 13:19:40 EST
How much memory is in the affected systems?  Does booting with
"mem=1024M" work?
Comment 7 Lars Damerow 2004-11-23 16:16:19 EST
The systems have 4GB of RAM. I ran the installer with mem=0x8000000
and, lo and behold, it worked! I also have to edit the grub.conf to
always use mem=0x80000000, though I'm about to install the 681 errata
kernel to see if that helps.

Let me know if there's any other hardware information I can send.

Thanks,
lars
Comment 8 Lars Damerow 2004-11-23 16:24:05 EST
The 681 errata kernel didn't help.
Comment 9 dff 2004-11-23 18:44:05 EST
This is almost certainly a dupe of private bug 132848, reported and being worked
against RHEL 4 beta.  Will leave this bug open and add a dependency.
Comment 10 Lars Damerow 2004-11-30 19:02:18 EST
Is there any way I can check the progress of the private bug? Also,
will the fix be applied to an errata kernel for FC2?

I currently have kernel 2.6.9-1.6_FC2 installed on my machine, and
though it correctly sees the first SATA drive, it ignores the second:

ata1: SATA max UDMA/133 cmd 0x5810 ctl 0x582A bmdma 0x54F0 irq 169
ata2: SATA max UDMA/133 cmd 0x5818 ctl 0x582E bmdma 0x54F8 irq 169
ata1: dev 0 ATA, max UDMA/133, 14522611 sectors: lba48
ata1: dev 0 configured for UDMA/133
scsi2: ata_piix
ata2: dev 0 not supported, ignoring

Thanks,
lars
Comment 11 dff 2004-12-07 15:51:02 EST
This issue is still being actively worked for RHEL 4, although we don't have a
solution in hand to test yet.
Comment 12 dff 2004-12-08 15:26:44 EST
Here's a RHEL 4 pre-release test kernel that we believe fixes this issue:

http://people.redhat.com/linville/.libata.update

This should apply against FC3 also.  Please give it a try and report back with
your results.
Comment 13 Lars Damerow 2004-12-08 16:30:10 EST
Excellent! This works well for me on FC3. I'm hoping this fix will show up in
an errata kernel for FC2 as well--when would that happen?

Many thanks,
lars
Comment 14 Lars Damerow 2004-12-17 16:56:03 EST
I just tried out the kernel-2.6.9-1.9_FC2 package that's in testing and it works
very well for me.

Note You need to log in before you can comment on or make changes to this bug.