Bug 1379431 - PCP network.interface.speed values are inaccurate
Summary: PCP network.interface.speed values are inaccurate
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pcp
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nathan Scott
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-26 17:45 UTC by William Cohen
Modified: 2016-12-02 00:17 UTC (History)
9 users (show)

Fixed In Version: pcp-3.11.6-1.fc25 pcp-3.11.6-1.fc24 pcp-3.11.6-1.fc23 pcp-3.11.6-1.el5
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-24 16:29:26 UTC
Type: Bug


Attachments (Terms of Use)
typo fix (632 bytes, patch)
2016-11-02 17:11 UTC, Frank Ch. Eigler
no flags Details | Diff

Description William Cohen 2016-09-26 17:45:40 UTC
Description of problem:

The expected values of network.interface.speed for the gigabit ethernet on a laptop (Lenovo thinkpad W530)  look way off from the expected values.  Not having reasonable values for this metric makes it very difficult to determine the network interface utilization.


Version-Release number of selected component (if applicable):

$ rpm -q pcp
pcp-3.11.4-1.fc24.x86_64
$ uname -a
Linux santana 4.7.4-200.fc24.x86_64 #1 SMP Thu Sep 15 18:42:09 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

How reproducible: Every time


Steps to Reproduce:
1. Install pcp on fedora 24
2.  pmval network.interface.speed


Actual results:

$ pminfo -d network.interface.speed

network.interface.speed
    Data Type: float  InDom: 60.3 0xf000003
    Semantics: discrete  Units: Mbyte / sec

$ pmval network.interface.speed

metric:    network.interface.speed
host:      santana
semantics: discrete instantaneous value
units:     Mbyte / sec
samples:   all

       wlp3s0            lo    virbr0-nic        virbr0         vnet0           em1       docker0 
       2.146              ?     7.813E+04             ?     7.813E+04     7.813E+06             ? 
       2.146              ?     7.813E+04             ?     7.813E+04     7.813E+06             ? 


Expected results:

Would expect the results to be more like the rhel7 on a W541 machine like the following (enp0s25 interface):

$ rpm -q pcp
pcp-3.10.6-2.el7.x86_64
[wcohen@dhcp129-2 ~]$ uname -a
Linux dhcp129-2.rdu.redhat.com 3.10.0-482.el7.x86_64 #1 SMP Mon Aug 1 10:31:16 EDT 2016 x86_64 x86_64 x86_64 GNU/Linux
$  pmval network.interface.speed

metric:    network.interface.speed
host:      dhcp129-2.rdu.redhat.com
semantics: discrete instantaneous value
units:     Mbyte / sec
samples:   all

      enp0s25            lo    virbr0-nic        virbr0 
     119.2                ?        1.192              ?

Comment 1 William Cohen 2016-11-02 16:51:45 UTC
This issue was introduced between the 3.10.6 and the 3.11.  On a RHEL7 machine build the PCP 3.11 RPMs and install them.  Got the same incorrect results on RHEL7 using the newer PCP 3.11.

Comparing the values of broken/working it looks like PCP 3.11 has the values about 65K (~2^16) higher than the correct values.

When I reverted following patch in PCP the network.interface.speed values look more reasonable:

commit 9b616ace2284b622c4a8e7eae7766c11a2f0b9e8
Author: Nathan Scott <nathans@redhat.com>
Date:   Tue Sep 22 17:32:52 2015 +1000

    pmdalinux: correctly report high speed network link speeds
    
    The kernel ethtool ioctl interface was extended to allow speeds
    beyond 1Gbps to be reported - update to use this (back-compat)
    extension.  We only use this interface nowadays if the sysfs
    access to read interface speed fails.

Comment 2 Frank Ch. Eigler 2016-11-02 17:11:17 UTC
Created attachment 1216645 [details]
typo fix

Comment 3 Dave Brolley 2016-11-02 20:03:04 UTC
Fixed by upstream commit f1915a72d42be118f60aaf2018a0d5c22cee11a4

Comment 4 Fedora Update System 2016-11-16 05:12:15 UTC
pcp-3.11.6-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-d0ad9e5194

Comment 5 Fedora Update System 2016-11-16 05:13:39 UTC
pcp-3.11.6-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-15f10c1698

Comment 6 Fedora Update System 2016-11-16 05:15:46 UTC
pcp-3.11.6-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-a7626fa3f1

Comment 7 Fedora Update System 2016-11-16 05:16:40 UTC
pcp-3.11.6-1.el5 has been submitted as an update to Fedora EPEL 5. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-a7454a07e7

Comment 8 Fedora Update System 2016-11-16 20:25:30 UTC
pcp-3.11.6-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-a7626fa3f1

Comment 9 Fedora Update System 2016-11-17 03:53:01 UTC
pcp-3.11.6-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-15f10c1698

Comment 10 Fedora Update System 2016-11-17 03:57:31 UTC
pcp-3.11.6-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-d0ad9e5194

Comment 11 Fedora Update System 2016-11-17 12:17:42 UTC
pcp-3.11.6-1.el5 has been pushed to the Fedora EPEL 5 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-a7454a07e7

Comment 12 Fedora Update System 2016-11-24 16:29:26 UTC
pcp-3.11.6-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2016-11-24 20:28:51 UTC
pcp-3.11.6-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2016-11-25 07:23:04 UTC
pcp-3.11.6-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2016-12-02 00:17:46 UTC
pcp-3.11.6-1.el5 has been pushed to the Fedora EPEL 5 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.