This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 137969 - crashes openoffice-1.1.2-10 under certain circumstances
crashes openoffice-1.1.2-10 under certain circumstances
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-03 09:52 EST by Bill Huizinga
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.1.2-10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-11 06:03:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bug buddy backtrace of segfault (no debuginfo installed) (10.00 KB, text/plain)
2004-11-03 09:56 EST, Bill Huizinga
no flags Details
Oo crash trace (with debuginfo this time) (3.64 KB, text/plain)
2004-11-04 10:50 EST, Bill Huizinga
no flags Details
Doc that makes Oo crash (18.98 KB, application/octet-stream)
2004-11-04 12:36 EST, Bill Huizinga
no flags Details
patch to sw to fix this (813 bytes, patch)
2004-11-05 06:08 EST, Caolan McNamara
no flags Details | Diff

  None (edit)
Description Bill Huizinga 2004-11-03 09:52:58 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
I'm seeing a problem with the new -5 build of gtk2/gtk2-devel and
openoffice 1.1.2-10.

I have two documents (company sensitive, so I can't give them for bug
verification; sorry), one small and one large, both in .sxw format
(but they were both originally imported as .doc).  If I open the small
one using the recent files option, and the large one using the recent
files option, I get the attached crash (output by bug-buddy and less
than totally useful without the debug info).  This is 100% repeatable.
 
I believe this to be a gtk problem because it goes away if I downgrade
back to the -4 builds.

I'll add steps to reproduce if I can figure out how to make it happen
with some sanitary docs.

Version-Release number of selected component (if applicable):
gtk2-2.4.13-5

How reproducible:
Always

Steps to Reproduce:
1.only happens with certain documents
2.
3.
    

Actual Results:  Bug buddy comes up with some segfault info and Oo
dies (all of its windows).

Additional info:
Comment 1 Bill Huizinga 2004-11-03 09:56:11 EST
Created attachment 106123 [details]
bug buddy backtrace of segfault (no debuginfo installed)
Comment 2 Matthias Clasen 2004-11-03 10:56:54 EST
Hmm, I really can't see how this crash could be related to the changes
between -4 and -5 of the gtk2 package, since they were only relevant to 
filechooser typeahead.

We really need documents to reproduce this. Maybe you can try
stripping your documents from sensitive information and see if you can
still reproduce the crash. I got the hint that it would be good to try
and keep any 3D graphics, since OOo may use opengl to render them,
which could cause the crash...
Comment 3 Bill Huizinga 2004-11-04 10:47:58 EST
Tried the -9 build of gtk2 and the problem didn't go away, then when I
went back to -3 again (-4 was never on my system, sorry about that)
the problem didn't go away this time, so I think calling this a gtk2
bug was in error.
Comment 4 Bill Huizinga 2004-11-04 10:50:08 EST
Created attachment 106169 [details]
Oo crash trace (with debuginfo this time)
Comment 5 Bill Huizinga 2004-11-04 12:35:37 EST
I've also determined that the crash only occurs when the document
comes up in Online Layout viewing mode.  The attached doc makes it
crash everytime for me now, even if nothing else's been opened.
Comment 6 Bill Huizinga 2004-11-04 12:36:36 EST
Created attachment 106179 [details]
Doc that makes Oo crash
Comment 7 Caolan McNamara 2004-11-05 06:08:45 EST
Created attachment 106206 [details]
patch to sw to fix this

When flipping from online layout to normal a few times I got it to crash
consistently as well. The following patch to sw/source/core/layout/fly.cxx
fixes it. 1.9.58 doesn't apparently suffer from this.
Comment 8 Dan Williams 2004-11-05 10:19:45 EST
Ok, folding patch into -11
Comment 9 Caolan McNamara 2004-11-11 06:03:07 EST
seems ok in 1.1.2-11 (fc2/fc3 update)

Note You need to log in before you can comment on or make changes to this bug.