Bug 1379774 - ldbsearch error - indexed and full searches both failed!
Summary: ldbsearch error - indexed and full searches both failed!
Status: CLOSED DUPLICATE of bug 1396912
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sssd
Version: 7.3
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: SSSD Maintainers
QA Contact: Steeve Goveas
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-27 15:53 UTC by Amith
Modified: 2017-02-01 13:09 UTC (History)
11 users (show)

(edit)
See Doc Text for BZ#888739
Clone Of:
(edit)
Last Closed: 2017-02-01 13:09:19 UTC


Attachments (Terms of Use)

Description Amith 2016-09-27 15:53:25 UTC
Description of problem:
This issue was observed during the testing of BZ888739 on rhel-7.3. It is kind of a load testing on sssd when enumeration is ON against an ldap server with over 25000 users and bulk groups. With default timeout value, the sssd_be process gets KILLED and restarts, every 50-60 seconds.

The sysdb and timestamp cache gets updated, however when you run ldbsearch on them, the command fails with search error - Indexed and full searches both failed!

Version-Release number of selected component (if applicable):
sssd-1.14.0-43.el7

How reproducible:
Always

Steps to Reproduce:
1. Create 30,000 users in ldap server.

2. Set enumerate = true, in sssd.conf and restart the service.

3. Wait for some time and allow users to be cached.

4. Run ldbsearch on sysdb and timestamp cache:
  # ldbsearch -H /var/lib/sss/db/cache_LDAP.ldb


Actual results:
You should see error : Indexed and full searches both failed!

Expected results:


Additional info:

Comment 7 Lukas Slebodnik 2017-01-26 11:29:45 UTC
Upstream ticket:
https://fedorahosted.org/sssd/ticket/3266

Comment 8 Lukas Slebodnik 2017-01-26 11:30:46 UTC
master:
* e6a5f8c58539fc31fd81fac89cfc85703b4250ea
* 087162b85e191af51637904702813969b35eaadc 

sssd-1-14:
* 0606a71b698c4acf954ba7284e62acbd0aa5e52d
* 442985a7af2262fab57f56c7a8cd40af10081610

Comment 9 Jakub Hrozek 2017-02-01 13:09:19 UTC
I'm closing this bug as a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1396912 -- simply because they are both the same issue but #1396912 has the customer cases attached to it.

*** This bug has been marked as a duplicate of bug 1396912 ***


Note You need to log in before you can comment on or make changes to this bug.