Bug 137981 - The time estimate tracking is totally useless
Summary: The time estimate tracking is totally useless
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Bugzilla
Classification: Community
Component: Bugzilla General   
(Show other bugs)
Version: 3.2
Hardware: All
OS: Linux
medium
medium vote
Target Milestone: ---
Assignee: PnT DevOps Devs
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-03 16:26 UTC by William Cohen
Modified: 2013-06-24 03:02 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-02 14:07:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description William Cohen 2004-11-03 16:26:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.2)
Gecko/20040308

Description of problem:
I have attempted to use the time estimate and hours worked in the
bugzilla entries, but it unusable in it current state.

Estimates are just that estimates. The bugzilla tracking makes the
assumption that estimate==actual time required. There is no leeway to
revise the estimate based on new information or say that that 8 hours
were required to fix something that was estimated to take 4 (bugzilla
does not like negative time).

It really should be a history, show the revision of the estimates and
the actual amount of time take required regardless of the estimate.
This would allow get a better undertanding of the amount of work
required to fix particular problems.

As it stands right now I do bother to fill the estimated and actual
timed because I always get some kind of error when I do.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. make bugzilla entry and estimate the time required
2. open bug and claim it is completed with more time than original
estimate.
3.
    

Actual Results:  bugzilla complains about negative time.

Expected Results:  Be able to track estimated and actual time spent on
bug.

Additional info:

Comment 1 David Lawrence 2004-11-03 17:54:03 UTC
So you are saying that the estimated time field cannot be changed from
4 to 8 for example later once a better idea of time needed is decided?
You should be able to and it will go in the bug activity like any
other change so you can look back and see that it did in fact need
more time than originally though. If this is broken or incomplete I
will file a bug upstream since this is part of the main Bugzilla code
base and has not been altered by myself.

Comment 2 William Cohen 2004-11-04 15:56:28 UTC
I made a dummy bug
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=138084

To show the problem.

I initial set the estimate to 0.5 hours. Then attempted to put doen
the "Hours Worked" as 1 hour. I got a message.

 The Hours Left field requires a positive number.


How many estimate do you know that error on the high side? What I
would like to see is where there can be multiple lines of estimates, a
history of the estimates. Also allow the hours work to be an accurate
reflection of the time spent regardless of what it does to the "Hours
left"

Est.  	 Current Est.  	 Hours Worked  	Hours Left  %Complete  	 Gain
0.5      0.5 	         0.0 + 1	0 	0.0      -0.5

Basically have a new line each time a time field is change. Also have
dates on when the times related things are changes. In general give
better tracking on how much work required to fix bugs.


Comment 3 David Lawrence 2008-09-16 16:51:27 UTC
Red Hat Bugzilla is now using version 3.2 of the Bugzilla codebase and therefore this bug will need to be re-verified against the new release. With the updated code this bug may no longer be relevant or may have been fixed in the new code.
Updating bug version to 3.2.

Comment 4 Chris Ward 2009-04-02 06:10:11 UTC
Is this RFE still valid?

Comment 5 William Cohen 2009-04-02 13:42:12 UTC
Yes, this appears to still be valid.

Comment 6 William Cohen 2009-04-02 13:48:54 UTC
The behavior seems to be improved. Is there some way to get a get history of estimate data? If there is someway to get the history of the estimate/work data, then this can be closed.

Comment 7 Kevin Baker 2009-04-02 13:51:18 UTC
Did you try the history tab? Upper right on the "Modified" label

Comment 8 William Cohen 2009-04-02 14:07:02 UTC
Looks like the information can be obtained from the history.


Note You need to log in before you can comment on or make changes to this bug.