Bug 137996 - USB harddisk causes 100% cpu load when copying large files
USB harddisk causes 100% cpu load when copying large files
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-03 12:59 EST by Thomas Uebermeier
Modified: 2007-11-30 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-22 13:05:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Thomas Uebermeier 2004-11-03 12:59:56 EST
Description of problem: 
 
when copying a large file to a USB harddisk, the CPU load goes up to 
100% (used by usb-storage-1) 
Small files or using an older kernel (2.4.21-15.0.4) does not show 
this behavior. 
 
Version-Release number of selected component (if applicable): 
2.4.21-20 
 
How reproducible: 
Always. 
 
Steps to Reproduce: 
1. Attach USB storage device 
2. mount it 
3. copy a large file to the mounted device 
   
Actual results: 
system is stuck in 100% usage of usb-storage-1 
 
Expected results: 
 
 
Additional info: 
I know of the accuracy of "small" and "large" files :), but no 
testing was done where the threshold is.
Comment 3 Ernie Petrides 2004-11-03 16:39:25 EST
There were VM changes in U4 that might address this.  Does this problem
occur with the U4 beta kernel (2.4.21-23.EL)?
Comment 4 Larry Woodman 2004-11-03 16:54:40 EST
Thomas, please attach a "top" output and get several "AltSysrq W"
outputs when the system is in this state so I can see what process is
running and exactly what routines it is running.  Please use the
latest RHEL3-U4 kernel since we fixed a problem in prune_icache that
looks exactly like this.

That kernel is here: http://people.redhat.com/~lwoodman/RHEL3/

Larry Woodman
Comment 5 Dominique Mueller 2004-12-22 09:07:43 EST
Hi, I am the customer who had this problem and Thomas created this 
bugreport for me. As I was unable to install the beta U4 Kernel I 
installed the U4 release today - and the problem is gone.

Thanks & many greetings
Dominique
Comment 7 Ernie Petrides 2004-12-22 20:27:57 EST
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-550.html

Note You need to log in before you can comment on or make changes to this bug.