Bug 1379982 - Improve documentation of new public gfapi/upcall functions
Summary: Improve documentation of new public gfapi/upcall functions
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: GlusterFS
Classification: Community
Component: libgfapi
Version: mainline
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1344714
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-28 10:44 UTC by Niels de Vos
Modified: 2020-03-12 12:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-12 12:41:17 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Niels de Vos 2016-09-28 10:44:57 UTC
Description of problem:
http://review.gluster.org/14701 adds new public functions for gfapi applications that want to receive upcall events. These functions are sparsely documented, which need to improve.

Version-Release number of selected component (if applicable):
mainline (+backports)

Comment 1 Amar Tumballi 2019-07-15 05:42:40 UTC
There are more APIs added since this bug is filed. Would be great to fix them too.

Comment 2 Worker Ant 2020-03-12 12:41:17 UTC
This bug is moved to https://github.com/gluster/glusterfs/issues/927, and will be tracked there from now on. Visit GitHub issues URL for further details


Note You need to log in before you can comment on or make changes to this bug.