Bug 1380036 - tab name like "New Tab" are not automatly translated when you change language
Summary: tab name like "New Tab" are not automatly translated when you change language
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Jan Horak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-28 14:41 UTC by Quentin Tayssier
Modified: 2016-09-29 10:52 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-29 10:52:19 UTC
Type: Bug


Attachments (Terms of Use)

Description Quentin Tayssier 2016-09-28 14:41:17 UTC
Description of problem:

Already open tab name are not translated when you change language.

Version-Release number of selected component (if applicable):

firefox-49.0.2

How reproducible:
always

Steps to reproduce:
1 - Open one or more new tab (tested in english, french and japanese)
2 - Change language
3 - Logoff as asked
4 - Open firefox and restore page if needed


Actual results:
Previous new tab name are still in old language 

Expected results:
Previous new tab name to be in new language


Additional info:
If you click on the previous new tab, the name of this tab change to the good language.

Comment 1 Jan Horak 2016-09-29 10:52:19 UTC
If you mean a tab named "New Tab" (ie. without any loaded page) we can't do much about it. Last tabs are restored from profile_dir/sessionstore-backup/previous.js file where the "New Tab" string is stored along with tab url. That makes loading list of last opened tabs very fast. 

The downside is there does not do any translation during loading, but since frequent changing language for one's profile is minor use case therefore checking language changes each time Firefox is launched and rebuild tabs list would be making things slow, thus closing as won't fix.

If you meant different issue, please reopen and elaborate with more detail.


Note You need to log in before you can comment on or make changes to this bug.