Bug 1380098 - Add message to install ansible >= 2.2 on RHEL6 machines
Summary: Add message to install ansible >= 2.2 on RHEL6 machines
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gdeploy
Version: rhgs-3.2
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: RHGS 3.1.3 Async
Assignee: Sachidananda Urs
QA Contact: Manisha Saini
URL:
Whiteboard:
Depends On:
Blocks: 1351528
TreeView+ depends on / blocked
 
Reported: 2016-09-28 16:08 UTC by Sachidananda Urs
Modified: 2017-03-07 17:42 UTC (History)
5 users (show)

Fixed In Version: gdeploy-2.0.1-2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-07 11:34:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2017:0260 normal SHIPPED_LIVE Important: ansible and gdeploy security and bug fix update 2017-02-07 16:32:47 UTC

Description Sachidananda Urs 2016-09-28 16:08:44 UTC
Red Hat Gluster Storage does not ship Ansible on RHEL6 machines. If gdeploy is run on RHEL 6 machines, print a message to install Ansible >= 2.2

Comment 4 Manisha Saini 2016-10-13 19:03:33 UTC
Verified this on RHEL6

[root@server3 examples]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 6.8 (Santiago)

[root@server3 examples]# rpm -qa | grep ansible
[root@server3 examples]# rpm -qa | grep gdeploy
gdeploy-2.0.1-2.el6rhs.noarch


root@server4 ~]# rpm -qa | grep gluster
glusterfs-server-3.8.4-2.el6rhs.x86_64
glusterfs-geo-replication-3.8.4-2.el6rhs.x86_64
gluster-nagios-common-0.2.4-1.el6rhs.noarch
glusterfs-fuse-3.8.4-2.el6rhs.x86_64
glusterfs-libs-3.8.4-2.el6rhs.x86_64
glusterfs-api-3.8.4-2.el6rhs.x86_64
gluster-nagios-addons-0.2.8-1.el6rhs.x86_64
vdsm-gluster-4.16.30-1.5.el6rhs.noarch
glusterfs-3.8.4-2.el6rhs.x86_64
glusterfs-cli-3.8.4-2.el6rhs.x86_64
python-gluster-3.8.4-2.el6rhs.noarch
glusterfs-client-xlators-3.8.4-2.el6rhs.x86_64
glusterfs-rdma-3.8.4-2.el6rhs.x86_64

[root@server3 examples]# gdeploy -c gedply.conf 
Error: Please install Ansible(version >= 2.2) to use gdeploy.

Comment 5 Manisha Saini 2016-10-14 10:41:40 UTC
Running gdeploy on RHEL6 is giving Error message :Please install Ansible(version >= 2.2) to use gdeploy and gdeploy is not running.

Not able to find the Ansible >= 2.2 in EPEL repo.
Until i get the way of installing Ansible >=2.2 to run on RHEL6 ,keeping this bug ON_QA

Comment 6 Manisha Saini 2016-11-22 06:30:02 UTC
As Discussed,Its not feasible to get ansible with yum on Rhel6
And while installing gdeploy on rhel6,its installing without dependency on Ansible .
Based on Comment 4,Marking this Bug as verified

[root@dhcp37-156 examples]# gdeploy -c nfs_ganesha.conf 
Error: Please install Ansible(version >= 2.2) to use gdeploy.

[root@dhcp37-156 examples]# rpm -qa | grep gdeploy
gdeploy-2.0.1-3.el6rhs.noarch

[root@dhcp37-156 examples]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 6.8 (Santiago)

Comment 8 errata-xmlrpc 2017-02-07 11:34:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHSA-2017-0260.html


Note You need to log in before you can comment on or make changes to this bug.