Bug 1380190 - inserting encrypted usb stick results in non-functional, non-cancelable modal dialog asking for passphrase
Summary: inserting encrypted usb stick results in non-functional, non-cancelable modal...
Keywords:
Status: CLOSED DUPLICATE of bug 1377113
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F25FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2016-09-28 21:40 UTC by Chris Murphy
Modified: 2016-09-29 12:17 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-29 12:17:17 UTC


Attachments (Terms of Use)
journal.log (274.46 KB, text/x-vhdl)
2016-09-28 21:41 UTC, Chris Murphy
no flags Details

Description Chris Murphy 2016-09-28 21:40:08 UTC
Description of problem:

Upon inserting a LUKS encrypted USB stick (created with gnome-disk-utility f24), I see a modal dialog asking for the passphrase. I enter the passphrase, get dots, but neither the Cancel or Unlock buttons do anything.

Problem doesn't happen when booting with enforcing=0


Version-Release number of selected component (if applicable):

gnome-shell-3.22.0-1.fc25.x86_64
selinux-policy-3.13.1-214.fc25.noarch
storaged-2.6.2-2.fc25.x86_64



How reproducible:
F24, not reproducible
F25, default live boot, always reproducible
F25, enforcing=0, not reproducible


Steps to Reproduce:
1. F24 create an encrypted USB stick (gpt, luks, ext4) using gnome-disk-utility.
2. F25 live boot from USB stick created with dd, Fedora-Workstation-Live-x86_64-25-20160927.n.0.iso
3. At the desktop, insert the USB stick.

Actual results:

- dialog appears to enter passphrase
- cancel and unlock buttons do nothing, either when entering or not entering the correct passphrase

Expected results:

- the modal dialog should be cancellable
- the stick should be unlocked and mounted (like it is on F24)

Additional info:

Comment 1 Chris Murphy 2016-09-28 21:41:45 UTC
Created attachment 1205700 [details]
journal.log

This seems to be the only relevant AVC at the time of the problem.


[  139.331215] localhost.localdomain audit[1148]: USER_AVC pid=1148 uid=81 auid=4294967295 ses=4294967295 subj=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 msg='avc:  denied  { send_msg } for msgtype=method_return dest=:1.9 spid=1178 tpid=1139 scontext=system_u:system_r:policykit_t:s0 tcontext=system_u:system_r:devicekit_t:s0 tclass=dbus
                                                   exe="/usr/bin/dbus-daemon" sauid=81 hostname=? addr=? terminal=?'

Comment 2 Chris Murphy 2016-09-28 21:53:50 UTC
"All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test. "

Seems to me gnome-shell is an application, and modal dialogs with cancel buttons should cancel, but also it should be possible to unlock encrypted USB sticks. So it fails basic functionality in two ways.

Comment 3 Lukas Vrabec 2016-09-29 12:17:17 UTC

*** This bug has been marked as a duplicate of bug 1377113 ***


Note You need to log in before you can comment on or make changes to this bug.