Bug 138023 - 32-bit gtk2-devel does not exist on ia64 platform
Summary: 32-bit gtk2-devel does not exist on ia64 platform
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: firefox (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: ia64 Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-03 21:51 UTC by Jerry Jaskierny
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-30 18:30:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jerry Jaskierny 2004-11-03 21:51:18 UTC
Description of problem:
32-bit versions of 'gtk2-devel' do not exist, only 64-bit.


Steps to Reproduce:
1.  Check the ISO install image for the platform and see it not there.


Additional info:
This makes users unable to use Mozilla's firefox, as it looks for
32-bit libraries.

Comment 1 Matthias Clasen 2004-11-04 13:00:24 UTC
We do not do multilib -devel packages, since they are by definition
only needed for development. If firefox really needs gtk2-devel
something is wrong.

Comment 2 Jerry Jaskierny 2004-11-04 20:25:16 UTC
Ah, that's understandable.  But I /did/ notice some lib packages that
were build for x86_64 *and* i386.  Why is that?

When firefox was run, it complained that it needed
`libgtk-x11-2.0.so'.  A quick check showed that it existed in
`/usr/lib64', but not `/usr/lib'.  A quick check showed that those
libraries were found in the "gtk2-devel" package.

Comment 3 Matthias Clasen 2004-11-04 21:15:05 UTC
firefox should be happy with libgtk-x11-2.0.so.0 which is included in
the gtk2 package

Comment 4 Matthias Clasen 2004-12-16 16:39:48 UTC
If not NOTABUG, this must be a firefox issue

Comment 5 Warren Togami 2005-01-06 10:34:21 UTC
This bug is confusing.  Why is it reported against RHEL3?  firefox is
not a supported component of RHEL3.

Bug reporter mentions i386 and x86_64, but Summary indicates that this
is an ia64 problem?

Unless Jerry can explain the issue better, this should be closed NOTABUG.

Comment 6 Suzanne Hillman 2005-03-30 18:30:14 UTC
Due to lack of reply in almost two months, closing this NOTABUG as per comment #5.


Note You need to log in before you can comment on or make changes to this bug.