Bug 138025 - right-click on misspelled word crashes OOo writer and gnome session when autocorrect is turned on
right-click on misspelled word crashes OOo writer and gnome session when auto...
Status: CLOSED DUPLICATE of bug 124374
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dan Williams
Depends On:
  Show dependency treegraph
Reported: 2004-11-03 16:55 EST by Gabriel M. Elder
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-12-15 11:06:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Gabriel M. Elder 2004-11-03 16:55:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.4.1)

Description of problem:
When the autocorrect feature is turned on and i right-click (to bring
up the context menu) on a red-wavy underlined misspelled word in an
oowriter document, it instantly pegs the CPU, memory and swap usage.
This continues for about 5 minutes, with heavy disk thrashing, after
which the application and the entire gnome session crashes. I noticed
a similar problem with the previous packaged version, but not as
severe, because with that version the "thinking" only lasted ~30-60
seconds, and then the application and document editing would function
normally. If this is related to some kind of a memory leak, i would
rate this as a fairly significant problem, since this is a feature
that most gui word-processing users have come to take for granted.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Open a new document in oowriter.
2.Make sure the autocorrect feature is turned on. Type in an
intentionally misspelled word, so that autocorrect puts a red, wavy
underline underneath it.
3.Right-click once on the misspelled word.

Actual Results:  The cpu, memory, and swap usage overloads for a
while, resulting in a complete crash of my desktop session, after
which X/gdm may or may not be able to recover. Sometimes rebooting is
necessary at this point.

Expected Results:  The context menu should come up immediately,
displaying a short list of options, including suggested spelling

Additional info:

The machine in question has 256 Mb RAM, and a 633MHz celeron processor.

I checked on the OOo users mailing list, and a debian user recently
reported a crash bug with the spell checker in that distro-specific

In the meantime, i've downloaded the most recent (1.1.3) OOo release
and will install and test with that, in the hopes of isolating or
working around this problem. Perhaps this is unique to the
Fedora-specific OOo package?
Comment 1 Dan Williams 2004-11-29 21:47:13 EST
It most likely is unique to the Fedora packages since we package so
many dictionaries with OOo.  If you added all the dictionaries to a
stock OO.org download, it'd have the same problem.

*** This bug has been marked as a duplicate of 124374 ***

Note You need to log in before you can comment on or make changes to this bug.