Bug 1380391 - Traceback in metricd.log during service stop
Summary: Traceback in metricd.log during service stop
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-gnocchi
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 10.0 (Newton)
Assignee: Mehdi ABAAKOUK
QA Contact: Yurii Prokulevych
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-29 12:57 UTC by Yurii Prokulevych
Modified: 2016-12-14 16:06 UTC (History)
5 users (show)

Fixed In Version: openstack-gnocchi-3.0.1-0.20160922215118.31cdcb5.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 16:06:02 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 368410 None None None 2016-09-29 13:27:25 UTC

Description Yurii Prokulevych 2016-09-29 12:57:36 UTC
Description of problem:
-----------------------
During openstack-gnocchi-metricd stop traceback appears in metricd.log

2016-09-29 12:46:22.501 18238 INFO cotyledon [-] Caught SIGTERM signal, graceful exiting of service processing(1) [18238]
2016-09-29 12:46:22.502 18238 ERROR cotyledon [-] Unhandled exception
2016-09-29 12:46:22.502 18238 ERROR cotyledon Traceback (most recent call last):
2016-09-29 12:46:22.502 18238 ERROR cotyledon   File "/usr/lib/python2.7/site-packages/cotyledon/__init__.py", line 52, in _exit_on_exception
2016-09-29 12:46:22.502 18238 ERROR cotyledon     yield
2016-09-29 12:46:22.502 18238 ERROR cotyledon   File "/usr/lib/python2.7/site-packages/cotyledon/__init__.py", line 141, in _clean_exit
2016-09-29 12:46:22.502 18238 ERROR cotyledon     self.terminate()
2016-09-29 12:46:22.502 18238 ERROR cotyledon   File "/usr/lib/python2.7/site-packages/gnocchi/cli.py", line 107, in terminate
2016-09-29 12:46:22.502 18238 ERROR cotyledon     self.close_services()
2016-09-29 12:46:22.502 18238 ERROR cotyledon   File "/usr/lib/python2.7/site-packages/gnocchi/cli.py", line 291, in close_services
2016-09-29 12:46:22.502 18238 ERROR cotyledon     self.queue.close()
2016-09-29 12:46:22.502 18238 ERROR cotyledon AttributeError: 'AutoProxy[Queue]' object has no attribute 'close'
2016-09-29 12:46:22.502 18238 ERROR cotyledon 
2016-09-29 12:46:22.545 18235 DEBUG futurist.periodics [-] Stopped running 1 callbacks:
+--------------------------+------+----------+-----------+-----------------+-------------------------+
|           Name           | Runs | Failures | Successes | Average elapsed | Average elapsed waiting |
+--------------------------+------+----------+-----------+-----------------+-------------------------+
| gnocchi.cli.run_watchers | 2764 |    0     |    2764   |     0.0434s     |         0.0009s         |
+--------------------------+------+----------+-----------+-----------------+-------------------------+ _on_finish /usr/lib/python2.7/site-packages/futurist/periodics.py:707



Version-Release number of selected component (if applicable):
-------------------------------------------------------------
python-gnocchiclient-2.5.1-0.20160906152650.1bd3e90.el7ost.noarch
puppet-gnocchi-9.2.0-0.20160903224605.a403dbc.el7ost.noarch
openstack-gnocchi-carbonara-2.2.1-0.20160907155758.83dad26.el7ost.noarch
openstack-gnocchi-statsd-2.2.1-0.20160907155758.83dad26.el7ost.noarch
openstack-gnocchi-common-2.2.1-0.20160907155758.83dad26.el7ost.noarch
openstack-gnocchi-metricd-2.2.1-0.20160907155758.83dad26.el7ost.noarch
python-gnocchi-2.2.1-0.20160907155758.83dad26.el7ost.noarch
openstack-gnocchi-api-2.2.1-0.20160907155758.83dad26.el7ost.noarch
openstack-gnocchi-indexer-sqlalchemy-2.2.1-0.20160907155758.83dad26.el7ost.noarch

python-cotyledon-1.2.7-2.el7ost.noarch


Steps to Reproduce:
1. Deploy overcloud
2. Run systemctl stop openstack-gnocchi-metricd
3. Check metricd.log

Comment 1 Mehdi ABAAKOUK 2016-09-29 13:28:06 UTC
Already fixed in Gnocchi 3.0 upstream, next RDO->OSP10 sync will close this BZ

Comment 3 Yurii Prokulevych 2016-10-06 13:23:59 UTC
Verified with next package:
---------------------------
openstack-gnocchi-carbonara-3.0.1-0.20160923180636.c6b2c51.el7ost.noarch
openstack-gnocchi-statsd-3.0.1-0.20160923180636.c6b2c51.el7ost.noarch
openstack-gnocchi-common-3.0.1-0.20160923180636.c6b2c51.el7ost.noarch
openstack-gnocchi-metricd-3.0.1-0.20160923180636.c6b2c51.el7ost.noarch
puppet-gnocchi-9.4.0-1.el7ost.noarch
python-gnocchi-3.0.1-0.20160923180636.c6b2c51.el7ost.noarch
openstack-gnocchi-api-3.0.1-0.20160923180636.c6b2c51.el7ost.noarch
python-gnocchiclient-2.6.0-1.el7ost.noarch
openstack-gnocchi-indexer-sqlalchemy-3.0.1-0.20160923180636.c6b2c51.el7ost.noarch

Comment 7 errata-xmlrpc 2016-12-14 16:06:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.