Bug 1380395 - SSSD logs error upon adding [secrets] section.
Summary: SSSD logs error upon adding [secrets] section.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sssd
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: SSSD Maintainers
QA Contact: Amith
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-29 13:09 UTC by Amith
Modified: 2020-05-02 18:31 UTC (History)
8 users (show)

Fixed In Version: sssd-1.15.0-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 09:00:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github SSSD sssd issues 4240 None None None 2020-05-02 18:31:02 UTC
Red Hat Product Errata RHEA-2017:2294 normal SHIPPED_LIVE sssd bug fix and enhancement update 2017-08-01 12:39:55 UTC

Description Amith 2016-09-29 13:09:31 UTC
Description of problem:
When a secrets section is added to sssd.conf, SSSD service logs error: "Section [secrets] is not allowed. Check for typos."

Version-Release number of selected component (if applicable):
sssd-1.14.0-43.el7

How reproducible:
Always

Steps to Reproduce:
1. Edit sssd.conf file and add a secrets section as given below:
        [secrets]
        debug_level = 0xFFF0
        provider = local
2. Restart sssd service
3. Verify error log in sssd.log file

Actual results:
SSSD logs error message : "Section [secrets] is not allowed. Check for typos."

Expected results:
Section [secrets] shouldn't be considered invalid.

Comment 2 Jakub Hrozek 2016-09-29 14:11:07 UTC
Upstream ticket:
https://fedorahosted.org/sssd/ticket/3207

Comment 3 Jakub Hrozek 2016-10-03 13:39:53 UTC
master:
5e17edfc899d4fffb15f8300d15e4412af0f2f7d
ba96228853da4981cc5c12904c52cd7242417d6d
47aea8d2fc19fedb0a774f2e72c02ac2c87d1723

Comment 5 Amith 2017-05-30 19:04:17 UTC
Verified the bug on SSSD Version: sssd-1.15.2-37.el7.x86_64

Steps followed during verification:

1. Update sssd.conf with secrets section.
2. Restart sssd service 
3. Verify SSSD.log file for error: "Section [secrets] is not allowed. Check for typos."

The log error disappeared and issue is fixed.

Comment 6 errata-xmlrpc 2017-08-01 09:00:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:2294


Note You need to log in before you can comment on or make changes to this bug.