Bug 1380438 - java.lang.NoClassDefFoundError: jdk/nashorn/internal/runtime/ECMAException
Summary: java.lang.NoClassDefFoundError: jdk/nashorn/internal/runtime/ECMAException
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse
Version: 24
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Alexander Kurtakov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:234567181;
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-29 15:05 UTC by Alex Villacís Lasso
Modified: 2016-11-23 18:52 UTC (History)
8 users (show)

Fixed In Version: eclipse-4.6.1-6.fc24 eclipse-4.6.1-6.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-23 03:53:52 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (2.25 KB, text/plain)
2016-09-29 15:05 UTC, Alex Villacís Lasso
no flags Details

Description Alex Villacís Lasso 2016-09-29 15:05:49 UTC
Description of problem:
Trying to open a javascript source file in an existing project

Version-Release number of selected component:
eclipse-platform-4.6.1-2.fc24

Additional info:
reporter:       libreport-2.7.2
cmdline:        /usr/bin/java -Dosgi.requiredJavaVersion=1.8 -Xms128m -Xmx1024m -Dorg.eclipse.swt.browser.UseWebKitGTK=true -Dhelp.lucene.tokenizer=standard -XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith -XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init> -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding -XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile -XX:CompileCommand=exclude,org/eclipse/tycho/core/osgitools/EquinoxResolver,newState -Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins -Dp2.fragments=/usr/share/eclipse/droplets,/usr/lib64/eclipse/droplets -Declipse.p2.skipMovedInstallDetection=true -jar /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.3.200.v20160915-0852.jar -os linux -ws gtk -arch x86_64 -showsplash /usr/lib64/eclipse//plugins/org.eclipse.platform_4.6.1.v20160915-0852/splash.bmp -launcher /usr/lib64/eclipse/eclipse -name Eclipse --launcher.library /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.400.v20160915-0852/eclipse_1617.so -startup /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.3.200.v20160915-0852.jar -protect master --launcher.appendVmargs -exitdata a0003 -vm /usr/bin/java -vmargs -Dosgi.requiredJavaVersion=1.8 -Xms128m -Xmx1024m -Dorg.eclipse.swt.browser.UseWebKitGTK=true -Dhelp.lucene.tokenizer=standard -XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith -XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init> -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding -XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile -XX:CompileCommand=exclude,org/eclipse/tycho/core/osgitools/EquinoxResolver,newState -Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins -Dp2.fragments=/usr/share/eclipse/droplets,/usr/lib64/eclipse/droplets -Declipse.p2.skipMovedInstallDetection=true -jar /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.3.200.v20160915-0852.jar
eclipseplugin:  org.eclipse.core.jobs
executable:     /usr/lib64/eclipse/plugins/org.eclipse.core.jobs_3.8.0.v20160915-0852.jar
kernel:         4.7.4-200.fc24.x86_64
pkg_fingerprint: 73BD E983 81B4 6521
pkg_vendor:     Fedora Project
runlevel:       N 5
type:           libreport
uid:            1000

Truncated backtrace:
java.lang.NoClassDefFoundError: jdk/nashorn/internal/runtime/ECMAException
	at org.eclipse.wst.jsdt.core.dom.ASTParser.internalCreateAST(ASTParser.java:898)
	at org.eclipse.wst.jsdt.core.dom.ASTParser.createAST(ASTParser.java:673)
	at org.eclipse.wst.jsdt.internal.core.validation.JavaScriptValidator.validate(JavaScriptValidator.java:62)
	at org.eclipse.wst.validation.Validator$V2.validate(Validator.java:1159)
	at org.eclipse.wst.validation.internal.ValManager.validate(ValManager.java:704)
	at org.eclipse.wst.validation.internal.ValManager$1.visit(ValManager.java:665)
	at org.eclipse.wst.validation.internal.ValManager.accept(ValManager.java:810)
	at org.eclipse.wst.validation.internal.ValManager.validate(ValManager.java:669)
	at org.eclipse.wst.validation.internal.ValBuilderJob$Visitor.visit(ValBuilderJob.java:327)
	at org.eclipse.core.internal.events.ResourceDelta.accept(ResourceDelta.java:64)
	at org.eclipse.core.internal.events.ResourceDelta.accept(ResourceDelta.java:75)
	at org.eclipse.core.internal.events.ResourceDelta.accept(ResourceDelta.java:75)
	at org.eclipse.core.internal.events.ResourceDelta.accept(ResourceDelta.java:75)
	at org.eclipse.core.internal.events.ResourceDelta.accept(ResourceDelta.java:75)
	at org.eclipse.core.internal.events.ResourceDelta.accept(ResourceDelta.java:48)
	at org.eclipse.wst.validation.internal.ValBuilderJob.deltaBuild(ValBuilderJob.java:211)
	at org.eclipse.wst.validation.internal.ValBuilderJob.run(ValBuilderJob.java:179)
	at org.eclipse.wst.validation.internal.ValBuilderJob.runInWorkspace(ValBuilderJob.java:126)
	at org.eclipse.core.internal.resources.InternalWorkspaceJob.run(InternalWorkspaceJob.java:39)
	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
Caused by: java.lang.ClassNotFoundException: jdk.nashorn.internal.runtime.ECMAException cannot be found by org.eclipse.wst.jsdt.core_2.0.0.v201607072300
	at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:461)
	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:372)
	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:364)
	at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:161)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
	... 20 more

Comment 1 Alex Villacís Lasso 2016-09-29 15:05:55 UTC
Created attachment 1205975 [details]
File: backtrace

Comment 2 Alex Villacís Lasso 2016-09-29 15:11:59 UTC
This happened after updating to Eclipse Neon.1 in Fedora 24 x86_64:

eclipse-abrt-0.0.3-1.fc24.noarch
eclipse-anyedit-2.6.1-1.fc24.noarch
eclipse-cdt-9.0.0-1.fc24.x86_64
eclipse-changelog-5.0.0-2.fc24.noarch
eclipse-collabnet-merge-4.1.0-1.fc24.noarch
eclipse-dltk-5.5.0-3.fc24.noarch
eclipse-dltk-mylyn-5.5.0-3.fc24.noarch
eclipse-dltk-sh-5.5.0-3.fc24.noarch
eclipse-dtp-1.12.0-7.fc24.noarch
eclipse-e4-importer-0.2.0-0.2.gitb33919c.fc24.noarch
eclipse-ecf-core-3.13.2-1.fc24.x86_64
eclipse-egit-4.4.1-1.fc24.noarch
eclipse-emf-core-2.12.0-1.fc24.x86_64
eclipse-emf-runtime-2.12.0-1.fc24.noarch
eclipse-emf-sdk-2.12.0-1.fc24.noarch
eclipse-epic-0.6.57-2.fc24.noarch
eclipse-epp-logging-1.100.0-0.5.gitc6ce9f2.fc24.noarch
eclipse-equinox-osgi-4.6.1-2.fc24.x86_64
eclipse-filesystem-1.0-7.fc24.x86_64
eclipse-gef-3.11.0-1.fc24.noarch
eclipse-jdt-4.6.1-2.fc24.noarch
eclipse-jgit-4.4.1-1.fc24.noarch
eclipse-launchbar-2.0.0-0.1.git1f95c6c.fc24.noarch
eclipse-linuxtools-5.0.0-2.fc24.noarch
eclipse-manpage-5.0.0-2.fc24.noarch
eclipse-mpc-1.5.0-2.fc24.noarch
eclipse-mylyn-3.20.2-1.fc24.noarch
eclipse-mylyn-context-cdt-3.20.2-1.fc24.noarch
eclipse-mylyn-context-java-3.20.2-1.fc24.noarch
eclipse-mylyn-docs-wikitext-3.20.2-1.fc24.noarch
eclipse-mylyn-tasks-bugzilla-3.20.2-1.fc24.noarch
eclipse-mylyn-tasks-trac-3.20.2-1.fc24.noarch
eclipse-mylyn-tasks-web-3.20.2-1.fc24.noarch
eclipse-p2-discovery-4.6.1-2.fc24.noarch
eclipse-packagekit-0.2.0-4.fc24.noarch
eclipse-pde-4.6.1-2.fc24.x86_64
eclipse-pdt-4.0.0-2.fc24.noarch
eclipse-platform-4.6.1-2.fc24.x86_64
eclipse-pydev-5.1.2-1.fc24.x86_64
eclipse-remote-2.1.0-1.fc24.noarch
eclipse-rpm-editor-5.0.0-2.fc24.noarch
eclipse-rse-3.7.1-0.1.git671d63b.fc24.noarch
eclipse-subclipse-1.10.11-3.fc24.noarch
eclipse-subclipse-graph-1.10.11-3.fc24.noarch
eclipse-swt-4.6.1-2.fc24.x86_64
eclipse-tm-terminal-4.1.0-1.fc24.noarch
eclipse-webtools-common-3.8.0-1.fc24.noarch
eclipse-webtools-javaee-3.8.0-1.fc24.noarch
eclipse-webtools-servertools-3.8.0-1.fc24.noarch
eclipse-webtools-sourceediting-3.8.0-1.fc24.noarch
eclipse-xsd-2.12.0-1.fc24.noarch

Comment 3 Peter Verthez 2016-10-15 12:01:59 UTC
The same error occurs if you install eclipse-webtools-sourcediting and then you open a JavaScript file with the JavaScript editor.

I have the following Eclipse packages on Fedora 24:

eclipse-webtools-sourceediting-3.8.0-1.fc24.noarch
eclipse-launchbar-2.0.0-0.1.git1f95c6c.fc24.noarch
eclipse-collabnet-merge-4.1.0-1.fc24.noarch
eclipse-e4-importer-0.2.0-0.2.gitb33919c.fc24.noarch
eclipse-emf-runtime-2.12.0-1.fc24.noarch
eclipse-remote-2.1.0-1.fc24.noarch
eclipse-changelog-5.0.0-2.fc24.noarch
eclipse-mylyn-3.20.2-1.fc24.noarch
eclipse-xsd-2.12.0-1.fc24.noarch
eclipse-subclipse-1.10.11-3.fc24.noarch
eclipse-tm-terminal-4.1.0-1.fc24.noarch
eclipse-pde-4.6.1-2.fc24.x86_64
eclipse-jgit-4.4.1-1.fc24.noarch
eclipse-pydev-5.1.2-1.fc24.x86_64
eclipse-jdt-4.6.1-2.fc24.noarch
eclipse-webtools-common-3.8.0-1.fc24.noarch
eclipse-epp-logging-1.100.0-0.5.gitc6ce9f2.fc24.noarch
eclipse-cdt-9.0.0-1.fc24.x86_64
eclipse-egit-4.4.1-1.fc24.noarch
eclipse-webtools-servertools-3.8.0-1.fc24.noarch
eclipse-platform-4.6.1-2.fc24.x86_64
eclipse-swt-4.6.1-2.fc24.x86_64
eclipse-emf-core-2.12.0-1.fc24.x86_64
eclipse-epic-0.6.57-2.fc24.noarch
eclipse-subclipse-graph-1.10.11-3.fc24.noarch
eclipse-abrt-0.0.3-1.fc24.noarch
eclipse-rse-3.7.1-0.1.git671d63b.fc24.noarch
eclipse-linuxtools-5.0.0-2.fc24.noarch
eclipse-gef-3.11.0-1.fc24.noarch
eclipse-filesystem-1.0-7.fc24.x86_64
eclipse-ecf-core-3.13.2-1.fc24.x86_64
eclipse-mylyn-tasks-bugzilla-3.20.2-1.fc24.noarch
eclipse-equinox-osgi-4.6.1-2.fc24.x86_64
eclipse-mylyn-docs-wikitext-3.20.2-1.fc24.noarch

Fedora 24 is installed from scratch for me, not upgraded from earlier releases.

Comment 4 Peter Verthez 2016-10-15 12:26:30 UTC
Found a web page here: https://stackoverflow.com/questions/36317684/eclipse-jsdt-internal-error-noclassdeffounderror-jdk-nashorn-internal-runtime

From that I found that if you provide the following option to Eclipse:
-Dosgi.framework.extensions=org.eclipse.wst.jsdt.nashorn.extension

the problem does not occur

Comment 5 Roland Grunberg 2016-10-26 18:38:12 UTC
This should be fixed soon assuming adding that flag when webtools is not present will not bring down the entire Eclipse instance.

Comment 6 Fedora Update System 2016-11-14 10:28:18 UTC
eclipse-4.6.1-6.fc25 eclipse-xpand-2.2.0-1.fc25 eclipse-swtbot-2.5.0-3.fc25 eclipse-mylyn-3.20.2-2.fc25 eclipse-cdt-9.1.0-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-b63293acef

Comment 7 Fedora Update System 2016-11-14 10:28:25 UTC
eclipse-4.6.1-6.fc24 eclipse-xpand-2.2.0-1.fc24 eclipse-swtbot-2.5.0-3.fc24 eclipse-mylyn-3.20.2-2.fc24 eclipse-cdt-9.1.0-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-cd0af66bae

Comment 8 Fedora Update System 2016-11-15 02:30:09 UTC
eclipse-4.6.1-6.fc24, eclipse-cdt-9.1.0-2.fc24, eclipse-mylyn-3.20.2-2.fc24, eclipse-swtbot-2.5.0-3.fc24, eclipse-xpand-2.2.0-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-cd0af66bae

Comment 9 Fedora Update System 2016-11-15 13:27:02 UTC
eclipse-4.6.1-6.fc25, eclipse-cdt-9.1.0-2.fc25, eclipse-mylyn-3.20.2-2.fc25, eclipse-swtbot-2.5.0-3.fc25, eclipse-xpand-2.2.0-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-b63293acef

Comment 10 Fedora Update System 2016-11-23 03:53:52 UTC
eclipse-4.6.1-6.fc24, eclipse-cdt-9.1.0-2.fc24, eclipse-mylyn-3.20.2-2.fc24, eclipse-swtbot-2.5.0-3.fc24, eclipse-xpand-2.2.0-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2016-11-23 18:52:49 UTC
eclipse-4.6.1-6.fc25, eclipse-cdt-9.1.0-2.fc25, eclipse-mylyn-3.20.2-2.fc25, eclipse-swtbot-2.5.0-3.fc25, eclipse-xpand-2.2.0-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.