Bug 1380667 - Alarm-Notifer : 'AlarmNotifierService' object has no attribute '_title'
Summary: Alarm-Notifer : 'AlarmNotifierService' object has no attribute '_title'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-aodh
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 10.0 (Newton)
Assignee: Mehdi ABAAKOUK
QA Contact: Yurii Prokulevych
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-30 09:50 UTC by Yurii Prokulevych
Modified: 2016-12-14 16:06 UTC (History)
3 users (show)

Fixed In Version: openstack-aodh-3.0.0-0.20160921151816.bb5103e.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 16:06:25 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 367057 None None None 2016-09-30 09:52:19 UTC

Description Yurii Prokulevych 2016-09-30 09:50:16 UTC
Description of problem:
-----------------------
Traceback during openstack-aodh-notifier.service start

Sep 28 11:54:30 controller-0.localdomain systemd[1]: Starting OpenStack Alarm notifier service...
Sep 28 11:54:32 controller-0.localdomain aodh-notifier[11463]: Exception in thread Thread-3:
Sep 28 11:54:32 controller-0.localdomain aodh-notifier[11463]: Traceback (most recent call last):
Sep 28 11:54:32 controller-0.localdomain aodh-notifier[11463]: File "/usr/lib64/python2.7/threading.py", line 811, in __bootstrap_inner
Sep 28 11:54:32 controller-0.localdomain aodh-notifier[11463]: self.run()
Sep 28 11:54:32 controller-0.localdomain aodh-notifier[11463]: File "/usr/lib64/python2.7/threading.py", line 764, in run
Sep 28 11:54:32 controller-0.localdomain aodh-notifier[11463]: self.__target(*self.__args, **self.__kwargs)
Sep 28 11:54:32 controller-0.localdomain aodh-notifier[11463]: File "/usr/lib/python2.7/site-packages/cotyledon/__init__.py", line 128, in _run
Sep 28 11:54:32 controller-0.localdomain aodh-notifier[11463]: LOG.debug("Run service %s" % self._title)
Sep 28 11:54:32 controller-0.localdomain aodh-notifier[11463]: AttributeError: 'AlarmNotifierService' object has no attribute '_title'



Version-Release number of selected component (if applicable):
-------------------------------------------------------------

openstack-aodh-evaluator-3.0.0-0.20160907221145.3990c5b.el7ost.noarch
openstack-aodh-notifier-3.0.0-0.20160907221145.3990c5b.el7ost.noarch
openstack-aodh-common-3.0.0-0.20160907221145.3990c5b.el7ost.noarch
puppet-aodh-9.2.0-0.20160902115754.16ea22a.el7ost.noarch
openstack-aodh-listener-3.0.0-0.20160907221145.3990c5b.el7ost.noarch
python-aodhclient-0.6.0-0.20160826150744.65d2e62.el7ost.noarch
openstack-aodh-api-3.0.0-0.20160907221145.3990c5b.el7ost.noarch
python-aodh-3.0.0-0.20160907221145.3990c5b.el7ost.noarch

python-cotyledon-1.2.7-2.el7ost.noarch


Steps to Reproduce:
-------------------
1. Deploy overcloud
2. Run systemctl status -l openstack-aodh-notifier

Comment 1 Mehdi ABAAKOUK 2016-09-30 09:52:19 UTC
Fixed upstream in 3.0.0.0rc1 and downstream in openstack-aodh-3.0.0-0.20160921151816.bb5103e.el7ost

Comment 3 Yurii Prokulevych 2016-10-06 14:02:05 UTC
Verified with packages:
-----------------------
python-aodh-3.0.0-0.20160921151816.bb5103e.el7ost.noarch
openstack-aodh-notifier-3.0.0-0.20160921151816.bb5103e.el7ost.noarch
openstack-aodh-evaluator-3.0.0-0.20160921151816.bb5103e.el7ost.noarch
python-aodhclient-0.7.0-1.el7ost.noarch
puppet-aodh-9.4.0-1.el7ost.noarch
openstack-aodh-listener-3.0.0-0.20160921151816.bb5103e.el7ost.noarch
openstack-aodh-common-3.0.0-0.20160921151816.bb5103e.el7ost.noarch
openstack-aodh-api-3.0.0-0.20160921151816.bb5103e.el7ost.noarch

Comment 6 errata-xmlrpc 2016-12-14 16:06:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.