Bug 1380926 - RFE Build backintime with Qt5
Summary: RFE Build backintime with Qt5
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: backintime
Version: rawhide
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Raphael Groner
QA Contact: Fedora Extras Quality Assurance
URL: https://github.com/bit-team/backintim...
Whiteboard: https://copr.fedorainfracloud.org/cop...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-01 15:29 UTC by Raphael Groner
Modified: 2019-05-05 02:19 UTC (History)
4 users (show)

Fixed In Version: backintime-1.2.0-3.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-05 02:19:34 UTC


Attachments (Terms of Use)
bump to Qt5 (9.44 KB, patch)
2018-04-06 19:54 UTC, Raphael Groner
no flags Details | Diff
bump to Qt5 (9.44 KB, patch)
2018-04-09 18:41 UTC, Raphael Groner
projects.rg: review?
Details | Diff

Description Raphael Groner 2016-10-01 15:29:30 UTC
Description of problem:
Upstream moved to Qt5. Please build new packages with dependencies to Qt5.

Version-Release number of selected component (if applicable):
1.1.12+ (1.2.0 upcoming)

How reproducible:
-

Steps to Reproduce:
1. dnf install backintime
2.
3.

Actual results:
A binary with name backintime-qt4 gets installed in need for qt4 libraries.

Expected results:
A binary named backintime-qt gets installed with proper dependencies to Qt5.

Additional info:
https://github.com/bit-team/backintime/issues/518
https://github.com/bit-team/backintime/commit/32fd7de9421524c477fdb3018e3516cf72e264ec

Comment 1 hannes 2016-10-02 03:03:01 UTC
I am on holidays until mid october, will do it when back home.

Comment 2 Raphael Groner 2016-10-09 18:54:57 UTC
You may also want to fix the missing application icon. We accidently add a patch via sed, please remove those lines:

# Fix icon name.
sed -i 's/Icon=document-save/Icon=backintime/g' qt4/backintime-qt4.desktop
sed -i 's/Icon=document-save/Icon=backintime/g' qt4/backintime-qt4-root.desktop

There's no available icon named backintime. Not sure if I should report that in another bug.

Comment 3 Raphael Groner 2017-04-07 09:47:09 UTC
Later, when upstream decides to do next official release with support for Qt5.
https://github.com/bit-team/backintime/commit/1d63ced1d0025dc4ca18f595bf3e0c8b18b555d0

Comment 4 Raphael Groner 2017-08-21 11:30:22 UTC
I'm going to add a backintime-qt5 subpackage besides the legacy -qt4.

Comment 5 hannes 2017-08-21 12:14:26 UTC
Well, but only when they release a new Qt5 version. There's no reason for any activity as long as upstream hasn't done anything.

Comment 6 Raphael Groner 2017-08-21 12:58:46 UTC
Support for Qt5 is there since about one year.
https://github.com/bit-team/backintime/blame/b9c39138b84647d520a957231db16c4b3b8e3ffb/README.md#L13

Comment 7 hannes 2017-08-21 13:43:21 UTC
As I see it, this is only done in master and not yet in the released tarball. So please just be a bit more patient and don't raise this issue again and again without any change from upstream.
https://github.com/bit-team/backintime/compare/v1.1.20...master

Comment 8 Raphael Groner 2017-09-20 20:59:44 UTC
(In reply to hannes from comment #7)
> As I see it, this is only done in master and not yet in the released
> tarball.

Would it be okay for you if I update in rawhide and maybe F27 as currently in major testing to a snapshot build or pre-release?
https://fedoraproject.org/wiki/Packaging:Versioning#Snapshots

> So please just be a bit more patient and don't raise this issue again and 
> again without any change from upstream.

Fully ack to not touch other branches. Maybe worth trying on Copr then.

Comment 9 hannes 2017-09-21 07:27:14 UTC
(In reply to Raphael Groner from comment #8)
> (In reply to hannes from comment #7)
> > As I see it, this is only done in master and not yet in the released
> > tarball.
> 
> Would it be okay for you if I update in rawhide and maybe F27 as currently
> in major testing to a snapshot build or pre-release?
> https://fedoraproject.org/wiki/Packaging:Versioning#Snapshots
I would not use a pre-release snapshot in any official repository. Copr seems to be more appropriate. In my opinion backup software is far too important to just upgrade it without thorough testing. Additionally we would be stuck with the pre-release snapshot in f27 or f28 if there's no proper release from upstream. So copr is the only option.
> 
> > So please just be a bit more patient and don't raise this issue again and 
> > again without any change from upstream.
> 
> Fully ack to not touch other branches. Maybe worth trying on Copr then.

Comment 10 Raphael Groner 2017-09-21 21:50:14 UTC
Poking upstream.

Comment 11 Raphael Groner 2017-11-30 09:38:21 UTC
"BTW there is an AUR package building from my git master"
https://aur.archlinux.org/packages/backintime-git/
https://github.com/bit-team/backintime/issues/787

Comment 12 hannes 2017-11-30 09:43:27 UTC
As I said before, if you want to use git snapshots be my guest and just create a copr repo. Otherwise until upstream is not releasing anything new, I will not update the package.

Comment 13 Raphael Groner 2018-04-06 19:54:01 UTC
Created attachment 1418286 [details]
bump to Qt5

Done. This patch brings support for Qt5 and uses a recent git snapshot.
Unfortunately, copr does not work for me (unknown reason).

Comment 14 hannes 2018-04-07 13:12:18 UTC
Thanks a lot, looks really good. Will try it out.

Comment 15 Raphael Groner 2018-04-07 18:05:58 UTC
I'm glad you like it, enjoy. :)

Comment 16 hannes 2018-04-08 06:38:05 UTC
It didn't work yesterday and did not finish the snapshot. It took hours although the last snapshot was just done the day before.

Comment 17 Raphael Groner 2018-04-08 08:19:20 UTC
Have you tried from my copr?
https://copr.fedorainfracloud.org/coprs/raphgro/backintime-qt/packages/

Obviously, there's a bug in rawhide/F28 with systemd dependencies somehow.

Comment 18 hannes 2018-04-09 07:33:08 UTC
I used the f27 build from your copr and updated my installation. Is the Obsoletes/Provides and the subpackage stuff correct?
Does it need a systemd service to run in the latest version?

Comment 19 Raphael Groner 2018-04-09 18:33:29 UTC
BUILDSTDERR: error: line 161: Too many names: %posttrans common %systemd_postun_with_restart backintime-qt.service

How does %{?systemd_requires} work correctly?

Comment 20 Raphael Groner 2018-04-09 18:41:00 UTC
Created attachment 1419520 [details]
bump to Qt5

This patch builds latest git snapshot with Qt5.
Accidently uploaded a reverse patch, fixed.

Comment 21 Raphael Groner 2018-04-09 20:50:56 UTC
(In reply to hannes from comment #18)
> I used the f27 build from your copr and updated my installation. Is the
> Obsoletes/Provides and the subpackage stuff correct?

Just a guess. Added because backintime-qt is the (unofficial) snapshot build, see also Release tag. Official package is named backintime.

> Does it need a systemd service to run in the latest version?

It has always had support for systemd. Nothing changed compared to the official spec file, only thing is the adjustment to new guideline with %{?systemd_requires}, see comment 19.

Comment 23 Raphael Groner 2018-05-05 20:16:31 UTC
Copr has now successful builds for rawhide and F28, too.

Comment 24 Fedora Update System 2019-04-29 18:35:07 UTC
backintime-1.2.0-1.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-a1c4862b2e

Comment 25 Fedora Update System 2019-04-30 02:49:24 UTC
backintime-1.2.0-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-a1c4862b2e

Comment 26 Fedora Update System 2019-04-30 20:42:14 UTC
backintime-1.2.0-3.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-a1c4862b2e

Comment 27 Fedora Update System 2019-05-01 01:43:51 UTC
backintime-1.2.0-3.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-a1c4862b2e

Comment 28 Fedora Update System 2019-05-05 02:19:34 UTC
backintime-1.2.0-3.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.