Bug 138094 - Table Cells Contain Default Font at Far Right
Table Cells Contain Default Font at Far Right
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-04 11:26 EST by Stephen Lawrence Jr.
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-08 10:35:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
OO Bug example for insert row bug (6.11 KB, application/octet-stream)
2004-11-08 11:14 EST, Stephen Lawrence Jr.
no flags Details

  None (edit)
Description Stephen Lawrence Jr. 2004-11-04 11:26:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040922

Description of problem:
I have a table I am working on and I noticed that sometimes when I
inserted a new row, that new row would default to the default page
font?? instead of inherriting the font from the row above. 

I looked into it a little more and noticed that at the far right of
each cell, the default font is set. 

Version-Release number of selected component (if applicable):
openoffice.org-1.1.2-10.fc2

How reproducible:
Always

Steps to Reproduce:
1. Create a 5 column table
2. Enter text in each cell of a row using a different font than the
page default
3. Using your right-arrow key, move the cursor to the end of the text
in one of the cells. The very last position shows up as the page
default font.
4. No try to insert a new row
5. Every once in a while, the new row will have the default font set
in the cells instead of the font you chose.
    

Additional info:
Comment 1 Caolan McNamara 2004-11-05 09:20:28 EST
Once you are at the end of a paragraph (and a cell in a table is no
exception), pressing the right arrow again is a built-in shortcut for
"reset to underlying style." i.e. see
http://blogs.linux.ie/caolan/2004/08/05/writer-end-of-paragr/. Does
this explain the behaviour you see ?
Comment 2 Stephen Lawrence Jr. 2004-11-08 10:38:26 EST
The problem is not with the shortcut for "reset", the problem is that
when I insert a new row, the new row is created with the "reset" font
instead of the font of the current cell I am in when doing the insert.
Comment 3 Caolan McNamara 2004-11-08 10:51:40 EST
Can you create an example .sxw document with an example of a table
which will cause the problem and put your cursor into the place where
you will insert a new row and save the document and attach it here.
Writer saves the location of the cursor in the file, so if I open the
document here and do a insert->row without moving the cursor I'll see
exactly what you do.
Comment 4 Stephen Lawrence Jr. 2004-11-08 11:14:21 EST
Created attachment 106286 [details]
OO Bug example for insert row bug

Ok, I went to insert a row while I was in the middle of a cell, and the row
below was created with a different font. I attached the file.

Note You need to log in before you can comment on or make changes to this bug.