Bug 138101 - Process memory usage incorrect in top - RHEL3 U4 *Beta*
Process memory usage incorrect in top - RHEL3 U4 *Beta*
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Rik van Riel
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-04 11:58 EST by Juanjo Villaplana
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-03 19:52:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Juanjo Villaplana 2004-11-04 11:58:46 EST
Description of problem:

'top' is reporting incorrect values for memory usage of
several processes. It seems the same issue as bugzilla #137927

Version-Release number of selected component (if applicable):

kernel 2.4.21-22.ELsmp (the only rpm installed from RHEL3 U4 *Beta* on
this system)

How reproducible:

After 6 hours of uptime some processes are affected

Steps to Reproduce:
1. Run top, press 'M', check if processes are using an unreasonable
amount of RAM
2. Check process with ps -lfp
3. Compare proces's 'statm' and 'status'
  
Actual results:

[root@nuvol root]# uptime
 17:51:03  up 10:00, 21 users,  load average: 2.82, 3.47, 3.87
[root@nuvol root]# uname -a 
Linux nuvol.uji.es 2.4.21-22.ELsmp #1 SMP Tue Oct 19 17:15:49 EDT 2004
i686 i686 i386 GNU/Linux

Partial 'top' output in 'M' mode:
  PID USER     PRI  NI  SIZE  RSS SHARE STAT %CPU %MEM   TIME CPU COMMAND
 1547 root      16   0 10.4G  10G  2492 S     0.5 279.1   1:48   3
xmlrpcQuotas.py
 1121 root      19   0 3497M 3.4G   892 S     0.0 91.3   1:18   0 xinetd

[root@nuvol root]# ps -lfp 1121
F S UID        PID  PPID  C PRI  NI ADDR    SZ WCHAN  STIME TTY      
   TIME CMD
5 S root      1121     1  0  75   0    -   561 schedu 07:52 ?       
00:01:18 xinetd -stayalive -pidfile /var/run/xinetd.pid
[root@nuvol root]# cat /proc/1121/statm
896860 896860 223 740 64826 831294 10
[root@nuvol root]# cat /proc/1121/status 
Name:   xinetd
State:  S (sleeping)
Tgid:   1121
Pid:    1121
PPid:   1
TracerPid:      0
Uid:    0       0       0       0
Gid:    0       0       0       0
FDSize: 32
Groups: 
VmSize:     2244 kB
VmLck:         0 kB
VmRSS:      1044 kB
VmData:      328 kB
VmStk:        40 kB
VmExe:       144 kB
VmLib:      1680 kB
SigPnd: 0000000000000000
ShdPnd: 0000000000000000
SigBlk: 0000000000000000
SigIgn: 0000000000381000
SigCgt: 000000007fc3eeff
CapInh: 0000000000000000
CapPrm: 00000000fffffeff
CapEff: 00000000fffffeff

Expected results:

'statm' and 'status' /proc files should be coherent.

Additional info:
Comment 1 John Caruso 2004-12-03 15:29:56 EST
FYI, this looks like the same bug as bug 137927 (I just posted a 
comment on this one, and then saw this one as well in the search 
list).
Comment 2 Ernie Petrides 2004-12-03 19:52:14 EST
Thanks for the tip, John.  I agree, and have further concluded
that a fix for bug 137927 was committed to the RHEL3 U4 patch
pool Wednesday evening (in kernel version 2.4.21-27.EL).


*** This bug has been marked as a duplicate of 137927 ***
Comment 3 Ernie Petrides 2004-12-09 21:55:55 EST
The fix for this problem has also been committed to the RHEL3 U5
patch pool this evening (in kernel version 2.4.21-27.3.EL).
Comment 4 John Flanagan 2004-12-20 15:56:55 EST
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-550.html

Note You need to log in before you can comment on or make changes to this bug.