Bug 1381014 - Stuttering video playback in totem after update to 1.19-rc1
Summary: Stuttering video playback in totem after update to 1.19-rc1
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-02 10:33 UTC by Piotr Drąg
Modified: 2016-11-24 15:39 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-24 15:39:19 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
FreeDesktop.org 98030 0 None None None 2016-10-03 15:13:04 UTC

Description Piotr Drąg 2016-10-02 10:33:39 UTC
After updating to https://bodhi.fedoraproject.org/updates/FEDORA-2016-a5c3ebe67a video playback in totem stutters every few seconds. It doesn't happen with video playback (e.g. YouTube) in Firefox, and system generally works fine. Downgrading the update "fixes" the problem.

I'm using X11 with nouveau on a GT216M (GeForce GT 240M).

Comment 1 Hans de Goede 2016-10-02 16:52:34 UTC
Hi,

Thank you for filing a bug for this. So downgrading xorg-x11-server* and xorg-x11-drv* to the non updates-testing version fixes this ?

Or did you also downgrade any other packages ? There is nothing in the update which would explain this, although wait, maybe this nouveau commit:

https://cgit.freedesktop.org/nouveau/xf86-video-nouveau/commit/?id=1da8a937be19e41c51a3d516bd98cee988bca44b

Can you try downloading the 1.0.13 .src.rpm file from here:

http://koji.fedoraproject.org/koji/buildinfo?buildID=805646

And then do a "rpmbuild --rebuild ....src.rpm" on your system in a working state (so with the 1.18.4 rpms) and then upgrade to the build 1.0.13 rpm:

sudo rpm -Uvh ......x86_64.rpm

Restart X and see if that introduces the problem ? If we can pin the problem to being triggered by xorg-x11-drv-nouveau going from 1.0.12 to 1.0.13 without changing the rest of the xserver, then the commit I linked above is likely the culprit.

Regards,

Hans

Comment 2 Piotr Drąg 2016-10-02 17:32:48 UTC
(In reply to Hans de Goede from comment #1)
> Thank you for filing a bug for this. So downgrading xorg-x11-server* and
> xorg-x11-drv* to the non updates-testing version fixes this ?
> 

Yes, it does.

> Or did you also downgrade any other packages ?

I also downgraded the unpushed nss update, but I don't think it can be related.

> Restart X and see if that introduces the problem ? If we can pin the problem
> to being triggered by xorg-x11-drv-nouveau going from 1.0.12 to 1.0.13
> without changing the rest of the xserver, then the commit I linked above is
> likely the culprit.
> 

I did that and unfortunately the problem didn't appear - videos are smooth as they should be.

Comment 3 Hans de Goede 2016-10-03 07:00:45 UTC
(In reply to Piotr Drąg from comment #2)
> I did that and unfortunately the problem didn't appear - videos are smooth
> as they should be.

Hmm, can you try installing the 1.19 packages and then use the modesetting driver? After the update do:

rpm -e xorg-x11-drivers xorg-x11-drv-nouveau

To remove nouveau (the xorg-x11-drivers pkg is a meta pkg requiring it) and then log into X again.
"xrandr --listproviders" should show "modesetting" at the end of its output now.

Talking about xrandr --listproviders, can you provide xrandr --listproviders output please ?

Comment 4 Piotr Drąg 2016-10-03 10:11:21 UTC
(In reply to Hans de Goede from comment #3)
> Hmm, can you try installing the 1.19 packages and then use the modesetting
> driver?

The issue is not reproduced when using the modesetting driver.

> Talking about xrandr --listproviders, can you provide xrandr --listproviders
> output please ?

On nouveau:

Providers: number : 1
Provider 0: id: 0x64 cap: 0x7, Source Output, Sink Output, Source Offload crtcs: 2 outputs: 3 associated providers: 0 name:nouveau

On modesetting:

Providers: number : 1
Provider 0: id: 0x44 cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 2 outputs: 3 associated providers: 0 name:modesetting

Comment 5 Hans de Goede 2016-10-03 14:52:01 UTC
Hi,

Ok, so you do not have hybrid gfx in your laptop, good, and this does seem to be xf86-video-nouveau related.

xf86-video-nouveau has pretty good upstream maintenance, can you please file a bug here:

https://bugs.freedesktop.org/enter_bug.cgi?product=xorg

And pick Driver/nouveau as component ?

Important things to mention are:

1) This bug
2) That xf86-video-nouveau-1.0.13 does not show this problem with xserver-1.18.4, but does show it with xserver-1.19-rc1
3) That using the modesetting driver with xserver-1.19-rc1 makes the problem go away.

Thank you.

Regards,

Hans

Comment 6 Piotr Drąg 2016-10-03 15:13:04 UTC
Thank you very much for your help. I reported the problem upstream:

https://bugs.freedesktop.org/show_bug.cgi?id=98030

Comment 7 Piotr Drąg 2016-11-24 15:39:19 UTC
Fixed in 1.19 RC2.


Note You need to log in before you can comment on or make changes to this bug.