Bug 1381045 - xorg-x11-drv-qxl update lets sddm coredump
Summary: xorg-x11-drv-qxl update lets sddm coredump
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-qxl
Version: 25
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Alon Levy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: Accepted0Day
Depends On:
Blocks: F25BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2016-10-02 18:04 UTC by Raphael Groner
Modified: 2016-10-19 17:28 UTC (History)
20 users (show)

Fixed In Version: xorg-x11-drv-qxl-0.1.4-10.20160929gite13d28ee.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-19 17:28:15 UTC


Attachments (Terms of Use)
Xorg.0.log with segfault on QXL (11.96 KB, text/plain)
2016-10-04 12:15 UTC, Laszlo Ersek
no flags Details

Description Raphael Groner 2016-10-02 18:04:59 UTC
Description of problem:
xorg-x11-drv-qxl update lets sddm coredump.

Version-Release number of selected component (if applicable):
xorg-x11-drv-qxl-0.1.4-9.20160929gite13d28ee.fc25.x86_64
sddm-0.13.0-7.fc25.x86_64

How reproducible:
yes

Steps to Reproduce:
1. boot into f25
2. dnf update --enablerepo updates-testing
3.

Actual results:
black screen

Expected results:
sddm shows the normal login screen

Additional info:
A downgrade of all xorg-x11 packages fixes this bug. Alternatively, the option to switch from QXL to VGA graphics helps, too.

-- Reboot --
Jul 16 12:44:45 builder24 systemd[1]: Started Simple Desktop Display Manager.
Jul 16 12:44:46 builder24 sddm-helper[804]: pam_unix(sddm-greeter:session): session opened for user sddm by (uid=0)
Jul 16 18:54:59 builder24 sddm[746]: Authentication error: "Process crashed"
Jul 16 18:54:59 builder24 sddm[746]: Auth: sddm-helper crashed (exit code 15)
Jul 16 18:54:59 builder24 sddm[746]: Authentication error: "Process crashed"
Jul 16 18:54:59 builder24 sddm[746]: Auth: sddm-helper exited with 15
Jul 16 18:54:59 builder24 systemd[1]: Stopping Simple Desktop Display Manager...
Jul 16 18:54:59 builder24 sddm[746]: Signal received: SIGTERM
Jul 16 18:54:59 builder24 sddm[746]: QProcess: Destroyed while process ("/usr/libexec/sddm-helper") is still running.
Jul 16 18:54:59 builder24 systemd[1]: Stopped Simple Desktop Display Manager.
-- Reboot --

Comment 1 Raphael Groner 2016-10-02 18:07:42 UTC
CC maintainers of sddm

Comment 2 Raphael Groner 2016-10-02 18:18:29 UTC
Proposing as a blocker:

Failure of test case desktop login:
The login manager should display all regular user accounts, but not the root account, for selection.
You should be able to log in with each configured user account and the correct password. 

http://fedoraproject.org/wiki/QA:Testcase_desktop_login

- Both is not possible with QXL, the user sees a black screen only.

Comment 3 Chris Murphy 2016-10-02 19:57:10 UTC
Does it work with the virtio video driver? I'm not sure what's required to work video driver wise for VM. Tentatively though I'm +1 beta blocker if this always happens with KDE in a libvirt VM.

Comment 4 Raphael Groner 2016-10-02 20:55:21 UTC
It works if I switch from QXL to VGA in virt-manager, the guest xorg then chooses framebuffer and vesa driver instead of the qxl one.

Comment 5 Hans de Goede 2016-10-03 06:44:26 UTC
HI,

(In reply to Raphael Groner from comment #2)
> Proposing as a blocker:
> 
> Failure of test case desktop login:
> The login manager should display all regular user accounts, but not the root
> account, for selection.
> You should be able to log in with each configured user account and the
> correct password. 
> 
> http://fedoraproject.org/wiki/QA:Testcase_desktop_login
> 
> - Both is not possible with QXL, the user sees a black screen only.

If this only happens with the updated 1.19 xorg-x11-xserver* pkgs (and matching driver rebuilds) then this is not a beta blocker, as those are sitting in updates testing and won't leave updates-testing until after the beta.

We still need to fix this of course.

Regards,

Hans

Comment 6 Raphael Groner 2016-10-03 09:08:37 UTC
Well, the bodhi update has already a karma value of +4. I've commented there.

Comment 7 Raphael Groner 2016-10-03 16:51:20 UTC
Tested with both sddm 0.13.0-7 and 0.14.0-1 (currently in testing) and got a black screen when QXL is chosen in virt-manager. It's clearly xorg to blame.

Comment 8 Petr Schindler 2016-10-03 16:53:06 UTC
Discussed at 2016-10-03 blocker review meeting: [1]. 

This bug was accepted as 0-day blocker: the affected package is in updates-testing, so the Beta compose is not affected, but Beta installs will break on first update. So we accept this as a 0-day blocker, meaning (for Beta) a fixed package must be added to the update or the update must be unpushed, by go/no-go day

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2016-10-03/

Comment 9 Laszlo Ersek 2016-10-04 12:15:14 UTC
Created attachment 1207154 [details]
Xorg.0.log with segfault on QXL

I can reproduce this issue. The X server crashes with a segfault. Please see the complete log file attached. I plan to look into this a bit more.

Comment 10 Hans de Goede 2016-10-04 12:19:20 UTC
Hi,

(In reply to Laszlo Ersek from comment #9)
> Created attachment 1207154 [details]
> Xorg.0.log with segfault on QXL
> 
> I can reproduce this issue. The X server crashes with a segfault. Please see
> the complete log file attached. I plan to look into this a bit more.

No need Christopher Fergau and I already debugged this this morning, a qxl driver patch fixing this has been send to xorg-devel and a build fixing this is building right now:

http://koji.fedoraproject.org/koji/taskinfo?taskID=15936163

Regards,

Hans

Comment 11 Laszlo Ersek 2016-10-04 12:24:40 UTC
Thank you. (If only every BZ worked like this after my first comment... I can dream :) *chuckle*) I'll report back with test results. Thanks!

Comment 12 Hans de Goede 2016-10-04 12:25:54 UTC
And that build failed, it seems that anytime you change builds in an update bodhi removes all pkgs in that update from the buildroot overrides. Grrr.

Waiting for new buildroot overrides now.

Comment 13 Raphael Groner 2016-10-05 09:13:21 UTC
It seems the Debian guys found the same or a similiar bug, with sddm 0.13.0:

https://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg1458594.html

Comment 14 Hans de Goede 2016-10-05 09:16:05 UTC
(In reply to Raphael Groner from comment #13)
> It seems the Debian guys found the same or a similiar bug, with sddm 0.13.0:
> 
> https://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg1458594.
> html

That looks like a different bug, no mention of qxl and startx does work for them, where as the xserver with qxl was completely broken by the 1.19 update including startx.

Comment 15 Kamil Páral 2016-10-05 10:02:09 UTC
xorg-x11-drv-qxl-0.1.4-10.20160929gite13d28ee.fc25 from https://bodhi.fedoraproject.org/updates/FEDORA-2016-a5c3ebe67a seems to fix the bug.

Comment 16 Laszlo Ersek 2016-10-05 19:21:19 UTC
(In reply to Kamil Páral from comment #15)
> xorg-x11-drv-qxl-0.1.4-10.20160929gite13d28ee.fc25 from
> https://bodhi.fedoraproject.org/updates/FEDORA-2016-a5c3ebe67a seems to fix
> the bug.

For me too. Thanks.

Comment 17 Fedora Update System 2016-10-05 22:25:06 UTC
libXfont2-2.0.1-2.fc25, tigervnc-1.7.0-3.fc25, xorg-x11-drivers-7.7-18.fc25, xorg-x11-drv-amdgpu-1.1.2-3.20160929git97d7386c.fc25, xorg-x11-drv-armsoc-1.4.0-3.20160929.fc25, xorg-x11-drv-ati-7.7.1-1.20160928git3fc839ff.fc25, xorg-x11-drv-dummy-0.3.6-26.fc25, xorg-x11-drv-evdev-2.10.4-1.fc25, xorg-x11-drv-fbdev-0.4.3-25.fc25, xorg-x11-drv-fbturbo-0.5.1-0.8.20150221.fc25, xorg-x11-drv-freedreno-1.4.0-3.20160929.fc25, xorg-x11-drv-geode-2.11.18-2.fc25, xorg-x11-drv-intel-2.99.917-26.20160929.fc25, xorg-x11-drv-ivtv-1.2.0-0.22.fc25, xorg-x11-drv-libinput-0.19.1-3.20160929.fc25, xorg-x11-drv-nouveau-1.0.13-1.fc25, xorg-x11-drv-omap-0.4.4-3.fc25, xorg-x11-drv-openchrome-0.5.0-2.fc25, xorg-x11-drv-opentegra-0.7.0-8.fc25, xorg-x11-drv-qxl-0.1.4-10.20160929gite13d28ee.fc25, xorg-x11-drv-sisusb-0.9.6-24.fc25, xorg-x11-drv-synaptics-1.8.99.1-2.20160929git48632211.fc25, xorg-x11-drv-v4l-0.2.0-47.fc25, xorg-x11-drv-vesa-2.3.2-25.fc25, xorg-x11-drv-vmware-13.0.2-12.20150211git8f0cf7c.fc25, xorg-x11-drv-voodoo-1.2.5-25.fc25, xorg-x11-drv-wacom-0.33.0-2.20160929gitb61d1711.fc25, xorg-x11-font-utils-7.5-32.fc25, xorg-x11-proto-devel-7.7-20.fc25, xorg-x11-server-1.19.0-0.2.20160929.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-a5c3ebe67a

Comment 18 Raphael Groner 2016-10-06 18:04:33 UTC
QXL works again. Thanks for the investigation and the fast fix.

Comment 19 Fedora Update System 2016-10-11 04:57:28 UTC
libXfont2-2.0.1-2.fc25, tigervnc-1.7.0-3.fc25, xorg-x11-drivers-7.7-18.fc25, xorg-x11-drv-amdgpu-1.1.2-3.20160929git97d7386c.fc25, xorg-x11-drv-armsoc-1.4.0-3.20160929.fc25, xorg-x11-drv-ati-7.7.1-1.20160928git3fc839ff.fc25, xorg-x11-drv-dummy-0.3.6-26.fc25, xorg-x11-drv-evdev-2.10.4-1.fc25, xorg-x11-drv-fbdev-0.4.3-25.fc25, xorg-x11-drv-fbturbo-0.5.1-0.8.20150221.fc25, xorg-x11-drv-freedreno-1.4.0-3.20160929.fc25, xorg-x11-drv-geode-2.11.18-2.fc25, xorg-x11-drv-intel-2.99.917-26.20160929.fc25, xorg-x11-drv-ivtv-1.2.0-0.22.fc25, xorg-x11-drv-libinput-0.19.1-3.20160929.fc25, xorg-x11-drv-nouveau-1.0.13-1.fc25, xorg-x11-drv-omap-0.4.4-3.fc25, xorg-x11-drv-openchrome-0.5.0-2.fc25, xorg-x11-drv-opentegra-0.7.0-8.fc25, xorg-x11-drv-qxl-0.1.4-10.20160929gite13d28ee.fc25, xorg-x11-drv-sisusb-0.9.6-24.fc25, xorg-x11-drv-synaptics-1.8.99.2-2.fc25, xorg-x11-drv-v4l-0.2.0-47.fc25, xorg-x11-drv-vesa-2.3.2-25.fc25, xorg-x11-drv-vmware-13.0.2-12.20150211git8f0cf7c.fc25, xorg-x11-drv-voodoo-1.2.5-25.fc25, xorg-x11-drv-wacom-0.33.0-2.20160929gitb61d1711.fc25, xorg-x11-font-utils-7.5-32.fc25, xorg-x11-proto-devel-7.7-20.fc25, xorg-x11-server-1.19.0-0.2.20160929.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-a5c3ebe67a

Comment 20 Fedora Update System 2016-10-19 17:28:15 UTC
libXfont2-2.0.1-2.fc25, tigervnc-1.7.0-3.fc25, xorg-x11-drivers-7.7-18.fc25, xorg-x11-drv-amdgpu-1.1.2-3.20160929git97d7386c.fc25, xorg-x11-drv-armsoc-1.4.0-3.20160929.fc25, xorg-x11-drv-ati-7.7.1-1.20160928git3fc839ff.fc25, xorg-x11-drv-dummy-0.3.6-26.fc25, xorg-x11-drv-evdev-2.10.4-1.fc25, xorg-x11-drv-fbdev-0.4.3-25.fc25, xorg-x11-drv-fbturbo-0.5.1-0.8.20150221.fc25, xorg-x11-drv-freedreno-1.4.0-3.20160929.fc25, xorg-x11-drv-geode-2.11.18-2.fc25, xorg-x11-drv-intel-2.99.917-26.20160929.fc25, xorg-x11-drv-ivtv-1.2.0-0.22.fc25, xorg-x11-drv-libinput-0.19.1-3.20160929.fc25, xorg-x11-drv-nouveau-1.0.13-1.fc25, xorg-x11-drv-omap-0.4.4-3.fc25, xorg-x11-drv-openchrome-0.5.0-2.fc25, xorg-x11-drv-opentegra-0.7.0-8.fc25, xorg-x11-drv-qxl-0.1.4-10.20160929gite13d28ee.fc25, xorg-x11-drv-sisusb-0.9.6-24.fc25, xorg-x11-drv-synaptics-1.8.99.2-2.fc25, xorg-x11-drv-v4l-0.2.0-47.fc25, xorg-x11-drv-vesa-2.3.2-25.fc25, xorg-x11-drv-vmware-13.0.2-12.20150211git8f0cf7c.fc25, xorg-x11-drv-voodoo-1.2.5-25.fc25, xorg-x11-drv-wacom-0.33.0-2.20160929gitb61d1711.fc25, xorg-x11-font-utils-7.5-32.fc25, xorg-x11-proto-devel-7.7-20.fc25, xorg-x11-server-1.19.0-0.2.20160929.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.