Bug 138105 - setkey calls for manual keying choke
Summary: setkey calls for manual keying choke
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: ipsec-tools   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC3Blocker
TreeView+ depends on / blocked
 
Reported: 2004-11-04 17:27 UTC by Ulrich Drepper
Modified: 2014-03-17 02:50 UTC (History)
1 user (show)

Fixed In Version: 0.3.3-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-04 20:30:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to remove the comments (1.29 KB, patch)
2004-11-04 17:27 UTC, Ulrich Drepper
no flags Details | Diff

Description Ulrich Drepper 2004-11-04 17:27:03 UTC
Description of problem:
The setkey calls used in ifup-ipsec use comments (lines introduced by #).  At
least the setkey distributes in FC3 does not understand this and there are no
comments in the more commonly used setkey calls.

Version-Release number of selected component (if applicable):
initscripts-7.93.2-1

How reproducible:
always

Steps to Reproduce:
1.define host-to-host IPsec connection with manual key
2.restart network
3.
  
Actual results:
setkey -D shows nothing

Expected results:
setkey -D should show appropriate parameters

Additional info:
I'll add the bug to the blocker list since some functionality is completely
non-operational.  But the fact that this has not been noticed earlier might
suggest it is not that important.

Comment 1 Ulrich Drepper 2004-11-04 17:27:03 UTC
Created attachment 106178 [details]
Patch to remove the comments

Comment 2 Bill Nottingham 2004-11-04 19:43:47 UTC
This should be fixed to make ipsec-tools less braindamaged; it worked
fine with the previous version.

Comment 3 Bill Nottingham 2004-11-04 19:54:02 UTC
   Configuration syntax
     With -c or -f on the command line, setkey accepts the following
configu-
     ration syntax.  Lines starting with hash signs (â#â) are treated
as com-
     ment lines.


Ergo, setkey is broken.

Comment 4 Bill Nottingham 2004-11-04 20:30:40 UTC
Fixed in 0.3.3-2. Off to figure out what the upstream maintainer is
thinking.


Note You need to log in before you can comment on or make changes to this bug.