Bug 138106 - Empty reporter, assigned_to fields when person has no real name.
Empty reporter, assigned_to fields when person has no real name.
Status: CLOSED RAWHIDE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.18
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: David Lawrence
David Lawrence
:
Depends On:
Blocks: BZ_218_Beta3
  Show dependency treegraph
 
Reported: 2004-11-04 12:49 EST by David Lawrence
Modified: 2007-04-18 13:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-10 14:38:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Lawrence 2004-11-04 12:49:19 EST
Description of problem:
https://bugzilla.redhat.com/beta2/show_bug.cgi?id=137459

Note the empty reporter field.
In the old bugzilla, we get the reporters email address.

Because of sanitizing email address for spam, if an account doesnt
have a real name, then nothing is shown. I suggest showing the email
address when no real name is there but create a
Bugzilla::Util::SanitizeEmail() function will replace for example,

foo@bar.com

with 

foo_AT_bar.com

or similar.
Comment 1 David Lawrence 2004-11-10 14:38:57 EST
Fixed in CVS.

Note You need to log in before you can comment on or make changes to this bug.