Bug 1381187 - tar 1.29 broke --exclude
Summary: tar 1.29 broke --exclude
Keywords:
Status: CLOSED DUPLICATE of bug 1337864
Alias: None
Product: Fedora
Classification: Fedora
Component: tar
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pavel Raiskup
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-03 10:59 UTC by Kamil Páral
Modified: 2016-10-03 11:27 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-03 11:27:28 UTC
Type: Bug


Attachments (Terms of Use)

Description Kamil Páral 2016-10-03 10:59:33 UTC
Description of problem:

With tar-2:1.28-7.fc24:

$ tar cvf test.tar /home/kparal/.thumbnails --exclude .thumbnails
$

With tar-2:1.29-1.fc25:

$ tar cvf test.tar /home/kparal/.thumbnails --exclude .thumbnails
tar: Removing leading `/' from member names
/home/kparal/.thumbnails/
/home/kparal/.thumbnails/normal/
/home/kparal/.thumbnails/normal/edcfcea2d4e30b97f176cb556cf14816.png
/home/kparal/.thumbnails/normal/677c5741bc313b8959672d7b835ca18f.png
/home/kparal/.thumbnails/normal/639740e03397914475d64b36abb63052.png
...
$


Version-Release number of selected component (if applicable):
tar-2:1.29-1.fc25
tested on F25 system (downgraded tar to .fc24 package to verify it was working before)

How reproducible:
always

Steps to Reproduce:
1. see description

Comment 1 Pavel Raiskup 2016-10-03 11:27:28 UTC
Thanks for the report, but unfortunately, this is expected change.  For more
info, have a look at:
info tar -n "Position-Sensitive Options"

*** This bug has been marked as a duplicate of bug 1337864 ***


Note You need to log in before you can comment on or make changes to this bug.