Bug 13812 - Unable to use CD-ROM as install media
Unable to use CD-ROM as install media
Status: CLOSED DUPLICATE of bug 17472
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
alpha Linux
medium Severity high
: ---
: ---
Assigned To: Matt Wilson
Depends On:
  Show dependency treegraph
Reported: 2000-07-12 13:28 EDT by Richard D. Payne
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-10-05 17:43:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Richard D. Payne 2000-07-12 13:28:55 EDT
Using the kernel from the Beta3 CDs and the ramdisk image from:
the installer is unable to use the CD-ROM as the install media. The TUI
console reports "Unable to find  Red Hat CDROM", vc3 prints:

trying to mount device hda
loopfd is -1
LOOP_SET_FD failed: Bad file descriptor

The ramdisk included with beta3 always fails to find init at boot time,
the use of the one from the update directory.
Comment 1 mchampig 2000-07-14 10:00:46 EDT
Verified on the following platforms:

o Multia
o Mustang
o Corelle
o Monet

Multia and Mustang have NCR*** SCSI controllers and are recognized as DAC960!
Corelle and Monet just give "unrecognized CD-ROM" messages and the above bad
file descriptor message.
Comment 2 Hans de Goede 2000-07-17 16:58:07 EDT
The problem is that the new generic kernel has only sym53c8xx support compiled
in not ncr support, resulting in the following boot messages:
sym53c8xx: PCI bus 0, device 6, function 0
sym53c8xx: not initializing, device not supported
scsi: 0 hosts.
scsi: detected total.

So either the ramdisk should contain an ncr module, or the generic kernel should
include it.

Also please note that this is an very severe bug, without working scsi support
install is impossible since the root fs is on scsi too.

The ncr53c810 is the default scsi controller for a lott of alpha's without it
most wont work. (most alpha's are scsi only)

This goes for atleast multia's and axpci/33 machines.
Comment 3 Hans de Goede 2000-07-17 17:03:17 EDT
I worked around the not having an ncr53c8xx driver by using the kernel from 6.2,
now it does see the CD, but I get the messages described at the top of the bug
report, so it seems this bug should be split:
-cdrom install gives loop_fd=-1 errors (with updated ramdisk from gribble)
-ncr53c8xx driver is missign causing trouble on quite a lot of alpha's
Comment 4 Richard D. Payne 2000-07-17 17:07:45 EDT
Please note that the NCR problem is not the problem that I reported. The CD
install is
broken regardless of what the CD-ROM is connected to. For example I am using
Comment 5 Hans de Goede 2000-07-17 17:16:39 EDT
As said (maybe we both submitted after each other? ) this bug should be split,
there are really 2 bugs. I got confused by the messages of mchampig@110.net who
talked about having NCR controllers. I guess he should have openend a new bug.

AS soon as all my i386's are installed (need hd space can't export CD's anymore
with the dual CD setup, this needs fixing, GRRR) I'll try todo a network
Comment 6 Michael Fulbright 2000-07-27 14:44:36 EDT
Is this still an issue with beta 5?
Comment 7 Hans de Goede 2000-07-27 14:59:04 EDT
Ehm platform = alpha = not supported, so yeah this is still a problem, since
beta3 was the last alpha beta afaik.
Comment 8 Richard D. Payne 2000-07-27 15:20:43 EDT
Can't verify the bug as Alpha is no longer supported.
Comment 9 Brock Organ 2000-10-05 17:43:52 EDT
this is a duplicate of 17472 (or is it the other way around ;-) ) ... 

in regards to the issue:

trying to mount device hda
loopfd is -1
LOOP_SET_FD failed: Bad file descriptor

*** This bug has been marked as a duplicate of 17472 ***

Note You need to log in before you can comment on or make changes to this bug.