Bug 1381216 - --nogpgcheck doesn't work properly
Summary: --nogpgcheck doesn't work properly
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf   
(Show other bugs)
Version: rawhide
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Triaged
: 1383768 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-03 12:44 UTC by Igor Gnatenko
Modified: 2016-12-02 15:21 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-02 15:21:34 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Igor Gnatenko 2016-10-03 12:44:34 UTC
[brain@brain ~]$ sudo dnf --nogpgcheck reinstall \* -y
...
warning: /var/cache/dnf/google-talkplugin-dfa34928d410c534/packages/google-talkplugin-5.41.3.0-1.x86_64.rpm: Header V4 DSA/SHA1 Signature, key ID 7fac5991: NOKEY
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Public key for google-talkplugin-5.41.3.0-1.x86_64.rpm is not installed
[brain@brain ~]$ echo $?
130

Comment 1 Igor Gnatenko 2016-10-11 17:57:49 UTC
*** Bug 1383768 has been marked as a duplicate of this bug. ***

Comment 2 Jaroslav Mracek 2016-10-14 11:12:42 UTC
Please can you provide repo information from where the package was installed or reinstalled. Also dnf.conf would be pretty handy.

Comment 3 Igor Gnatenko 2016-10-14 11:28:25 UTC
(In reply to Jaroslav Mracek from comment #2)
> Please can you provide repo information from where the package was installed
> or reinstalled.
[google-talkplugin]
name=google-talkplugin
baseurl=http://dl.google.com/linux/talkplugin/rpm/stable/x86_64
enabled=1
gpgcheck=1
> Also dnf.conf would be pretty handy.
it's default one.

Comment 4 Jaroslav Mracek 2016-10-14 13:48:35 UTC
Here is the PR that should fix the problem: 
https://github.com/rpm-software-management/dnf/pull/634

Comment 5 Łukasz Posadowski 2016-10-26 19:30:40 UTC
Thanks. I have the same problem in Rawhide. Either --nogpgcheck and gpgcheck=0 doesn't work.

Comment 6 Łukasz Posadowski 2016-11-17 04:52:59 UTC
I see that it has been fixed on github, but version in the repo is still not working.


Note You need to log in before you can comment on or make changes to this bug.