Bug 138128 - Belkin USB to Serial Adapter does not work correctly
Belkin USB to Serial Adapter does not work correctly
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2004-11-04 16:03 EST by David Kaplan
Modified: 2015-01-04 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-04-16 01:52:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description David Kaplan 2004-11-04 16:03:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)

Description of problem:
I have been using a USB-Serial adapter to connect my computer to a
palm pilot.  Recently I switched adapters to a Belkin USB to Serial
adapter and have been unable to connect to my palm pilot.  I am fairly
certain it is a problem with the driver as the configuration worked
previously with another adapter (i.e. it is the only thing that has
changed).  I have tried all the obvious tests and am willing to debug
the problem if someone can explain to me how I do that.

The kernel recognizes the adapter when it is inserted, loads the
mct_u232 driver (even though there is a belkin_sa driver which would
be the obvious choice) and puts the adapter on ttyUSB0.  

# dmesg
usb 2-1: new full speed USB device using address 3
mct_u232 2-1:1.0: Magic Control Technology USB-RS232 converter detected
usb 2-1: Magic Control Technology USB-RS232 converter now attached to

# lsusb
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 003: ID 050d:0109 Belkin Components F5U109 PDA Adapter
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 005: ID 046d:c00e Logitech, Inc. Optical Mouse
Bus 001 Device 004: ID 0518:0001 EzKEY Corp.
Bus 001 Device 003: ID 0409:0058 NEC Corp. HighSpeed Hub
Bus 001 Device 001: ID 0000:0000

# more /proc/bus/usb/devices
T:  Bus=02 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  3 Spd=12  MxCh= 0
D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=16 #Cfgs=  1
P:  Vendor=050d ProdID=0109 Rev= 1.02
S:  Manufacturer=Belkin USB PDA Adapter
S:  Product=Belkin Components
S:  SerialNumber=271806
C:* #Ifs= 1 Cfg#= 1 Atr=a0 MxPwr=100mA
I:  If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=mct_u232
E:  Ad=81(I) Atr=03(Int.) MxPS=   2 Ivl=2ms
E:  Ad=82(I) Atr=03(Int.) MxPS=  64 Ivl=1ms
E:  Ad=02(O) Atr=02(Bulk) MxPS=  16 Ivl=0ms

When I try to sync with my palm pilot, the LEDs indicate that there is
communication from the palm pilot, but not from the computer.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.insert the Belkin USB-Serial adapter
2.try to sync with palm pilot

Actual Results:  Nothing happens

Expected Results:  gpilot should recognize the sync operation and
synchronize with palm pilot.

Additional info:

Willing to debug if someone can give me some suggestions.
Comment 1 David Kaplan 2004-11-05 14:47:06 EST
Well, I have figured out how to make it work, but there is definitely
a bug somewhere, just not sure where. First I had to drop the baud
rate down to a maximum of 38400. Second, I have to first use
pilot-xfer to make contact before attempting to use gpilot to
synchronize and then I need to try gpilot twice to actually get it to
work.  It is strange that pilot-xfer should work and gpilot not since
I thought gpilot was a child of pilot-xfer.

So, the steps are:

1) Set baud rate to 38400
2) run "pilot-xfer --list"
3) open gpilot and try to synch. This appears to always fail.
4) Try synch again. This should work.

Strange, but not sure where the bug lies.

Comment 2 David Kaplan 2004-11-12 20:37:32 EST
I have also noticed the following error sometimes occur when this
device is inserted, particularly when it is connected to a USB hub:

drivers/usb/serial/mct_u232.c: usb_submit_urb(read bulk) failed
Comment 3 Dave Jones 2005-04-16 01:52:22 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.