Bug 1381333 - Overcloud ceph deployment fails because of missing "ceph" package not in downstream Red Hat repo
Summary: Overcloud ceph deployment fails because of missing "ceph" package not in down...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-ceph
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: 10.0 (Newton)
Assignee: Giulio Fidente
QA Contact: Yogev Rabl
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-03 17:57 UTC by John Fulton
Modified: 2017-07-06 02:42 UTC (History)
11 users (show)

Fixed In Version: puppet-ceph-2.2.1-1.el7ost openstack-tripleo-heat-templates-5.0.0-0.20161008015357.0d3e3e3.1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 16:07:12 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 382131 None None None 2016-10-05 04:10:44 UTC
OpenStack gerrit 383614 None None None 2016-10-07 10:10:49 UTC
Launchpad 1630468 None None None 2016-10-05 13:00:52 UTC

Description John Fulton 2016-10-03 17:57:00 UTC
1. Description of problem:

During an overcloud deployment, OSD nodes attempt to run the following command: 

 /usr/bin/yum -d 0 -e 0 -y install ceph

The above fails because the "ceph" metapacakge is not shipped in RHCS 2 and instead "ceph-mon" or "ceph-osd" should be used, which will in turn, pull in the dependencies that "ceph" would have pulled in if upstream. 

2. Version-Release number of selected component (if applicable):
- OSP10 9/30.2 puddle

3. How reproducible:
- Deterministic

4. Steps to Reproduce:
- Deploy an overcloud with Ceph

5. Actual results:

Deployment fails with the following in /var/log/messages of an overcloud node:

os-collect-config[11363]: Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install ceph' returned 1: Error: Nothing to do

6. Expected results:

Deploy succeeds 

7. Additional info:

The following upstream commit in review, which splits the installed packages per role, should fix this when merged and the result is in then repackaged in OSP. 

 https://review.openstack.org/#/c/381228/

Comment 1 Giulio Fidente 2016-10-05 07:53:22 UTC
John, I realized puppet should not attempt a yum install as we fake the yum provider with a custom norpm provider.

Can you paste output from a controller/ceph node of the following two:

# hiera tripleo::packages::enable_upgrade
# hiera tripleo::packages::enable_install

Comment 2 John Fulton 2016-10-05 12:55:23 UTC
Giulio,

Here's that output from a controller/ceph-mon that I was able to deploy after adding the gerrit changes 382132 and 382131. 

[root@overcloud-controller-0 ~]# hiera tripleo::packages::enable_upgrade
false
[root@overcloud-controller-0 ~]# hiera tripleo::packages::enable_install
false
[root@overcloud-controller-0 ~]#

Comment 4 John Fulton 2016-10-10 15:28:55 UTC
As per the upstream bug report [1] this was fixed in the openstack/puppet-ceph 2.2.1 release. However, this fix ALSO requires that tripleo-heat-templates be updated as covered the upstream review [2]. 

Thus, the fixed-in-version flag for this BZ has been updated to: 

  puppet-ceph-2.2.1 openstack-tripleo-heat-templates-5.?-TBD-?

Still need to determine what TBD is in the above. 

[1] https://bugs.launchpad.net/puppet-ceph/+bug/1630468
[2] https://review.openstack.org/#/c/382132

Comment 13 Yogev Rabl 2016-10-26 11:07:54 UTC
Verification passed.

The installation process was successful with the implemented changes

Comment 16 errata-xmlrpc 2016-12-14 16:07:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.