Bug 138134 - gaim chat font does not track GNOME app font correctly
gaim chat font does not track GNOME app font correctly
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gaim (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Warren Togami
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-04 16:31 EST by Dan Williams
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version: gaim-2.0.0-0.11.beta3.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-20 04:32:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Williams 2004-11-04 16:31:44 EST
You have to restart GAIM to get the message font to change after
making a change in GNOME Menu->Preferences->Fonts.  The UI font of
gaim instantly updates, but the message font stays the same until a
restart.
Comment 1 Warren Togami 2005-04-08 22:54:08 EDT
Upstream, is this one thing that will be possible after gaim begins using gconf?
 (I still dislike gconf horribly, but just curious.)
Comment 2 Luke Schierer 2005-04-08 23:02:40 EDT
I'm not actually sure.  I would expect that if there is no font face explicitly
set in tools->preferences->interface->conversations->message text, then it would
update on the second message sent in that conversation.  incoming messages
naturally use whatever font is specified in them. 
Comment 3 Warren Togami 2005-09-04 06:05:11 EDT
After learning more about GNOME's architecture, this functionality is definitely
blocking on gconf support.  Novell has proposed gconf configuration to replace
its current file based configuration, but upstream has resisted the idea for
several good reasons and it remains to be seen if a future version of gaim will
ever support it.
Comment 4 Luke Schierer 2005-09-04 08:24:44 EDT
this isn't just a question of gconf support, it also hinges on how often we
recreate the style used when no
tools->preferences->interface->conversations->message text style is specified. 
if the UI font of gaim is successfully changing, then it stands to reason that
we must not be recreating the send im style as frequently as we check the style
for the UI.  This could potentially be tracked down and changed, as the fact
that the UI changes demonstrates that the pertinent information is in fact in
the ~/.gtkrc-2.0 for us to read.
Comment 5 Warren Togami 2005-09-04 15:33:28 EDT
AFAIK, the way GNOME apps handle application font changes in real-time like Dan
Williams is asking for in this report is attaching a function to the gconf key.
 When that gconf key, that function runs changing the application font.  You are
otherwise correct in everything you stated above.  I see little benefit in
adding gconf support for this reason alone.  If gaim upstream however decides to
add Novell's gconf support for the other reasons, then this would be possible to
implement fairly easily.  But again I see little real benefit in having this
capability.
Comment 6 Ethan Blanton 2005-09-04 23:29:33 EDT
This would be XSettings, not gconf.  Since Gtk+ does handle xsettings, we
probably should as well.
Comment 7 Nicole Dai 2006-09-20 04:32:37 EDT
It was not found in gaim-2.0.0-0.11.beta3.fc6.

Note You need to log in before you can comment on or make changes to this bug.