Bug 138136 - Panel clock doesn't resize on font change
Panel clock doesn't resize on font change
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-04 16:36 EST by Dan Williams
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-27 07:14:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Williams 2004-11-04 16:36:26 EST
When you change the global desktop font size, the font size of the
panel updates, but it does not resize itself accordingly.  Therefore,
the date still shows, but the time is cut off and completely
invisible.  It should either make itself wider to show everything, or
do somethign else that I can't think of.
Comment 1 Dan Williams 2004-11-04 16:36:56 EST
note: I'm using 18-pt fonts.
Comment 2 Mark McLoughlin 2005-04-27 07:14:41 EDT
Seems to be working again now - I've a recollection of fixing it at some point.

(The way it works is that the panel has a heuristic for the minimum size of the
panel - enough to display a line of text with some padding on either side.
Essentially, exactly what's needed for the clock. So, if the clock adds a pixel,
it doesn't work anymore and we have to go back and either fix the clock or the
heuristic. Sigh.)

Note You need to log in before you can comment on or make changes to this bug.