Bug 1381369 - Starting Chromium-Browser creates a black screen
Summary: Starting Chromium-Browser creates a black screen
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: chromium
Version: 24
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-03 21:14 UTC by tibgler
Modified: 2016-11-24 02:20 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-10 03:24:28 UTC


Attachments (Terms of Use)

Description tibgler 2016-10-03 21:14:44 UTC
Description of problem:
When starting the Chromium-Browser on Gnome 3.20 workstation. Chromium opens up with a black empty window. After a few seconds the browser freezes/crashes the whole Gnome Desktop. Forcing to reboot the computer again.


Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Click on the Chromium-Browser shortcut to start the browser.
2. A blank black window opens up.


Actual results:
Crashes the Gnome 3.20 desktop(unless killing the browser within a few seconds) and opens a black empty window.  


Expected results:
Open browser and go to the webpage that the user requests.


Additional info:


* I avoid this for now with this trick: google-chrome --disable-gpu as per the comment section tip.


* This bug might have been fixed and you might need to upload the fix to the Fedora Distro.
This bug is located at: https://bugs.chromium.org/p/chromium/issues/detail?id=602679

Comment 1 Tom "spot" Callaway 2016-10-04 13:39:47 UTC
I need more information here:

* What version of chromium are you running?
* What GPU do you have?
* What driver are you using (e.g. are you using a proprietary driver like the NVIDIA driver)?

I do not see this issue on Fedora 24 x86_64, running on Intel GPU with chromium-53.0.2785.143 (or 116).

Comment 2 tibgler 2016-10-04 18:37:07 UTC
I need more information here:

Hello,

* What version of chromium are you running?

+ I am running chromium version: 53.0.2785.116 64 bit on an AMD processor.


* What GPU do you have?

+ I have a NV44(NVIDIA Corporation NV44 [GeForce 7100 GS] (rev a1) Nvidia graphics card.


* What driver are you using (e.g. are you using a proprietary driver like the NVIDIA driver)?


+ I'm using the default: Open Source X.Org X11 nouveau video driver version: 1.0.12-4.fc24.

Note: This seems to be related to Nvidia Cards(in my opinion). I'm currently still running Chromium under that setting short term fix from: https://bugs.chromium.org/p/chromium/issues/detail?id=602679.

Comment 3 Tom "spot" Callaway 2016-10-05 15:39:23 UTC
Okay, first thing, first. Please update to the latest package in testing (https://bodhi.fedoraproject.org/updates/FEDORA-2016-d61c4f72da) and see if the black screen still happens. Please test with chromium-browser running from a terminal, and send over any logs it generates.

It looks like it could be this bug:
https://bugs.chromium.org/p/chromium/issues/detail?id=573615

I think it is highly likely that this issue is NVIDIA specific, could be something anywhere in that driver stack, from the kernel to X. --disable-gpu is a valid workaround for now, but you really need to open this bug with the chromium upstream so that they can troubleshoot it.

Comment 4 tibgler 2016-10-06 02:39:00 UTC
I have installed those three testing packages and the same result. It seems that Chrome is a very expensive browser. It requires too much to keep it happy and working. Firefox seems to run on this computer, and on machines even in a worse shape. I'm not sure if that is the issue or not. I give up on the browser for now but may try it again at sometime later(it was my default for a few years).

Comment 5 tibgler 2016-10-06 03:07:28 UTC
I have forgotten to add that it would be impossible to get the output in time. That is because the browser crashes the desktop a few seconds into the terminal output.  This is not good for the drive not cleanly unmounting the filesystem every time anyway. If anything changes let me know I'll be watching this bug report.

Comment 6 Fedora Update System 2016-11-07 14:36:05 UTC
chromium-54.0.2840.90-3.fc25 chromium-native_client-54.0.2840.59-1.20161013git090f907.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-35049d9d97

Comment 7 Fedora Update System 2016-11-07 14:36:18 UTC
chromium-54.0.2840.90-3.fc25 chromium-native_client-54.0.2840.59-1.20161013git090f907.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-35049d9d97

Comment 8 Fedora Update System 2016-11-07 14:39:00 UTC
chromium-54.0.2840.90-3.fc24 chromium-native_client-54.0.2840.59-1.20161013git090f907.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-c671aae490

Comment 9 Fedora Update System 2016-11-07 14:39:16 UTC
chromium-54.0.2840.90-3.fc24 chromium-native_client-54.0.2840.59-1.20161013git090f907.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-c671aae490

Comment 10 Fedora Update System 2016-11-07 14:40:13 UTC
chromium-54.0.2840.90-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-012de4c97e

Comment 11 Fedora Update System 2016-11-07 14:40:27 UTC
chromium-54.0.2840.90-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-012de4c97e

Comment 12 Fedora Update System 2016-11-07 14:41:17 UTC
chromium-54.0.2840.90-3.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-2fcbc39837

Comment 13 Fedora Update System 2016-11-07 14:41:30 UTC
chromium-54.0.2840.90-3.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-2fcbc39837

Comment 14 Fedora Update System 2016-11-07 18:21:52 UTC
chromium-54.0.2840.90-3.fc25, chromium-native_client-54.0.2840.59-1.20161013git090f907.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-35049d9d97

Comment 15 Fedora Update System 2016-11-07 23:48:24 UTC
chromium-54.0.2840.90-3.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-2fcbc39837

Comment 16 Fedora Update System 2016-11-08 01:27:15 UTC
chromium-54.0.2840.90-3.fc24, chromium-native_client-54.0.2840.59-1.20161013git090f907.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-c671aae490

Comment 17 Fedora Update System 2016-11-08 01:30:10 UTC
chromium-54.0.2840.90-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-012de4c97e

Comment 18 Fedora Update System 2016-11-10 03:24:28 UTC
chromium-54.0.2840.90-3.fc24, chromium-native_client-54.0.2840.59-1.20161013git090f907.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2016-11-19 07:25:08 UTC
chromium-54.0.2840.90-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2016-11-19 21:03:41 UTC
chromium-54.0.2840.90-3.fc25, chromium-native_client-54.0.2840.59-1.20161013git090f907.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 21 Fedora Update System 2016-11-24 02:20:37 UTC
chromium-54.0.2840.90-3.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.