Bug 138146 - nautilus illegally keeps references to file - umount problems
nautilus illegally keeps references to file - umount problems
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
not applicable
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-04 18:31 EST by Harm Verhagen
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-11 09:30:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harm Verhagen 2004-11-04 18:31:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040811

Description of problem:
When mounting an usb memory card using nautilus, while also using the
nautilus "File Browser" unmounting the usb memory card fails. 
This is caused by nautilus/fam keeping a reference to the directory,
while no nautilis window actually referenses the usb card anymore.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Right-Click <user's> Home on desktop and select "Browse Folder".
This opens a new nautilus window pointing to <users> homedrive. Don't
use this window.
2. Click "Computer" on the desktop. This opens a new nautilus windows
showing most 'mountable' thingyes + "network"
3. In the last window click the usb memory card device. This will
mount the usb card, and open a new nautilus window showing the
contents of your USB memory card.
4. Close the windows from step 2 and 3. Only the "File Browse" window
stays opened. Note how that window did not refer to the usb card in
any way
5. Right-click the USB-card icon on the desktop and select umount.
    

Actual Results:  The umount fails:
"An error occurred. Unable to umount the selected volume. umount:
/mnt/usbreader-SM: device is busy"

fuser shows that "fam" has a reference to the mounted directory

Nautilus causes fam to keep this reference. while this reference
should have been released in step 4).

Expected Results:  umount succeeds, because all the nautilus windows
that accessed the USB card are closed.

Additional info:

Only when the "File Browse" window is closed. Then the umount
succeeds. That makes no sense to the user. That window did not have
anything to do with the USB memory card. 
This especially annoying if the File browse window was opened an hour
ago in a different workspace. You mounted the USB card, edited some
photos. Close everything you can find that might have a reference and
still see the umount fail.....

If the "File Browse" window from step 1) is not opened, there is no
problem.
Comment 1 Alexander Larsson 2005-01-11 09:30:52 EST
I believe this is fixed with gamin etc in FC3.
Comment 2 Harm Verhagen 2005-01-11 16:55:17 EST
confirmed, this is fixed in FC3

Note You need to log in before you can comment on or make changes to this bug.