Bug 1381589 - for RHEL6, rubygem-foreman_scap_client depends on openscap-utils instead of openscap-scanner only
Summary: for RHEL6, rubygem-foreman_scap_client depends on openscap-utils instead of o...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Packaging
Version: 6.2.2
Hardware: All
OS: Linux
high
high vote
Target Milestone: Unspecified
Assignee: Chris Roberts
QA Contact: Peter Ondrejka
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks: 1405510
TreeView+ depends on / blocked
 
Reported: 2016-10-04 13:35 UTC by Tim Speetjens
Modified: 2020-04-15 14:42 UTC (History)
8 users (show)

Fixed In Version: rubygem-foreman_scap_client-0.1.2-2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1405510 (view as bug list)
Environment:
Last Closed: 2017-01-26 10:42:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 17280 0 Normal Closed for RHEL6, rubygem-foreman_scap_client depends on openscap-utils instead of openscap-scanner only 2020-03-20 14:37:58 UTC
Red Hat Product Errata RHBA-2017:0197 0 normal SHIPPED_LIVE Satellite 6.2.7 Async Bug Release 2017-01-26 15:38:38 UTC

Description Tim Speetjens 2016-10-04 13:35:28 UTC
Description of problem:
When Openscap is used on RHEL6 clients, these systems must install rubygem-foreman-scap-client, which depnds on openscap-utils, and also depends indirectly on gdb, often undesirable in production environments.

Version-Release number of selected component (if applicable):
rubygem-foreman_scap_client-0.1.2-1.el6sat

How reproducible:
100%

Steps to Reproduce:
1. yum install rubygem-foreman_openscap_client, on a RHEL6 host
2. Watch gdb being installed as a dependency
3.

Actual results:
gdb and rpmdevtools are indirect dependencies of rubygem-foreman_scap_client

Expected results:
only openscap-scanner package is required

Additional info:
In newer minor releases, the scanner (openscap-scanner) has been separted from the openscap-utils package, and should be used as a dependency instead. This is already the case for the package for RHEL7.

Comment 5 Chris Roberts 2016-11-08 22:03:07 UTC
Rebuilt rpm with non needed dep removed and it worked:

[root@dhcp-10-12-211-103 ~]# ls
anaconda-ks.cfg     rubygem-foreman_scap_client-0.2.0-1.el6.noarch.rpm
[root@dhcp-10-12-211-103 ~]# yum localinstall rubygem-foreman_scap_client-0.2.0-1.el6.noarch.rpm
Loaded plugins: product-id, search-disabled-repos, security, subscription-manager
Setting up Local Package Process
Examining rubygem-foreman_scap_client-0.2.0-1.el6.noarch.rpm: rubygem-foreman_scap_client-0.2.0-1.el6.noarch
Marking rubygem-foreman_scap_client-0.2.0-1.el6.noarch.rpm to be installed
rhel-6-server-optional-rpms                                                                                                                                                                  | 2.0 kB     00:00     
rhel-6-server-rh-common-rpms                                                                                                                                                                 | 2.1 kB     00:00     
rhel-6-server-rhev-agent-rpms                                                                                                                                                                | 2.0 kB     00:00     
rhel-6-server-rpms                                                                                                                                                                           | 2.0 kB     00:00     
rhel-6-server-satellite-tools-6.2-rpms                                                                                                                                                       | 2.1 kB     00:00     
rhel-6-server-supplementary-rpms                                                                                                                                                             | 2.0 kB     00:00     
rhel-server-rhscl-6-rpms                                                                                                                                                                     | 2.0 kB     00:00     
Resolving Dependencies
--> Running transaction check
---> Package rubygem-foreman_scap_client.noarch 0:0.2.0-1.el6 will be installed
--> Processing Dependency: ruby(abi) >= 1.8 for package: rubygem-foreman_scap_client-0.2.0-1.el6.noarch
--> Processing Dependency: /usr/bin/ruby for package: rubygem-foreman_scap_client-0.2.0-1.el6.noarch
--> Processing Dependency: ruby(rubygems) for package: rubygem-foreman_scap_client-0.2.0-1.el6.noarch
--> Running transaction check
---> Package ruby.x86_64 0:1.8.7.374-4.el6_6 will be installed
---> Package ruby-libs.x86_64 0:1.8.7.374-4.el6_6 will be installed
--> Processing Dependency: libreadline.so.5()(64bit) for package: ruby-libs-1.8.7.374-4.el6_6.x86_64
---> Package rubygems.noarch 0:1.3.7-5.el6 will be installed
--> Processing Dependency: ruby-rdoc for package: rubygems-1.3.7-5.el6.noarch
--> Running transaction check
---> Package compat-readline5.x86_64 0:5.2-17.1.el6 will be installed
---> Package ruby-rdoc.x86_64 0:1.8.7.374-4.el6_6 will be installed
--> Processing Dependency: ruby-irb = 1.8.7.374-4.el6_6 for package: ruby-rdoc-1.8.7.374-4.el6_6.x86_64
--> Running transaction check
---> Package ruby-irb.x86_64 0:1.8.7.374-4.el6_6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

====================================================================================================================================================================================================================
 Package                                               Arch                             Version                                     Repository                                                                 Size
====================================================================================================================================================================================================================
Installing:
 rubygem-foreman_scap_client                           noarch                           0.2.0-1.el6                                 /rubygem-foreman_scap_client-0.2.0-1.el6.noarch                            41 k
Installing for dependencies:
 compat-readline5                                      x86_64                           5.2-17.1.el6                                rhel-6-server-rpms                                                        129 k
 ruby                                                  x86_64                           1.8.7.374-4.el6_6                           rhel-6-server-rpms                                                        538 k
 ruby-irb                                              x86_64                           1.8.7.374-4.el6_6                           rhel-6-server-rpms                                                        317 k
 ruby-libs                                             x86_64                           1.8.7.374-4.el6_6                           rhel-6-server-rpms                                                        1.7 M
 ruby-rdoc                                             x86_64                           1.8.7.374-4.el6_6                           rhel-6-server-rpms                                                        381 k
 rubygems                                              noarch                           1.3.7-5.el6                                 rhel-6-server-optional-rpms                                               207 k

Transaction Summary
====================================================================================================================================================================================================================
Install       7 Package(s)

Will submit a PR and move to post once approved.

Comment 6 Chris Roberts 2016-11-08 23:27:54 UTC
Create redmine issue:

http://projects.theforeman.org/issues/17280

Comment 7 Bryan Kearney 2016-11-09 01:06:47 UTC
Upstream bug component is Packaging

Comment 8 Bryan Kearney 2016-11-11 11:06:43 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/17280 has been resolved.

Comment 9 Peter Ondrejka 2017-01-16 16:12:10 UTC
Verified in Sat 6.2.7 snap 1, the dependency on openscap-utils or gdb is no longer present:

===========================================================================
 Package                     Arch   Version            Repository     Size
===========================================================================
Installing:
 rubygem-foreman_scap_client noarch 0.1.2-2.el6sat     sat6-tools     19 k
Installing for dependencies:
 compat-readline5            x86_64 5.2-17.1.el6       beaker-Server 129 k
 openscap                    x86_64 1.2.8-2.el6        beaker-Server 3.9 M
 openscap-scanner            x86_64 1.2.8-2.el6        beaker-Server  45 k
 ruby                        x86_64 1.8.7.374-4.el6_6  beaker-Server 538 k
 ruby-irb                    x86_64 1.8.7.374-4.el6_6  beaker-Server 317 k
 ruby-libs                   x86_64 1.8.7.374-4.el6_6  beaker-Server 1.7 M
 ruby-rdoc                   x86_64 1.8.7.374-4.el6_6  beaker-Server 381 k
 rubygems                    noarch 1.3.7-5.el6        beaker-Server 207 k

Transaction Summary
===========================================================================
Install       9 Package(s)

Comment 11 errata-xmlrpc 2017-01-26 10:42:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0197


Note You need to log in before you can comment on or make changes to this bug.